Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Audio limited to 1 program at a time

  1. #1

    Default Audio limited to 1 program at a time

    I am running openSUSE 10.3, and this has been a problem on this machine since the initial install about a month ago.

    Audio will only work with one application at a time, and once that application has audio, it will hold it until it has been shut down. (Eg, if a video is open but paused, I can't watch youtube with sound, or start music on Amarok.) As soon as the app with audio has been closed, another program is free to take it (and in turn hold it as well.)

    Another, likely related symptom: When clicking on the KMix icon from the task tray, the slider bar for volume, and the mute button, have no effect at all on the sound.

    Any advice on this matter would be greatly appreciated.


    Recommended scripts have been run:

    general pastebin - merritt - post number 1058780

    tsalsa.txt - nopaste.com (beta)

  2. #2

    Default Re: Audio limited to 1 program at a time

    Also:



    uname -a
    Linux kristen-desktop 2.6.22.17-0.1-default #1 SMP 2008/02/10 20:01:04 UTC i686 athlon i386 GNU/Linux

    rpm -qa | grep alsa
    alsa-1.0.14-31.2
    alsa-plugins-1.0.14-41
    alsa-utils-1.0.14-27
    alsa-oss-1.0.14-23

    cat /etc/modprobe.d/sound
    options snd-hda-intel enable=1,1 index=1,0

    # 5Dex.EZvOC6rBsDE:SBx00 Azalia
    alias snd-card-1 snd-hda-intel
    # dP62.ARsxkZ5NWG0:Radeon X1200 Series Audio Controller
    alias snd-card-0 snd-hda-intel

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Audio limited to 1 program at a time

    Quote Originally Posted by Merrittkr View Post
    Audio will only work with one application at a time, and once that application has audio, it will hold it until it has been shut down
    I don't know what will cause this. But looking at your audio configuration, a few things I would recommend are:

    a. install alsa-firmware and reboot. Test your sound I had thought alsa-firmware necessary for an ATI SB, but the fact you have sound suggests maybe it is not.

    b. Try switching IEC958 to OFF (in your mixer) and see if that makes a difference. Switch back ON if it doesn't help.

    c. If a regular user loses sound all together (but root keeps their sound), be prepared to add your regular user to group audio, per this step in the audio troubleshooting guide:
    STEP-6:__How_To_Fix_a_Permissions_Problem

  4. #4

    Default Re: Audio limited to 1 program at a time

    Thanks oldcpu,

    Unfortunately still having no luck. I installed alsa-firmware and rebooted, and I can see no change from that.

    I turned IEC958 to Off, tested sounds, no change. Put it back to On.

    I even went ahead and added myself to the audio group, just in case. No change there either.

    Any other ideas?

  5. #5

    Default Re: Audio limited to 1 program at a time

    Try this thread here seems there's many different chipsets.

    HDA ATI SB / INTEL Sound card problem [SOLUTION!] - Ubuntu Forums

    So as we know ALC883/888

    3stack-dig 3-jack with SPDIF I/O
    6stack-dig 6-jack digital with SPDIF I/O
    3stack-6ch 3-jack 6-channel
    3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
    6stack-dig-demo 6-jack digital for Intel demo board
    acer Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
    acer-aspire Acer Aspire 9810
    medion Medion Laptops
    medion-md2 Medion MD2
    targa-dig Targa/MSI
    targa-2ch-dig Targs/MSI with 2-channel
    laptop-eapd 3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
    lenovo-101e Lenovo 101E
    lenovo-nb0763 Lenovo NB0763
    lenovo-ms7195-dig Lenovo MS7195
    haier-w66 Haier W66
    6stack-hp HP machines with 6stack (Nettle boards)
    3stack-hp HP machines with 3stack (Lucknow, Samba boards)
    auto auto-config reading BIOS (default)

    Now try the correct model or as that link try a few hopefully one will hit home.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  6. #6

    Default Re: Audio limited to 1 program at a time

    FeatherMonkey,

    I tried what you suggested without luck.
    I went through every single option.
    With 2 of the options, I got no sound at all.
    With the rest, I always got sound, though always with this program-captured problem, as well as the KMix master slider still being useless.

    So, two hours later, I'm still stuck. (Rebooting after every change was very time consuming!)

    Any other possiblities here..?


    Oh, by the way, I thought I'd give the error message that Amarok provides when I start it, with another program having audio captured:

    xine was unable to initialize any audio drivers.

  7. #7

    Default Re: Audio limited to 1 program at a time

    Still not having any luck with this problem, anyone else have any idea what's wrong, or what to try?

    Thanks in advance.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Audio limited to 1 program at a time

    Quote Originally Posted by Merrittkr View Post
    Still not having any luck with this problem, anyone else have any idea what's wrong, or what to try?
    Can you advise which amarok and xine versions you have ? Its possible you still have some "crippled for proprietary codec" versions. Please paste here the output of running the following in an xterm/konosole:
    rpm -qa | grep xine
    rpm -q amarok
    rpm -q mad

  9. #9

    Default Re: Audio limited to 1 program at a time

    rpm -qa | grep xine

    libxine1-1.1.12-0.pm.1
    amarok-xine-1.4.9.1-100.pm.1
    xinetd-2.3.14-77



    rpm -q amarok

    amarok-1.4.9.1-100.pm.1



    rpm -q mad

    package mad is not installed

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Audio limited to 1 program at a time

    Quote Originally Posted by Merrittkr View Post
    rpm -qa | grep xine
    libxine1-1.1.12-0.pm.1
    amarok-xine-1.4.9.1-100.pm.1
    xinetd-2.3.14-77

    rpm -q amarok
    amarok-1.4.9.1-100.pm.1

    rpm -q mad

    package mad is not installed
    Please install the application "mad".
    PackMan :: application mad

    How did you install amarok? Did you force your amarok install? Because mad is a dependency of the packman packaged amarok, and it should not be possible to have mad not installed when the packman packaged amarok is installed.

    I recommend you setup up your repositories for openSUSE-10.3 per the guidance here:
    Repositories/10.3 - openSUSE-Community
    and for now install only OSS, Non-OSS, Main Update, and Packman.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •