Results 1 to 4 of 4

Thread: Why would the font smoothing option be greyed out in KDE 3.5

  1. #1

    Default Why would the font smoothing option be greyed out in KDE 3.5

    KDE 3.5, openSUSE 11.0, two LCD monitors on an nVidia video card. Why is font-smoothing disabled? When I go to the font settings, the checkbox for "sub-pixel hinting" is completely greyed out. I can't think of any reason why this should happen and it makes the screen rather unpleasant to look at.

  2. #2

    Default Re: Why would the font smoothing option be greyed out in KDE

    Possible patent issues. Read below for the solution.
    SubpixelHinting - openSUSE-Community

  3. #3
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: Why would the font smoothing option be greyed out in KDE

    Add this to your ~/.fonts.conf file and that box will be ticked.

    Code:
    <match target="font">
             <edit name="rgba" mode="assign"><const>rgb</const></edit>
           </match>
    Change rgb to bgr if you need to use B-G-R subpixel rendering.
    <>---><^>

  4. #4

    Default Re: Why would the font smoothing option be greyed out in KDE

    Okay so the thing is ticked but the antialiasing still looks REALLY bad. Much worse than on Ubuntu. I'm not positive it's actually happening. I'm not sure if this is an openSUSE thing or a KDE thing or what, I'm new to both, but I certainly won't be sticking with them unless I can figure this out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •