Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: My Printer won't detect in Opensuse 11.0

  1. #1

    Default My Printer won't detect in Opensuse 11.0

    My printer detected fine with a ppd file in yast in suse 10.3.
    Now it detects but will not work. I try to select ppd file
    and it says unknown ppd file. If i keep trying it claims to install but won't work. if i try to print a test page in the wizard it says that I'm using a different spooler.
    So far Suse 11.0 is on my hit list. I hate it's guts because i could have left suse 10.3 installed, and now i cannot print.
    i have an hp deskjet 1455.

    Thanks for the help,

    Bill

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: My Printer won't detect in Opensuse 11.0

    Go start menu - applications - system - monitor
    Do you have a HP ico in there
    If not install via Yast
    Then run the HP setup
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Thumbs down Re: My Printer won't detect in Opensuse 11.0

    it's not in system monitor.

    What do you mean I told you it won't set up properly in yast even though it detects.
    How do i run hp setup when the disk that came with the printer is only for windows or mac os?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: My Printer won't detect in Opensuse 11.0

    Go to yast software management
    in search type: hp
    look for the hp drivers
    install

    now look for the HP setup
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Angry Re: My Printer won't detect in Opensuse 11.0

    This is really **** useless.
    That driver was already there.
    And if i leave it in or not i get the same **** results my printer does not work. suse 11 fixed my sound problem but now my flamin printer won't work. is goin back to 10.3 the only solution?
    It keeps saying i'm using a different spooler. suse 10.3 allowed me to specify a ppd file it worked on first try. So far suse 11.0 is nothing but a headache.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,316
    Blog Entries
    15

    Default Re: My Printer won't detect in Opensuse 11.0

    On Mon, 30 Jun 2008 15:06:03 GMT
    bperrotta <bperrotta@no-mx.forums.opensuse.org> wrote:

    >
    > This is really **** useless.
    > That driver was already there.
    > And if i leave it in or not i get the same **** results my printer
    > does not work. suse 11 fixed my sound problem but now my flamin
    > printer won't work. is goin back to 10.3 the only solution?
    > It keeps saying i'm using a different spooler. suse 10.3 allowed me to
    > specify a ppd file it worked on first try. So far suse 11.0 is nothing
    > but a headache.
    >
    >

    Hi
    Take a deep breath :-;
    Have you installed the hpijs rpm? You may also want to install the
    hplip rpm, then as root user run;

    hp-setup

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 19 days 11:39, 0 users, load average: 2.45, 2.65, 2.03
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  7. #7

    Default Re: My Printer won't detect in Opensuse 11.0

    I installed the rpm which directory do i run hp-setup from?

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: My Printer won't detect in Opensuse 11.0

    Quote Originally Posted by bperrotta View Post
    So far Suse 11.0 is on my hit list. I hate it's guts because i could have left suse 10.3 installed, and now i cannot print.
    i have an hp deskjet 1455.
    Was this a clean install, or an update?

    Worst comes to worst, you could take a look at this thread (on a lexmark 3200)
    Lexmark 3200 Driver - openSUSE Forums
    I note the use of an hp deskjet 5740 printer applied that fix, and it worked for them.

    When I update my openSUSE, I always keep a copy of my /etc directory (which has the printer settings) so if it were me that encountered this, I would use my functional printer settings from the previous distribution.

    In fact, if you read the Novell Manual, they recommend you keep a copy of your /etc ....

    Going one step further, if you look at the openSUSE-11.0 installation stickie (that we deliberately posted and tried to put in a prominent location for users to read):
    NEWBIES - Suse-11.0 Pre-installation PLEASE READ - openSUSE Forums

    you will read that I quoted this Novell recommendation of keeping a copy of your /etc settings:
    Hints when updating from 10.x to 11.0

    I don't suppose you saw or followed that recommendation?

  9. #9

    Default Re: My Printer won't detect in Opensuse 11.0

    no because I didn't think about it.
    I had no real important data on the pc
    if i knew i would get this hole in the head i would've though.
    I attempted an update that crashed the os. a repair failed.
    i reinstalled without deleting the data and some 10.3 files were still there.

  10. #10

    Smile Re: My Printer won't detect in Opensuse 11.0

    I figured it out. you have to download a weird self extracting file from hp's website. there is an instructions link that was down earlier, it is up now. run that from the command prompt. This created a ppdfile on my desktop. but i had to add it through cups cause this 11.0 doesn't let you do ppd in yast. after that an hp icon appeared in my system tray. then i typed hp-setup at the command prompt printed a test page and it finally worked.

    Hope i never need to do this again.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •