Results 1 to 7 of 7

Thread: Text looks like fried **** in openSUSE 11.0/KDE 4

  1. #1

    Default Text looks like fried **** in openSUSE 11.0/KDE 4

    Just installed it and the fonts look like they're not being sub-pixel antialiased and the hinting is repulsive. It's painful to try to use it at all. I can't figure out any way to change how it handles fonts, or even any way to change the appearance at all -- where is this hidden away at?

    Thanks.

  2. #2

    Default Re: Text looks like fried **** in openSUSE 11.0/KDE 4

    **** it. Figured it out, enabled sub-pixel antialiasing and hinting, and things may well actually look worse.

    Screw this.
    Last edited by kastorff; 29-Jun-2008 at 21:20. Reason: Edited for language.

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Text looks like fried hell in openSUSE 11.0/KDE 4

    Excalibre wrote:

    >
    > **** it. Figured it out, enabled sub-pixel antialiasing and hinting, and
    > things may well actually look -worse-.
    >
    > Screw this.
    >
    >


    Goodness Mr. Excalibre, you've hardly given anyone a chance to reply... 10
    minutes between posts? Tsk Tsk.

    I too have noticed issues with the fonts in KDE. I've got a solution that
    helps.. or helped me at least.

    On my system, the "calculated" DPI is something like 76 DPI (dots per inch).
    But the pretty fonts are based on 96 DPI, or 120 DPI, so any hinting being
    done doesn't line up with the physical pixels... uh... "fried hell" I believe
    you said.

    You can find out what your system is calculating your current DPI as by
    viewing the Xorg log file located at /var/log/Xorg.0.log

    Users have read permissions, so you should be able to view it easily
    (Konqueror, Kate Kwrite, nano, pico, vim, emacs, even openOffice will read
    it)

    Search for a line with the phrase "DPI set to" in it. It varies where in the
    file, mine shows up around line 400 or so, a friend's system give it on line
    596.

    It'll say something like "DPI set to (81, 108)" (that's my friend's... and
    yes, it's seriously out of whack)

    Ok... to fix:

    Start the KDE Control Center, usually named "Configure Desktop / Personal
    Settings", often found in the 'Favorites' section of the K-menu.

    Select "Appearance & Themes -> Fonts".

    You'll see a drop-down labelled "Force Fonts DPI". It's usually defaulted
    to 'disabled'. See if setting it to 96 DPI helps.

    Yes, you'll have to restart any applications you want to see a change in. I
    find it easiest to set the option, "apply" it, then close and reopen the
    Control Center program and return to the Fonts page. You can immediately see
    a change then. You might also try the 120 DPI setting, but unless you've got
    a *really* large monitor, with teeny tiny dot-pitch, it might not help, and
    might make it worse. (worser? )

    Please give that a try. See if it helps.



    There's another change which will help the fonts on Firefox and any other 'QT'
    based program (Google Earth!!)

    in your home directory, look in the '.config' subdir. That's [DOT] config.
    The leading period makes it a hidden subdirectory and it doesn't show up in
    regular 'ls' or 'dir' commands.

    You'll either have to enable 'show hidden files / folders' in Konqueror, or
    just type the path in the address bar yourself.

    In the .config subdir, there's a file 'Trolltech.conf', it has settings within
    it to control the default fonts for QT programs.

    Delete that file.

    run the 'qtconfig' program, choose the 'Fonts' tab, and select a default size
    for QT fonts. It's usually defaulted to 9pt, which is too small for me on
    my monitors (19")... I typically bump it to 11 or 12 point. Then click
    on 'File' (top left), 'Save', and then 'Exit'.

    I can't recommend changing other items in the qtconfig program, I really don't
    know enough about the magic involved to change more things.

    If you were to restart the qtconfig program, you'd see an immediate
    improvement in the fonts. Or restart Firefox, or Google Earth... and so on.

    A thought: you can start the 'qtconfig' program by pressing ALT-F2, then
    typing 'qtconfig' at the prompt. I tend to use the shell (konsole) for most
    things, need to remember to help people to use the KDE GUI system. {Smile}

    Again, hope this helps.

    --
    L R Nix
    lornix@lornix.com

  4. #4

    Default Re: Text looks like fried **** in openSUSE 11.0/KDE 4

    Hi Lornix, I read your post with interest as I am having similar problems as you can read here,

    Is subpixel hinting of fonts disabled in openSuse 11? - openSUSE Forums

    I had already used the force fonts to 96 menu, but when I looked at my dpi in xorg log they are actually 90,91. Is there any way to change that to 96,96 and would it make much difference if I did?

  5. #5
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Text looks like fried **** in openSUSE 11.0/KDE 4

    Dxvid wrote:

    >
    > Hi Lornix, I read your post with interest as I am having similar
    > problems as you can read here,
    >
    > 'Is subpixel hinting of fonts disabled in openSuse 11? - openSUSE
    > Forums' (http://tinyurl.com/5fyfxo)
    >
    > I had already used the force fonts to 96 menu, but when I looked at my
    > dpi in xorg log they are actually 90,91. Is there any way to change
    > that to 96,96 and would it make much difference if I did?
    >
    >


    Don't know. The 'force dpi' sort of fixes the dpi values to what you set.

    Usually, best results are obtained when you use the native resolution of your
    screen. CRT's, being analog in nature, could likely fudge things to get
    better fonts and hinting by adjusting scanline timing to coincide with the
    electron beam masks. LCD's are built with a particular size in mind.

    My monitors are (EDID reported) 410 mm wide. Native resolution is 1440, DPI
    is (#pixels / width), giving me 3.5 px/mm, or 89.2 DPI (3.5 px/mm *
    25.4mm/inch)

    To me, using force DPI to 96, it appears to result in better looking fonts and
    easier reading. Of course, it could be that my vision is failing, my glasses
    are dirty, or I'm an old lady who fondly remembers the teletypes in
    highschool computer classes. (well, not THAT old!)

    I guess my stance is 'dunno'. Try it. Might work for you, might not.

    Loni
    --
    L R Nix
    lornix@lornix.com

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Text looks like fried **** in openSUSE 11.0/KDE 4

    I can't understand this. My fonts are perfectly fine from a default install.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Text looks like fried **** in openSUSE 11.0/KDE 4

    He was most likely using an nVidia card without the patched drivers - they had broken anti-aliasing in them or an unpatched FT library.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •