Results 1 to 7 of 7

Thread: Noob postinstallation issues

  1. #1
    drwarm NNTP User

    Default Noob postinstallation issues

    Hi just installed openSUSE, and having just a few issues, and couldn't find a noobie section on the forums. I downloaded the Live KDE version, and tried installing it along side my already existing Vista.

    1. Can't install the flash player, i downloaded first the .tar files and found i couldn't install it using './' as this command doesn't exist! What package does it come in?
    I then tried installing it with RPM, that seemed to install fine (i ran again and said it was installed) but flash videos still aren't working!!!

    2. openSUSE took over my MBR, I can still boot into Vista fine, but would like that to have control, incase I need to reinstall openSUSE. But all my BCD registry programs (easyBCD, vistaproregistry) all say my BCD is non-existant!!! I even tried putting the Vista dvd at startup, and going repair on the startup, but it said it couldn't (not even with MS's help!!).
    I don't suppose openSUSE makes a backup of it when it overwrites it does it.

    3. my openGL shaders aren't supported. I have a nVidea GeForce 8400M GS, so I would think this would run it.

    Also just a sidenote, when I was installing openSUSE for the first time, after I'd entered the login name etc I wanted to have, at some point later it switched to the terminal/console view and said login, so i started typing my username but it switched back when I'd only put in a few characters. I think this screwed it up and overwrote it, as when I rebooted it wouldn't let me log in!!!

    Thanks for reading, I'm sure I'll have many more issues in the near future!!!

    Reuben

  2. #2
    Join Date
    Jun 2008
    Location
    Babylon 5
    Posts
    18

    Default Re: Noob postinstallation issues

    1. yast2 -i flash-player in a terminal or just use the yast->software management. Make sure you have a 32 bit browser. Click the version tab in software management to check or flash won't work.

    2. I don't use Vista, I don't know.

    3. Did you install nvidia drivers? NVIDIA - openSUSE for 1 click install.

  3. #3
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: Noob postinstallation issues

    1 - Restricted Formats/11.0 - openSUSE-Community

    2 - I imagine that the Vista DVD doesn't see the MBR, so it can't do a repair. Go into a recovery console and run "fixmbr" but that will override grub, and no more Linux. Then you can go to a Linux live CD and do a chroot, and reinstall grub to the mbr. However, I'm not sure any of that is really necessary. You should be able to boot into openSUSE and Vista both right now. I'm not sure what the issue is.

    3 - NVIDIA - openSUSE - One click installer and the reboot.

  4. #4

    Default Re: Noob postinstallation issues

    The Vista bootloader does not support booting Linux. You have to stick with GRUB if you want Linux and Vista to be bootable without an external boot device. For your case, this is a non-issue, since reinstalling opensuse will reinstall GRUB.

  5. #5
    Join Date
    Jun 2008
    Location
    Rotterdam, Port to Europe
    Posts
    207

    Default Re: Noob postinstallation issues

    0. What version of openSuSE did you install ? 32 bits 64 bits ? 10.3 or 11.0 ? And what desktop are you using ? Answering might otherwise be difficult. Still...

    1. What browser are you using ? Konqueror & flash are no problem 32 & 64 bits. Firefox on a 64 bit system is sometimes harder but possible.

    2. Grub
    Either at boot you choose from the menu or let it autostart into either openSuSE or Windows.
    Go to /boot/grub/ and open menu.lst* at the top you will see: "default #" that is the one that is autobooted. Remember Linux starts counting at 0, so 0 is the first option in the list, 1 is the second one etc.

    3. try the one click install for the nVidia drivers, if that fails do it by hand. Download NVIDIA-Linux-x86_64-173.14.05-pkg2.run from the nVidia site and follow the instructions.

    *in a terminal type:
    su
    (password)
    kwrite menu.lst
    (edit it and save)

    If you use Gnome use gedit iso kwrite.
    OpenSuSE Leap 42.3 / KDE 5.8 | Intel i7 3770 | 16GBRam | 120 + 80GB SSD's | Benq 27" | DVD | PhilipsToUcam 740 | HPpsc2355p | Logitech KB & mouse | 320 +160 + 80 + 80 GB USB HDD's | Fritz!Box Fon WLAN 7360 | (V)DSL 12 MB/s | SuSE since 2001

  6. #6
    drwarm NNTP User

    Default Re: Noob postinstallation issues

    Whoa thanks for all the quick replies!!! My installation was a 32bit Intel of the KDE Live.

    Got flash working as well as those codecs, I wish somewhere when I installed it it pointed me to: Welcome to openSUSE-Community.org - openSUSE-Community that was really helpful in getting set up.

    I was following this guide: How to dual-boot Vista with Linux (Vista installed first) -- the step-by-step guide with screenshots
    I wanted to do it that way, because if I remove openSUSE, which deletes grub, what happens then!!?!

    The EasyBCD bootloader has a NeoGrub loader which should let me into openSUSE if I copy in the stuff from menu.lst? The only trouble is EasyBCD won't run because the BCD is missing.

    Go into a recovery console and run "fixmbr" but that will override grub, and no more Linux.
    Is this on vista or linux?

    I think this might all be too hard, so I'll just let Grub be in charge!! Does Grub work ok with Mac OSX cos I was thinking of giving that a try as well.

    Thanks for all the help,
    Reuben

  7. #7
    Join Date
    Jun 2008
    Location
    Rotterdam, Port to Europe
    Posts
    207

    Default Re: Noob postinstallation issues

    I think this might all be too hard, so I'll just let Grub be in charge!!
    That would be best as you know what you want to (autostart) anyway.
    Ex-windows user seem to delete their windows partition on average after 3.5 months so.....
    OpenSuSE Leap 42.3 / KDE 5.8 | Intel i7 3770 | 16GBRam | 120 + 80GB SSD's | Benq 27" | DVD | PhilipsToUcam 740 | HPpsc2355p | Logitech KB & mouse | 320 +160 + 80 + 80 GB USB HDD's | Fritz!Box Fon WLAN 7360 | (V)DSL 12 MB/s | SuSE since 2001

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •