Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: no suspend in Kmenu

  1. #1
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default no suspend in Kmenu

    Hi,
    I installed openSUSE 11.0 with KDE 3.5 on a Thinkpad R50e and on a Thinkpad R61i. Suspend generally works on both machines when I use the keyboard shortcuts or kpowersave. Suspend also works from the login screen. But there's no option to suspend from out of the Kmenu (or startmenu). Any suggestions?

  2. #2

    Default Re: no suspend in Kmenu

    Same Here..

    Google isn't helping out either

  3. #3

    Default Re: no suspend in Kmenu

    is your power-manager plugin for yast also missing
    as root run
    #yast2 -l | grep power
    to find out..

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: no suspend in Kmenu

    supertimorplusfort wrote:

    >
    > Hi,
    > I installed openSUSE 11.0 with KDE 3.5 on a Thinkpad R50e and on a
    > Thinkpad R61i. Suspend generally works on both machines when I use the
    > keyboard shortcuts or kpowersave. Suspend also works from the login
    > screen. But there's no option to suspend from out of the Kmenu (or
    > startmenu). Any suggestions?
    >
    >


    There's an option to select whether the shutdown/sleep/restart menu options
    are present in the Kmenu.

    KDE Control Center (Personal Settings)
    -> System Administration
    -> Login Manager
    --- Click on 'Administrator Mode', give root password
    -> Shutdown Tab

    The "Allow Shutdown" section, Local dropdown selects whether anyone can shut
    the machine down, or only root, or no one at all.

    I set mine to 'Only Root', since they're used as servers and I don't want the
    kids turning things off or rebooting them (they DO that y'know!). The Kmenu
    entries don't appear, and attempting to reboot or shutdown (or sleep) the
    machine cause a root prompt to appear for confirmation.

    If it's set to 'Everybody', then the menu entries are present, and you can
    perform the actions you're talking about, sleep/standby/reboot/shutdown.


    --
    L R Nix
    lornix@lornix.com

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: no suspend in Kmenu

    @ dspoelke: There's no power-manager plugin for yast installed, nor can I find one. there's only gnome-power-manager, but I use KDE 3...

    @lornix: Shutdown is already permitted to everybody as I see in kcontrol. And in fact I can shutdown and reboot from the Kmenu but suspend only shows up in Kpowersave.
    Thanks

  6. #6
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: no suspend in Kmenu

    supertimorplusfort wrote:

    >
    > @ dspoelke: There's no power-manager plugin for yast installed, nor can
    > I find one. there's only gnome-power-manager, but I use KDE 3...
    >
    > @lornix: Shutdown is already permitted to everybody as I see in
    > kcontrol. And in fact I can shutdown and reboot from the Kmenu but
    > suspend only shows up in Kpowersave.
    > Thanks
    >
    >

    Y'know what... I just looked, and neither of my systems have the suspend/sleep
    options in the Kmenu.

    Gosh!

    I'll keep an eye out for anything to do with this.

    Loni
    --
    L R Nix
    lornix@lornix.com

  7. #7
    Join Date
    Jul 2008
    Location
    Ovar, Portugal
    Posts
    7

    Default Re: no suspend in Kmenu

    bouncing against the wall with this also. It may be something related to KDE 3.5 on openSUSE 11.0, as I've installed it before with KDE4 and all the options were available.

  8. #8

    Default Re: no suspend in Kmenu

    I am having this same issue. In the past I was able to resolve it somehow, but can't remember. As stated, it only happens with KDE 3.xx, not with 4.XX.
    The 10 principles to understanding computer basic rules: :: On :: Off


    openSUSE11.0

  9. #9
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: no suspend in Kmenu

    Anyone have a fix for this problem? I'm in the same boat.
    "To err is human... to really foul up requires the root password."

  10. #10
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: no suspend in Kmenu

    Dexter1979 wrote:

    >
    > Anyone have a fix for this problem? I'm in the same boat.
    >
    >


    Try this from a konsole:

    kwriteconfig --file ksmserverrc --group General --key offerShutdown --type
    bool true

    (that's all one line)

    You may need to logout then back in to see the changes.

    Loni


    --
    L R Nix
    lornix@lornix.com

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •