Results 1 to 6 of 6

Thread: Need CUPS Setup Help

  1. #1
    SummerFun NNTP User

    Default Need CUPS Setup Help

    I'm having a configuration problem. On an internal network machine, I upgraded to openSuSE 11.0. I'm trying to get this openSuSE 11.0 machine to print to an openSuSE 10.2 print server on the network by using CUPS. It all used to work so easy in openSuSE 10.2 since there was an option in YAST that said, "Print via CUPS Network Server". SuSE 11.0 now has the option to "Print directly to a Network Printer". When I try Direct TCP Port Printing, I enter the hostname of my SuSE 10.2 machine and keep the default port of 9100. When I click on Test Remote Socket Access button, SuSE 11.0 responds with "Your network is not properly configured or the print server is unknown or unavailable." What am I doing wrong? Did I forget to open up something on my SuSE 11.0 firewall? Thanks in advance for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Need CUPS Setup Help

    SummerFun wrote:

    >
    > I'm having a configuration problem. On an internal network machine, I
    > upgraded to openSuSE 11.0. I'm trying to get this openSuSE 11.0
    > machine to print to an openSuSE 10.2 print server on the network by
    > using CUPS. It all used to work so easy in openSuSE 10.2 since there
    > was an option in YAST that said, "Print via CUPS Network Server". SuSE
    > 11.0 now has the option to "Print directly to a Network Printer". When
    > I try Direct TCP Port Printing, I enter the hostname of my SuSE 10.2
    > machine and keep the default port of 9100. When I click on Test Remote
    > Socket Access button, SuSE 11.0 responds with "Your network is not
    > properly configured or the print server is unknown or unavailable."
    > What am I doing wrong? Did I forget to open up something on my SuSE
    > 11.0 firewall? Thanks in advance for your help.
    >
    >

    CUPS uses port 631, lpd uses port 515, and print servers usually are on port
    9100.

    Try the 'print via cups' on 11.0 system.

    If I remember correctly, OS10.2 was a pain when it came to networking
    printers, the cups server doesn't broadcast properly so the other machines
    don't know there's a printer available on the network. CUPS is nice though,
    with 10.3 and 11.0... it "just works".

    Yes, doesn't fix your problem though, let's see...

    you CAN install the cups-lpd package (yast) on the 10.2 machine and it'll
    enable talking to the printer spooler via port 515. (setup as 'lpd printer')

    Generally, servers (10.2 and up) provide services on 631 (CUPS), with
    occasional support for lpd (515) (if installed/setup). Printer Servers, like
    those built into network printers and many print servers listen on port 9100.

    Hope this helps.


    --
    L R Nix
    lornix@lornix.com

  3. #3
    SummerFun NNTP User

    Default Re: Need CUPS Setup Help

    There was partial success! When I change the port to 631, I at least get a response when I click on the Test Remote Socket Access button. It replies with "The print server is accessible". The bad news is that when I actually send it a print job, nothing prints. The green light doesn't even flash on the printer to acknowledge it's accepting any data being sent to it. Thanks for all your help!



    Regards,
    SummerFun

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Need CUPS Setup Help

    SummerFun wrote:

    >
    > There was partial success! When I change the port to 631, I at least
    > get a response when I click on the Test Remote Socket Access button.
    > It replies with "The print server is accessible". The bad news is that
    > when I actually send it a print job, nothing prints. The green light
    > doesn't even flash on the printer to acknowledge it's accepting any
    > data being sent to it. Thanks for all your help!
    >
    >
    >
    > Regards,
    > SummerFun
    >
    >


    "Print Server is accessible" is a good sign.

    Hmmm, Let me describe how I'm doing it here between two 11.0 systems, and then
    we'll break it down into 11.0 and 10.2 sections:

    Main server: Saturn.
    -- printer hooked up directly
    -- drivers installed, able to print properly.
    -- CUPS server told to broadcast and share printer

    Other machine: Neptune
    -- NO printers defined
    -- CUPS server told to listen for broadcast messages

    With this setup, neptune can print anything, which gets sent to saturn,
    converted to proper output for printer and spooled out for actual printing.

    Saturn is essentially doing all the work really.

    Ok... your setup:

    Main Server: OS 10.2 system (nicknamed 'server')
    -- printer is connected
    -- drivers installed, prints just fine
    -- CUPS driver ... is it sharing/broadcasting?

    Other machine: OS 11.0 (nicknamed 'newmachine')
    -- Should be no printers defined in YaST Printers Module
    -- CUPS server told to listen for broadcasts?


    I've found that 11.0 DOES set CUPS up to listen for broadcasts, although
    sometimes my routers/switches drop the broadcasts (overzealous firewalls?) so
    I usually tell 'newmachine' to listen for 'server's IP address, along
    with '@LOCAL'. Thus:

    in 'CUPS server settings' section: Add two entries, first is IP address
    of 'server', second is '@LOCAL' which says to listen on local subnet.


    Does 'server' (10.2) have an active firewall? if so, is port 631 open? Oops,
    you said it was, the 'check port 631' worked.

    Looking back over what you've said, it appears that 'server' was providing
    printer access previously, so we shouldn't have to adjust anything.

    the CUPS server should have been restarted if you changed any settings
    on 'newmachine 11.0', and 'server's printer should be visible in
    the 'kjobviewer' (Printer) icon on the standard desktop.

    if you select 'Filter' -> Select printer... you should be able to see your
    shared printer from 'server'

    Worst case, you can reboot ({shudder} hate that answer) the 11.0 machine to
    restart everything cleanly.




    --
    L R Nix
    lornix@lornix.com

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: Need CUPS Setup Help

    Hi. For me it works like this:
    1. open ipp client port in firewall
    2. in the Yast printer dialog choose Network Printer > different (?) setup (it reads "Anderes Setup" in my german suse) > URI. Enter ipp://ip.adress.of.server:631/printers/yourprinter and configure it in the next dialogue.

  6. #6

    Default Re: Need CUPS Setup Help

    I often find it easier to just configure the printers via the cups interface (http://localhost:631).

    Anyway, if you are still having problems after trying the above, you might want to check the cups error file on your machine (/var/log/cups/error_log). After I installed 11.0, I tried to add the printer, and actually had a problem that my print server wouldn't accept the file format or something; I had to edit mime.convs and mime.types in /etc/cups.

    Just something to chew on if needed...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •