Results 1 to 4 of 4

Thread: FreeMat

  1. #1
    bitu NNTP User

    Default FreeMat

    I tried to install FreeMat 3.6-1.1 via Yast2 on openSuse 10.3 from the repository without success. The progress bar stays at 0% for some long time and then the window closes unexpected.

    I could install FreeMat from source, but needed a couple of additional libraries to install. To much action for many unexpirienced IT users i.e. mechanical engineers I have to work with. I would prefer an easy one step install by Yast2 and think I speak for many more Suse users.

    I found a repository with a working rpm with FreeMat 3.6 Index of /repositories/home:/dmacvicar/openSUSE_10.3
    May be it might be imported? Who is the mentainer of the official Suse repository?

    There is a math-error in FreeMat 3.6. That has nothing to do with the break of the installation but may be with the version. May be 3.6-1.1 is clean of taht error? Some more motivation to get that version 3.6-1.1 installed.

    Regards

    bitu

  2. #2
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: FreeMat

    Quote Originally Posted by bitu View Post
    I tried to install FreeMat 3.6-1.1 via Yast2 on openSuse 10.3 from the repository without success. The progress bar stays at 0% for some long time and then the window closes unexpected.

    I could install FreeMat from source, but needed a couple of additional libraries to install. To much action for many unexpirienced IT users i.e. mechanical engineers I have to work with. I would prefer an easy one step install by Yast2 and think I speak for many more Suse users.

    I found a repository with a working rpm with FreeMat 3.6 Index of /repositories/home:/dmacvicar/openSUSE_10.3
    May be it might be imported? Who is the mentainer of the official Suse repository?

    There is a math-error in FreeMat 3.6. That has nothing to do with the break of the installation but may be with the version. May be 3.6-1.1 is clean of taht error? Some more motivation to get that version 3.6-1.1 installed.

    Regards

    bitu
    It is not satisfying dependencies. In the header files of an rpm is a section that states what has to be installed to satisfy those dependencies. The easiest way to find them is to:
    Download the rpm
    in a terminal as root
    cd /path to the rpm's folder
    install with "rpm -ihv /packagename"
    and it will list the dependencies.
    those will have to be installed 1st.

    or

    go here: RPM Search
    and search for "FreeMat"
    look for the suse rpm
    click on it like:
    RPM Search FreeMat-3.6-1.1.x86_64.rpm
    then look down @ "Requires" and see a list of packages (dependencies) that need to be previously installed.

    best if you have the yast-sources/repros set up for where ever those packages reside & then Yast will do it for you. If not, it will take forever, as each of those packages may have dependencies too. Best to setup the repros & let Yast do it.

    Evidently, "dmacvicar" is the opensuse packager; he most likely took the source rpm and made it into an openSUSE rpm. Any math function in error would need to go back to the person that built the source. Start here: FreeMat - Home and contact that person.

    Hope that helps
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  3. #3
    bitu NNTP User

    Default Re: FreeMat

    Thank you for your reply.

    Well I tried that with openSUSE 10.3 and 11 as well, but always end up at missing libgfortran.so.2. I also tried to install some different fortran, c/c++ and gcc compilers (64 bit and 32 as well) that include such a libgfortran-library. Now I have a collection of about 20 of such a library in all versions - except that libgfortran.so.2 one! Any search on the net does not deliver a source for that. Seems to be a very rare and precious version?

    Any help possible?

  4. #4

    Default Re: FreeMat

    You just need to use
    osc linkpac home:dmacvicar FreeMat home:bitu
    to create a Freemat package for openSUSE 11.0 in your home repo.
    But doesn't compiles with gcc 4.3... so you would need to patch the compilation errors yourself or search them through upstream SVN.
    If you do so submit the changes to dmacvicar (if you aren't interested in mantaining the package).

    If you are able to compile from source this isn't more difficult... and you end with a RPM in your repo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •