Results 1 to 5 of 5

Thread: Using cifs to mount a drive

  1. #1

    Default Using cifs to mount a drive

    Ok I know this topic comes up a lot in different threads, but I haven't been able to solve the problem for my mount.

    Untill a few days ago used the following command in OS10.1 without any problem:
    mount -t smbfs -o username=***,password=*** //x.x.x.x/network_folder /home/spuser/Desktop/desktop_folder

    Now I've just installed OS11 and found that smbfs is replaced by cifs. I'm using exactly the same mount command but replacing the smbfs by cifs.

    The error I get is:
    mount error 20 = Not a directory
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    I checked and the following are installed:
    cifs-mount
    pam_cifs
    samba
    smb4k
    libsmbclient0
    samba-client
    (+some others)

    I tried mounting to /mnt but that doesn't work either. The network and local folders do exist and I checked the type case.

    What should I try?

    (By the way, if anyone can also quickly tell me how to add a shortcut to my KDE4 desktop that would be great!)

    Thanks

  2. #2
    Join Date
    Jun 2008
    Posts
    22

    Default Re: Using cifs to mount a drive

    Hi spetter0508,

    Had the same problem. Check
    [linux-cifs-client] cifs: mount error 20 = Not a directory, while it works with smbclient

    for a solution that worked for me. The only problem is that I don't know how to automate it so I have do this each time after a reboot.

  3. #3
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Using cifs to mount a drive

    On 06/29/2008 spetter0508 wrote:
    > mount -t smbfs -o username=***,password=*** //x.x.x.x/network_folder
    > /home/spuser/Desktop/desktop_folder


    Please try:
    mount -t cifs //ip.of.server/share /some/local/mountpoint -o username=remoteusername,password=remotepassword

    HTH
    Uwe

  4. #4

    Default Re: Using cifs to mount a drive

    Ok I am able to mount the drive using the same command which I gave at the top of this thread (using cifs), but only if I precede it with:

    modprobe cifs
    echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled

    I tried editing fstab to include the mount command but of course it won't work without the two lines (modprobe.../echo...). I then tried to include these in fstab, but it doesn't seem to react, and my network drives won't mount during boot.

    Any ideas?

  5. #5

    Default Re: Using cifs to mount a drive

    I have this same issue. Does anyone have a small startup script to set this on boot so entries in FSTAB will work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •