Results 1 to 4 of 4

Thread: VNC Hell

  1. #1
    Join Date
    Jun 2008
    Location
    England
    Posts
    15

    Default VNC Hell

    After getting VNC working on openSUSE 10.3 relatively easily, I am struggling to get it working how I want it to on 11. I am using the xinetd method, and am trying to use a password. Here is the appropriate section of /etc/xinetd.d/vnc:
    Code:
    service vnc4
    {
            type            = UNLISTED
            port            = 5904
            socket_type     = stream
            protocol        = tcp
            wait            = yes
            user            = <username>
            server          = /usr/bin/Xvnc
            server_args     = -noreset -inetd -once -query localhost -geometry 1680x1050 -depth 24 passwordFile=/home/<username>/.vnc/passwd
            disable         = no
    }
    When I try to connect from TightVNC on Windows I instantly get a connection closed error. There are no log files in ~/.vnc which are usually created on openSUSE 10.3. If I change the wait to no and remove the passwordFile argument it works, but the session is not persistent, and is not what I want. Unfortunately I did not backup my old /etc/xinetd.d/vnc file from 10.3 so I'm not sure if I've forgotten something.

    The xstartup file in ~/.vnc is the same as I used in 10.3 which worked:
    Code:
    #!/bin/sh
    
    xrdb $HOME/.Xresources
    xsetroot -solid grey
    #xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    startx &
    Can anyone help please?

  2. #2

    Default Re: VNC Hell

    hammettt schrieb:
    > After getting VNC working on openSUSE 10.3 relatively easily, I am
    > struggling to get it working how I want it to on 11. I am using the
    > xinetd method, and am trying to use a password. Here is the appropriate
    > section of /etc/xinetd.d/vnc:
    >
    > Code:
    > --------------------
    > service vnc4
    > {
    > type = UNLISTED
    > port = 5904
    > socket_type = stream
    > protocol = tcp
    > wait = yes
    > user = <username>
    > server = /usr/bin/Xvnc
    > server_args = -noreset -inetd -once -query localhost -geometry 1680x1050 -depth 24 passwordFile=/home/<username>/.vnc/passwd
    > disable = no
    > }
    > --------------------


    yes, it's broken:

    https://bugzilla.novell.com/show_bug.cgi?id=390468

    It works for me at home with -depth 24, so i'm wondering why it's not
    working for you. But i don't use it via xinetd, i have my own init
    script to start it at boottime.

    You can try to start it manually, disable the xinet script and do

    vncserver :4 -depth 24 -geometry 1680x1050

    as user ...

  3. #3

    Default Re: VNC Hell

    I'm not sure whether this applies to you, nor whether you've given up by now, but there was a bug, the fix for which was put into the updates in the last few days.

    If you don't have the updated Xvnc, you can work around the problem by specifying an 8-bit color space (256 colors) in your client before connecting.

  4. #4
    malvcr NNTP User

    Default Re: VNC Hell

    Hi

    Well, I had been fighting with VNC for many days now. Everything was OK on 10.3 but there are strange changes on 11.0.

    For the depth to work OK on Xvnc, you need to use it above of what you expect. If your client uses 16, you need to put 24 and your client will work (don't pay attention to the errors your client present or the ones can find in /var/log ... they push you out of the solution).

    In my case, I have another very very annoying problem. We have a 10.3 machine with many (30-50) Xvnc concurrent sessions and we were trying to update it to 11.0. However, the system isn't capable to go beyond 5 sessions, be them direct connections or http based ones. No mather how many parameters be changed in the xinetd.conf file, the "5" is an absolute limit.

    Somebody have any idea where is the clue? ... I suppose must be some parameter some place, but to be sincere, and after many hours changing everything, I have no idea where could it be.

    Thanks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •