Results 1 to 4 of 4

Thread: ATI 3d problems

  1. #1
    peter_b NNTP User

    Default ATI 3d problems

    i have suse 11 and ati x1950

    works ok about the resolution.

    but i cant work 3d acceleration i try it many times with many guides, from Internet.Is there a way to setup the ati drivers properly to work? Or stop trying with ati anymore.

    its a bad think to have a 512MB card with 3d and dont work never in linux

    if someone can give a solution or help i would like to try it

  2. #2

    Default Re: ATI 3d problems

    Hello,

    I have an AMD x1950 as well. Here is how I got my AMD card working.

    1. Enable the AMD / ATI Community Repository by: Computer > YaST > Software Repositories > Add > Community Repositories > (check) ATI Repository
    2. Install Drivers: Computer > YaST > Software Management > (install) ati-fglrxG01-kmp-default and x11-video-fglrxG01
    3. After they have installed, go to a command prompt / console and type the following:
    "su root" press enter and then enter your password
    "sax2 -r" press enter and then let it do it's thing

    Restart the computer.

    After rebooting to check to see if you have 3D enabled, go to Computer > Control Panel > Graphics Card and Monitor > (make sure Activate 3D Acceleration is checked).
    Go to a command prompt / console and type fglrxinfo, it should say something like this:
    Code:
    display: :0.0  screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1950 Series
    OpenGL version string: 2.1.7537 Release
    Hope this helps, but I hope you dodge the problem that I have been having with my x1950 and the 3D Desktop Effects:
    Choppiness with ATI card and desktop effects - openSUSE Forums

    My 3D works, it is just choppy at the desktop when Desktop Effects are enabled.

  3. #3

    Default Re: ATI 3d problems

    I can report that I have done the install as discussed, and it worked like a charm. I botched it the first time, got the black screen of death. So, I rebooted, started at a console and went through character YAST deleting the installed fglrx components. This got me running again on the Radeon drivers. Then, I loaded the drivers from the ATI repo, ran SAX2, accepted the auto configuration and then rebooted. Works in KDE3 and GNOME, ahve not played with the KDE4 settings yet.

    Andy

  4. #4

    Default Re: ATI 3d problems

    first download the driver at ATI Catalyst 8.6 Proprietary Linux x86 Display Driver

    install the Kernel Header from repository

    then install the driver and run 'aticonfig --initial',
    reboot

    run apps you want

    if you got black screen or hangs(it may or may NOT mean the driver fall to install),check the logs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •