Results 1 to 6 of 6

Thread: Screensave issues

  1. #1
    rassilon NNTP User

    Default Screensave issues

    I have just installed Suse 11 running Gnome, and have been really impressed so far apart from one thing:

    The screensaver X ray swarm hangs the syetem, even in the preview mode under Control Centre -> Screensaver. So now I have it accidentally set as the screensaver, and cannot change it, as when I open the preview screen the system immediately hangs.

    So, is there a way that I can change/alter the screensaver outside of X11, or changing it without using the preview window?

    Any help would be greatly appreciated, as it looks like I will have to re-install otherwise!


    R

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Screensave issues

    rassilon wrote:

    >
    > I have just installed Suse 11 running Gnome, and have been really
    > impressed so far apart from one thing:
    >
    > The screensaver X ray swarm hangs the syetem, even in the preview mode
    > under Control Centre -> Screensaver. So now I have it accidentally set
    > as the screensaver, and cannot change it, as when I open the preview
    > screen the system immediately hangs.
    >
    > So, is there a way that I can change/alter the screensaver outside of
    > X11, or changing it without using the preview window?
    >
    > Any help would be greatly appreciated, as it looks like I will have to
    > re-install otherwise!
    >
    >
    > R
    >
    >


    Edit this file with KWrite or Kate or your favorite editor:

    ..kde/share/config/kdesktoprc

    (There's a leading dot in front of the kde, making .kde a hidden subdir)

    towards the end, there's a section [ScreenSaver], with a line 'Saver=xxxx',
    with 'xxxx' being the name of the offending screen saver. Remove that line
    entirely.

    Save changed file, and when you go to configure the screen saver, it should
    default to none or something.


    --
    L R Nix
    lornix@lornix.com

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Screensave issues

    L R Nix wrote:

    > rassilon wrote:
    >
    >>
    >> I have just installed Suse 11 running Gnome, and have been really
    >> impressed so far apart from one thing:
    >>
    >> The screensaver X ray swarm hangs the syetem, even in the preview mode
    >> under Control Centre -> Screensaver. So now I have it accidentally set
    >> as the screensaver, and cannot change it, as when I open the preview
    >> screen the system immediately hangs.
    >>
    >> So, is there a way that I can change/alter the screensaver outside of
    >> X11, or changing it without using the preview window?
    >>
    >> Any help would be greatly appreciated, as it looks like I will have to
    >> re-install otherwise!
    >>
    >>
    >> R
    >>
    >>

    >
    > Edit this file with KWrite or Kate or your favorite editor:
    >
    > .kde/share/config/kdesktoprc
    >
    > (There's a leading dot in front of the kde, making .kde a hidden subdir)
    >
    > towards the end, there's a section [ScreenSaver], with a line 'Saver=xxxx',
    > with 'xxxx' being the name of the offending screen saver. Remove that line
    > entirely.
    >
    > Save changed file, and when you go to configure the screen saver, it should
    > default to none or something.
    >
    >


    OMG! Blonde Attack!!

    Totally spaced that you said Gnome!! I'm SO sorry.

    Gnome saves it's config data in a small database kinda thing, *sort of* like
    that _other_ OS does. And no, I don't know the exact file to edit to fix
    it...

    You might delete the .gconf and .gconfd subdirectories, log out, then log back
    in. {Sigh} You'll likely lose some configuration settings, desktop wallpaper
    and stuff. My apologies.

    There *IS* a program which can edit the config settings directly, but I can't
    think of it right now and it's use usually confuses me (not that I'm a big
    gnome fan myself, but to each their own, right?)

    --
    L R Nix
    lornix@lornix.com

  4. #4
    rassilon NNTP User

    Default Re: Screensave issues

    Thanks for the reply L R.

    So far I have had no success, and am just getting even more frustrated with it - I can't even go and make a cup of tea without the stupid sreensaver cutting in. And I can't change the idel time, as that requires the preview screen which also causes a hang.

    Looks like no alternative but a full re-install for me.


    R

  5. #5

    Default Re: Screensave issues

    To correct this, first log into your gnome-session and hit Alt+F2, type in 'gconf-editor' (without quotes) and hit Enter. In the application that opens you will see 4 categories on the left pane (apps, desktop, schemas, system). Double click on the apps category, and in the sub-menu that now opens scroll down (if necessary) to locate the entry 'gnome-screensaver' (without quotes) and select it. On the right pane you will see certain entries now. Among this you will see the entry: mode. Double-click on it and in the dialog box that now opens fill in the following for the 'Value' entry:
    blank-only
    Now click on OK.
    This should settle the issue. You could also choose to disable automatic activation of the screensaver for now. To do this clear the check-box next to idle_activation_enabled also on the right pane. You can now start up the normal screensaver settings from the gnome-control panel and select your choice of screensaver (be careful not to choose the one that caused the problem) and enable the 'activate when idle' option.
    Hope that helps.
    By the way you might want to file a bug regarding your problem.

  6. #6
    rassilon NNTP User

    Default Re: Screensave issues

    Thanks Badshah,

    That has worked fine. I have managed to organise a different screensaver now, and also avoided a a new install!

    Cheers,

    R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •