Results 1 to 6 of 6

Thread: xorg.conf file

  1. #1

    Default xorg.conf file

    Hi
    I've been using Suse for about a week now, before Suse i was using mainly debian based distro's
    My problem is with OpenSuse, when i run some games, I get an "out of range" error, some of these games i was able to fix in the config file for that particular game, but some i can't.
    I never had this problem in other distro's, and i think it is because mode "1280x1024" in the xorg.conf file is missing in OpenSuse, and alot of these games default at that resolution.
    I added in "1280x1024" to my xorg.conf file, reboot, and my resolution is messed up even though it says in YAST that my resolution is still 1440x900, which is what it should be.

    Any suggestions??? How do i add the resolution i need into xorg.conf without it messing up my screen, all i want is support for that resolution for my games. Or if anybody has an alternatate solution i'de be happy to hear it?

    heres my xorg.conf file


    # /.../
    # SaX generated X11 config file
    # Created on: 2008-06-29T16:28:56+0800.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "glx"
    Load "type1"
    Load "extmod"
    Load "dbe"
    Load "freetype"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "12"
    Option "Device" "/dev/input/mice"
    Option "Name" "Logitech USB Gaming Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 340 270
    HorizSync 30-83
    Identifier "Monitor[0]"
    ModelName "L1811S (ANALOG)"
    Option "DPMS"
    Option "PreferredMode" "1440x900"
    VendorName "LG"
    VertRefresh 56-75
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "GeForce 7800 GTX"
    BusID "7:0:0"
    Driver "nvidia"
    Identifier "Device[0]"
    Screen 0
    VendorName "NVidia"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection


    thanx
    kaddy
    Last edited by kaddy; 29-Jun-2008 at 04:12. Reason: adding xorg.conf file

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: xorg.conf file

    kaddy wrote:

    >
    > Hi
    > I've been using Suse for about a week now, before Suse i was using
    > mainly debian based distro's
    > My problem is with OpenSuse, when i run some games, I get an "out of
    > range" error, some of these games i was able to fix in the config file
    > for that particular game, but some i can't.
    > I never had this problem in other distro's, and i think it is because
    > mode "1280x1024" in the xorg.conf file is missing in OpenSuse, and alot
    > of these games default at that resolution.
    > I added in "1280x1024" to my xorg.conf file, reboot, and my resolution
    > is messed up even though it says in YAST that my resolution is still
    > 1440x900, which is what it should be.
    >
    > Any suggestions??? How do i add the resolution i need into xorg.conf
    > without it messing up my screen, all i want is support for that
    > resolution for my games. Or if anybody has an alternatate solution i'de
    > be happy to hear it?
    >
    > heres my xorg.conf file
    >
    >
    > # /.../
    > # SaX generated X11 config file
    > # Created on: 2008-06-29T16:28:56+0800.
    > #
    > # Version: 8.1
    > # Contact: Marcus Schaefer <sax@suse.de>, 2005
    > # Contact: SaX-User list
    > <https://lists.berlios.de/mailman/listinfo/sax-users>
    > #
    > # Automatically generated by [ISaX] (8.1)
    > # PLEASE DO NOT EDIT THIS FILE!
    > #
    >
    > Section "Files"
    > FontPath "/usr/share/fonts/misc:unscaled"
    > FontPath "/usr/share/fonts/local"
    > FontPath "/usr/share/fonts/75dpi:unscaled"
    > FontPath "/usr/share/fonts/100dpi:unscaled"
    > FontPath "/usr/share/fonts/Type1"
    > FontPath "/usr/share/fonts/URW"
    > FontPath "/usr/share/fonts/Speedo"
    > FontPath "/usr/share/fonts/PEX"
    > FontPath "/usr/share/fonts/cyrillic"
    > FontPath "/usr/share/fonts/latin2/misc:unscaled"
    > FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    > FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    > FontPath "/usr/share/fonts/latin2/Type1"
    > FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    > FontPath "/usr/share/fonts/baekmuk:unscaled"
    > FontPath "/usr/share/fonts/japanese:unscaled"
    > FontPath "/usr/share/fonts/kwintv"
    > FontPath "/usr/share/fonts/truetype"
    > FontPath "/usr/share/fonts/uni:unscaled"
    > FontPath "/usr/share/fonts/CID"
    > FontPath "/usr/share/fonts/ucs/misc:unscaled"
    > FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    > FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    > FontPath "/usr/share/fonts/hellas/misc:unscaled"
    > FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    > FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    > FontPath "/usr/share/fonts/hellas/Type1"
    > FontPath "/usr/share/fonts/misc/sgi:unscaled"
    > FontPath "/usr/share/fonts/xtest"
    > FontPath "/opt/kde3/share/fonts"
    > InputDevices "/dev/gpmdata"
    > InputDevices "/dev/input/mice"
    > EndSection
    >
    > Section "ServerFlags"
    > Option "AllowMouseOpenFail" "on"
    > Option "ZapWarning" "on"
    > EndSection
    >
    > Section "Module"
    > Load "glx"
    > Load "type1"
    > Load "extmod"
    > Load "dbe"
    > Load "freetype"
    > EndSection
    >
    > Section "InputDevice"
    > Driver "kbd"
    > Identifier "Keyboard[0]"
    > Option "Protocol" "Standard"
    > Option "XkbLayout" "us"
    > Option "XkbModel" "microsoftpro"
    > Option "XkbRules" "xfree86"
    > EndSection
    >
    >
    > Section "InputDevice"
    > Driver "mouse"
    > Identifier "Mouse[1]"
    > Option "Buttons" "12"
    > Option "Device" "/dev/input/mice"
    > Option "Name" "Logitech USB Gaming Mouse"
    > Option "Protocol" "explorerps/2"
    > Option "Vendor" "Sysp"
    > Option "ZAxisMapping" "4 5"
    > EndSection
    >
    >
    > Section "Monitor"
    > Option "CalcAlgorithm" "XServerPool"
    > DisplaySize 340 270
    > HorizSync 30-83
    > Identifier "Monitor[0]"
    > ModelName "L1811S (ANALOG)"
    > Option "DPMS"
    > Option "PreferredMode" "1440x900"
    > VendorName "LG"
    > VertRefresh 56-75
    > UseModes "Modes[0]"
    > EndSection
    >
    >
    > Section "Modes"
    > Identifier "Modes[0]"
    > EndSection
    >
    >
    > Section "Screen"
    > DefaultDepth 24
    > SubSection "Display"
    > Depth 15
    > Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768"
    > "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576"
    > "640x480"
    > EndSubSection
    > SubSection "Display"
    > Depth 16
    > Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768"
    > "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576"
    > "640x480"
    > EndSubSection
    > SubSection "Display"
    > Depth 24
    > Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768"
    > "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576"
    > "640x480"
    > EndSubSection
    > SubSection "Display"
    > Depth 8
    > Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768"
    > "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576"
    > "640x480"
    > EndSubSection
    > Device "Device[0]"
    > Identifier "Screen[0]"
    > Monitor "Monitor[0]"
    > EndSection
    >
    >
    > Section "Device"
    > BoardName "GeForce 7800 GTX"
    > BusID "7:0:0"
    > Driver "nvidia"
    > Identifier "Device[0]"
    > Screen 0
    > VendorName "NVidia"
    > EndSection
    >
    >
    >
    > Section "ServerLayout"
    > Identifier "Layout[all]"
    > InputDevice "Keyboard[0]" "CoreKeyboard"
    > InputDevice "Mouse[1]" "CorePointer"
    > Option "Clone" "off"
    > Option "Xinerama" "off"
    > Screen "Screen[0]"
    > EndSection
    >
    >
    > Section "DRI"
    > Group "video"
    > Mode 0660
    > EndSection
    >
    > Section "Extensions"
    > Option "Composite" "on"
    > EndSection
    >
    >
    > thanx
    > kaddy
    >
    >


    Well, you COULD shoehorn the 1280x1024 into the "Screen" section, maybe right
    before the "1280x800" bit.... put it in all 4 sections (which correspond to
    displaying with 8 bit, 15 bit, 16 bit or 24 bit color). Just don't put it
    FIRST in the line. Last will work though. Might make it easier.

    BUT. (there's *always* a but...)

    Based on your configuration, 1280x1024 is not a native resolution for your
    monitor. If it does display anything, it'll be squished in the vertical
    direction, and you'll lose pixels, since the monitor has to somehow
    interpolate 1024 pixels into the physically present 900 pixels.

    Hey! Haven't I seen you around here before?
    --
    L R Nix
    lornix@lornix.com

  3. #3

    Default Re: xorg.conf file

    lol, ive posted alot today.
    I tried what you suggested the first time, i added "1280x1024" before 1280x800, and i just tried adding it at the end for all 4 screen mode settings, but it still messes my resolution. bugga.

    I remember with ubuntu/linux mint my xorg.conf file had 1280x1024 in it.
    Weird.
    Any other suggestions?

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: xorg.conf file

    kaddy wrote:

    >
    > lol, ive posted alot today.
    > I tried what you suggested the first time, i added "1280x1024" before
    > 1280x800, and i just tried adding it at the end for all 4 screen mode
    > settings, but it still messes my resolution. bugga.
    >
    > I remember with ubuntu/linux mint my xorg.conf file had 1280x1024 in
    > it.
    > Weird.
    > Any other suggestions?
    >
    >


    Well, to be honest... What do you need 1280x1024 for anyways? (rhetorical
    question!) It's a 4:3 ratio screen size, it would certainly distort any
    image displayed on your 16:10 Widescreen display.

    Fullscreen apps work very well for me on my 1440x900. All scaled nice and
    everything!

    I'm not helping huh?

    Really down to inane answers and dumb stuff....

    messed up resolution when you choose 1280x1024? well don't DO that!
    (images of Three Stooges flash in my head when I say that)



    --
    L R Nix
    lornix@lornix.com

  5. #5
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: xorg.conf file

    I have exactly the same monitor, but on an ati card, the repo
    ati 8.49.7 driver gives this in Xorg.0.log


    (--) fglrx(0): Virtual size is 1440x900 (pitch 0)
    (**) fglrx(0): *Mode "1440x900": 106.5 MHz (scaled from 0.0 MHz), 55.9 kHz, 60.0 Hz
    (II) fglrx(0): Modeline "1440x900"x60.0 106.50 1440 1520 1672 1904 900 903 909 934 +vsync (55.9 kHz)
    (**) fglrx(0): *Mode "1400x1050": 121.8 MHz (scaled from 0.0 MHz), 65.3 kHz, 60.0 Hz
    (II) fglrx(0): Modeline "1400x1050"x60.0 121.75 1400 1488 1632 1864 1050 1053 1057 1089 +hsync (65.3 kHz)
    The 8.50.3 driver gives the correct screen size:

    (--) fglrx(0): Virtual size is 1280x1024 (pitch 0)
    (**) fglrx(0): *Mode "1280x1024": 135.0 MHz (scaled from 0.0 MHz), 80.0 kHz, 75.0 Hz
    (II) fglrx(0): Modeline "1280x1024"x75.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 (80.0 kHz)
    A little strange that both Nvidia and ATI gives the same
    error. Though there is a solution that worked for me with
    the repo driver. Goto yast>system>etc sysconfig editor
    continue with
    desktop>display manager>DISPLAYMANAGER_RANDR_MODE_auto
    set the value to 1280x1024_75 which should be fine for
    your display. Now I didn't use a sax generated xorg.conf
    for this, so it's still possible it won't work for you.
    But it's worth a try.

  6. #6
    theothermj NNTP User

    Default Re: xorg.conf file

    I found this link below and it helped. I had to do this just to run the live cd. I changed the directory to 11.1


    Nvidia Installer HOWTO for SUSE LINUX users


    Update your Kernel via YOU (YaST Online Update). Use

    YaST -> Software -> Software Repositories -> Add

    Protocol: HTTP
    Server Name: : download.nvidia.com
    Directory on Server: /opensuse/11.1

    to add the NVIDIA http server as additional installation source.
    Now use

    YaST -> Software -> Software Management

    to install the NVIDIA driver. The appropriate NVIDIA packages will be
    autoselected, if your card is supported. These are either

    x11-video-nvidiaG02...


    Then run "sax2 -r" and it works

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •