Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No desktop cube in openSUSE 11.0?

  1. #1

    Default No desktop cube in openSUSE 11.0?

    I just installed openSUSE 11.0 on my MacBook yesterday and, in general, it's working well.
    However, although I have Desktop Effects activated and the windows are wobbly, the desktop cube doesn't rotate.
    Now, before you ask, I do have Desktop Cube and Rotate Cube checked in CCSM but still it doesn't help.
    My graphics card is an integrated Intel 950 GM.
    Any clues what I might be overlooking?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: No desktop cube in openSUSE 11.0?

    If your'e using KDE 3.5.9 like myself, then open the KDE Control Centre and navigate to Session Manager. Set the Window Manager to 'Compiz'. Click on 'Apply', then restart the desktop. Thats all that should be required.

  3. #3

    Default Re: No desktop cube in openSUSE 11.0?

    Thanks for your reply.
    I'm actually using KDE4 and I cannot find any KDE Control Center on my computer.
    However, I did run "compiz --replace" in a terminal but still no rotating desktop showed up.
    Nevertheless, my wobbly windows became unwobbly, indeed completely unmovable, after this command.
    This suggests that I didn't have compiz as the window manager and that I need to change something in my /etc/X11/xorg.file.
    I'm used to using fusion-icon to select window manager but this doesn't seem to be available in openSUSE 11.0
    There must be a less complicated way to get compiz-fusion working in this distro.
    Any more clues?

  4. #4

    Default Re: No desktop cube in openSUSE 11.0?

    press alt+f2 and type in "systemsettings" without quotes then click on advanced and then session manager

    now change window manager to compiz and log out and back in, now enable effects in CCSM
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  5. #5

    Default Re: No desktop cube in openSUSE 11.0?

    Thanks for that suggestion.
    When I made that change my wobbly windows came back but I still don't have a rotating cube.
    Actually, I'm getting the impression that all is not well with my install as Alt-F2 only occasionally brings up a dialog box and Alt-Ctl-BkSpce doesn't ever restart X.
    I think I'm gonna have to reinstall openSUSE 11.0 as things just don't seem right here even though I got no errors during the install yesterday.
    Unless, of course, anybody has any suggestions as to what might be going wrong here...........?

  6. #6

    Default Re: No desktop cube in openSUSE 11.0?

    did u check the md5sum after downloading? while burning did u burn at low speeds? this should not be happening..........

    after u change settings try logging out and back in and try pressing CTRL+ALT+Backspace twice
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  7. #7

    Default Re: No desktop cube in openSUSE 11.0?

    Quote Originally Posted by snakeeyes View Post
    did u check the md5sum after downloading?
    Yes, I did and it gave no errors
    Quote Originally Posted by snakeeyes View Post
    while burning did u burn at low speeds?
    I burned the DVD at 1x

    Quote Originally Posted by snakeeyes View Post
    this should not be happening..........
    I totally agree but bad things happen to me

    Quote Originally Posted by snakeeyes View Post
    after u change settings try logging out and back in and try pressing CTRL+ALT+Backspace twice
    I tried this as suggested but no improvement. Now neither Alt-F2 nor Alt-Ctl-Bkspce do anything at all.

    At this stage, looks like a re-install is the only option.
    Thanks a lot for your help

  8. #8

    Default Re: No desktop cube in openSUSE 11.0?

    lets see if a re install fixes it
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  9. #9

    Default Re: No desktop cube in openSUSE 11.0?

    Hmmm....well, that didn't work.
    After the re-install there's no improvement. Indeed, it's even worse as I can't get a higher screen resolution than 800x600.
    Maybe it's the KDE4 DE.
    I'll re-install but this time with KDE 3.5
    I mean openSUSE 10.3 worked fine on this machine.

  10. #10

    Default Re: No desktop cube in openSUSE 11.0?

    Well, I tried KDE 3.5 and Gnome 2.22 but still get the same problem which is that <Ctl><Alt><Button1> doesn't rotate the desktop cube.
    Now as Alt-F2 doesn't work either and Ctl-Alt-BkSpce doesn't restart X, maybe the Alt key has a problem.
    So, I changed the binding for the cube rotate to <Ctl><Shift><Button1> and it worked perfectly.
    But <Ctl><Alt><Button1> works fine for me in quite a number of other distros that I have on this same machine.
    So, rather than the Alt key being messed up, it seems as if openSUSE maps the Alt key somewhat strangely (and remember I'm using a MacBook).
    Need to look into this but at least I've got my cube rotating

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •