Results 1 to 9 of 9

Thread: Can ssh only one way

  1. #1

    Default Can ssh only one way

    I am trying to get ssh working on a local network. I have 3 boxes on it XP, pclinux and Opensuse 10.3. I have cygwin installed on the xp. I can ssh the xp and the pclinux from each other. I can ssh the opensuse from the xp and the pclinux. I can not ssh either the xp or the pclinux from the opensuse. I get ssh: connect to host 192.168.1.113 port 22: No route to host when trying to connect to the pclinux. It does nothing when I ssh the xp box. I have tried with and without the firewall on. I am fairly new to Linux and really new to ssh. I appreciate any help.

    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Can ssh only one way

    No route to host means your network setting are incorrect.

    Make sure your default gateway and subnet settings are correct.

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Can ssh only one way

    Possibly your network settings are wrong. What are you using to assign addresses, a home router? What is the output of:

    Code:
    ip addr
    route -n
    cat /etc/resolv.conf

  4. #4

    Default Re: Can ssh only one way

    I they are all set to dhcp from a router. The pclinux is a laptop on wireless.

    ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    2: eth0: <BROADCAST,MULTICAST,NOTRAILERS,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:1d:92:b0:b9:31 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.115/24 brd 192.168.1.255 scope global eth0

    route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
    cat /etc/resolv.conf
    ### BEGIN INFO
    #
    # Modified_by: dhcpcd
    # Backup: /etc/resolv.conf.saved.by.dhcpcd.eth0
    # Process: dhcpcd
    # Process_id: 2990
    # Script: /sbin/modify_resolvconf
    # Saveto:
    # Info: This is a temporary resolv.conf created by service dhcpcd.
    # The previous file has been saved and will be restored later.
    #
    # If you don't like your resolv.conf to be changed, you
    # can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
    # variables are placed in /etc/sysconfig/network/config.
    #
    # You can also configure service dhcpcd not to modify it.
    #
    # If you don't like dhcpcd to change your nameserver
    # settings
    # then either set DHCLIENT_MODIFY_RESOLV_CONF=no
    # in /etc/sysconfig/network/dhcp, or
    # set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
    # /etc/sysconfig/network/config or (manually) use dhcpcd
    # with -R. If you only want to keep your searchlist, set
    # DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
    # (manually) use the -K option.
    #
    ### END INFO
    domain Palmer

    Thanks for the replies
    Last edited by cjck4; 29-Jun-2008 at 06:39. Reason: easier to read

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Can ssh only one way

    Well you don't have a nameserver in /etc/resolv.conf. Either the router didn't send that info, or more likely, you set it up in YaST > Network devices not to use the nameserver that is specified in the DHCP lease. Fix that.

    So you won't be able find a machine by name, but if you ssh to the IP address, it will probably respond.

  6. #6

    Default Re: Can ssh only one way

    I am using ip address to connect.

    ssh username@ip address

    I hit enter and it just sets there not giving me nothing now.

    When I do the same thing from the other boxes to Opensuse it connects right up.

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Can ssh only one way

    Not getting any response means that the server may be blocking incoming traffic on that port. Windows has a firewall, did you open port 22?

    In contrast, if you get no such host, you have a name resolution problem or routing problem. And if you get a reject, the machine is there but not accepting connections. Playing deaf usually means the packets are being blocked.

  8. #8

    Default Re: Can ssh only one way

    Thanks for all of your advice. I think that I might have solved it. I got the pclinux to work which is on wireless. The xp box is on a client bridge router so I think that the router may be stopping it.
    I dont have time to try now but will later. Hope that is the problem.

    thanks

  9. #9

    Default Re: Can ssh only one way

    Solved: port 22 was open on the xp machine but only allowing the pclinux thru.

    Thanks for all the replies

    Cliff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •