Results 1 to 5 of 5

Thread: libcurl so3?

  1. #1

    Default libcurl so3?

    Hi guys, i got a couple of games that won't run and complains that it needs this dependancy.... heres the error....

    ./warsow.i386: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory

    I installed the libcurl from the repository, "libcurl4" and "libcurl-devel"
    but it still complains with this same error.
    I googled for the dependancy but can't find it.
    How can i fix this? Or if i can get pointed in the right direction..
    thanx
    Im using opensuse 11 kde 3.5
    Thanx
    kaddy

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: libcurl so3?

    well, it's looking for libcurl.so.3


    a possible solution is to (as root) create a link from libcurl.so.4 (which you've installed) to libcurl.so.3 (which is an older version)

    - As root, in the /usr/lib subdirectory:

    su - root
    cd /usr/lib
    ln -s libcurl.so.4 libcurl.so.3

    - Then run the 'ldconfig' command to refresh the library indexes

    ldconfig

    - exit out of root

    try your game again.

    This **should** work.

    Lornix

  3. #3

    Default Re: libcurl so3?

    THANKYOU
    the game starts now, although, i get an "out of range" error
    when it starts, i changed my desktop resolution to every other setting there is and started the game to see if i could get into it and change the game resolution to match my lcd so when i change my lcd resolution it would work, but it didn't.....
    thats my next problem :s

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: libcurl so3?

    kaddy wrote:

    >
    > THANKYOU
    > the game starts now, although, i get an "out of range" error
    > when it starts, i changed my desktop resolution to every other setting
    > there is and started the game to see if i could get into it and change
    > the game resolution to match my lcd so when i change my lcd resolution
    > it would work, but it didn't.....
    > thats my next problem :s
    >
    >


    Hmmm, "out of range"... that's usually your monitor complaining about it
    being fed a signal it doesn't know how to handle (wrong dimensions or such)

    Can you specify a command line parameter to start in windowed mode rather
    than full screen?

    I dug around a bit... found the warsow wiki... {chuckle} the question you
    just asked about libcurl3 is discussed here:
    http://www.warsow.net/wiki/index.php...26_openSUSE_11

    Hey! At least I was right!

    Ok, back to the problem...

    Wiki says you can shift between full/windowed by pressing ALT+ENTER ingame.
    Might try that, then select options and choose windowed mode for 'next
    time'.

    OR...... EGADS! It's 184 meg.... ok, this'll take a moment.

    <musak plays quietly in lobby...>

    No, really... still downloading... and I've got a nice pipe to the 'series
    of tubes' too...

    20 seconds!!!

    LOUD! ooooOOOOOoooo! nice!

    Yup, ALT+ENTER works... try that.





    --
    L R Nix
    lornix@lornix.com

  5. #5

    Default Re: libcurl so3?

    i Just found the config files for my games and changed the r_mode "4" to r_mode "8"
    That fixed my resolution problem
    thanx for the help anyways

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •