Results 1 to 7 of 7

Thread: KDE4.0.x progression ? in opensuse11

  1. #1
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Lightbulb KDE4.0.x progression ? in opensuse11

    There seem to be loads of threads with conflicting information about kde4 and it's move toward 4.1.x

    Default updates will not bring 4.1 into suse 11 will it?

    But will, download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/ ?

    From what I can gather if one wants to use 4.1 now with reasonable stability, we should use: download.opensuse.org/repositories/KDE:/KDE4:/Factory:/

    But which of these or any other repo will eventually become the stable for 4.1 ?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  2. #2
    Join Date
    Mar 2008
    Location
    Toronto, Canada
    Posts
    305

    Default Re: KDE4.0.x progression ? in opensuse11

    caf4926 wrote:

    >
    > There seem to be loads of threads with conflicting information about
    > kde4 and it's move toward 4.1.x
    >
    > Default updates will not bring 4.1 into suse 11 will it?
    >
    > But will, download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/ ?
    >
    > From what I can gather if one wants to use 4.1 now with reasonable
    > stability, we should use:
    > download.opensuse.org/repositories/KDE:/KDE4:/Factory:/
    >
    > *But which of these or any other repo will eventually become the stable
    > for 4.1 ?*
    >
    >


    Factory:/ consists of weekly snapshots from KDE 4.1 development. I use it as my daily desktop, and it works well (prefer it to 4.0.x), but "reasonable stability" is the emphasis. It's developmental, so it's inevitable that things will break here and there.

    /STABLE: contains the latest release of KDE 4.0.x. /UNSTABLE is the milestone releases of KDE 4.1.

    Pick your poison... But I don't think you'll see a forced upgrade to 4.1 through openSUSE at this point. There was discussion at one point, but I don't think it will happen.

    I think you'll find that many people use the Factory: snapshots quite satisfactorily, and it gives a good idea of what's to come. But if you're not comfortable with the potential for quirks or breakage, then probably best to stay away from it.

    Cheers,
    KV

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: KDE4.0.x progression ? in opensuse11

    KV,

    Thanks for your clear reply. I have just tried factory of kde4, which I did also yesterday, and again it crashes trying to start plasma. There is a thread here I was in
    Plasma trashed after upgrade to 4.0.84 packages - openSUSE Forums

    There is a policykit package which needs updating but asks for all the following:

    #### YaST2 conflicts list - generated 2008-06-29 06:07:29 ####

    PolicyKit-kde-0.0.svn810196-5.1.x86_64 requires kdebase4-runtime < 4.0.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.0.4-20.1.i586[repo-oss]
    kdebase4-runtime-4.0.4-20.1.x86_64[repo-oss]
    [ ] do not install PolicyKit-kde-0.0.svn810196-5.1.x86_64
    [ ] Following actions will be done:
    downgrade of kdebase4-runtime-4.0.84-1.2.x86_64 to kdebase4-runtime-4.0.4-20.1.i586
    architecture change of kdebase4-runtime-4.0.84-1.2.x86_64 to kdebase4-runtime-4.0.4-20.1.i586
    downgrade of kdebase4-workspace-4.0.84-2.1.x86_64 to kdebase4-workspace-4.0.4-24.2.x86_64
    downgrade of kdegames4-4.0.84-1.2.x86_64 to kdegames4-4.0.4-16.1.x86_64
    downgrade of kdegraphics4-4.0.84-1.2.x86_64 to kdegraphics4-4.0.4-14.1.x86_64
    downgrade of kdemultimedia4-4.0.84-1.2.x86_64 to kdemultimedia4-4.0.4-15.1.x86_64
    downgrade of kdenetwork4-filesharing-4.0.84-1.2.x86_64 to kdenetwork4-filesharing-4.0.4-19.1.x86_64
    downgrade of kdetoys4-4.0.84-1.2.x86_64 to kdetoys4-4.0.4-14.1.x86_64
    downgrade of kdeutils4-4.0.84-1.2.x86_64 to kdeutils4-4.0.4-19.1.x86_64
    downgrade of kdewebdev4-4.0.84-1.3.x86_64 to kdewebdev4-4.0.4-14.1.x86_64
    downgrade of ktorrent-lang-3.1-3.1.x86_64 to ktorrent-lang-3.0.2-22.1.x86_64
    downgrade of ktorrent-3.1-2.5.x86_64 to ktorrent-3.0.2-22.1.x86_64
    downgrade of kde4-knewsticker-4.0.84-1.2.x86_64 to kde4-knewsticker-4.0.4-19.1.x86_64
    downgrade of kde4-superkaramba-4.0.84-1.2.x86_64 to kde4-superkaramba-4.0.4-19.1.x86_64
    downgrade of kde4-kmix-4.0.84-1.2.x86_64 to kde4-kmix-4.0.4-15.1.x86_64
    downgrade of kde4-akregator-4.0.84-1.2.x86_64 to kde4-akregator-4.0.80-9.3.x86_64
    downgrade of kde4-knotes-4.0.84-1.2.x86_64 to kde4-knotes-4.0.80-9.3.x86_64
    downgrade of kde4-kwrite-4.0.84-1.2.x86_64 to kde4-kwrite-4.0.4-18.1.x86_64
    downgrade of kde4-kopete-4.0.84-1.2.x86_64 to kde4-kopete-4.0.4-19.1.x86_64
    downgrade of kde4-kio_sysinfo-11.1-1.4.x86_64 to kde4-kio_sysinfo-11.0-74.2.x86_64
    downgrade of kde4-krfb-4.0.84-1.2.x86_64 to kde4-krfb-4.0.4-19.1.x86_64
    downgrade of kde4-kget-4.0.84-1.2.x86_64 to kde4-kget-4.0.4-19.1.x86_64
    downgrade of kde4-kwin-4.0.84-2.1.x86_64 to kde4-kwin-4.0.4-24.2.x86_64
    downgrade of kde4-kcalc-4.0.84-1.2.x86_64 to kde4-kcalc-4.0.4-19.1.x86_64
    downgrade of kdeartwork4-screensaver-4.0.84-1.2.x86_64 to kdeartwork4-screensaver-4.0.4-14.1.x86_64
    downgrade of kde4-kwalletmanager-4.0.84-1.2.x86_64 to kde4-kwalletmanager-4.0.4-19.1.x86_64
    downgrade of kde4-kshisen-4.0.84-1.2.x86_64 to kde4-kshisen-4.0.4-16.1.x86_64
    downgrade of kde4-konsole-4.0.84-1.2.x86_64 to kde4-konsole-4.0.4-18.1.x86_64
    downgrade of kde4-kcolorchooser-4.0.84-1.2.x86_64 to kde4-kcolorchooser-4.0.4-14.1.x86_64
    downgrade of kde4-okular-4.0.84-1.2.x86_64 to kde4-okular-4.0.4-14.1.x86_64
    downgrade of kde4-kate-4.0.84-1.2.x86_64 to kde4-kate-4.0.4-14.1.x86_64
    downgrade of kde4-konqueror-4.0.84-1.2.x86_64 to kde4-konqueror-4.0.4-18.1.x86_64
    downgrade of kde4-krdc-4.0.84-1.2.x86_64 to kde4-krdc-4.0.4-19.1.x86_64
    downgrade of kde4-dolphin-4.0.84-1.2.x86_64 to kde4-dolphin-4.0.4-18.1.x86_64
    downgrade of kdebase4-4.0.84-1.2.x86_64 to kdebase4-4.0.4-18.1.x86_64
    downgrade of kde4-ksudoku-4.0.84-1.2.x86_64 to kde4-ksudoku-4.0.4-16.1.x86_64
    downgrade of kde4-kfind-4.0.84-1.2.x86_64 to kde4-kfind-4.0.4-18.1.x86_64
    downgrade of kde4-kio_audiocd-4.0.84-1.2.x86_64 to kde4-kio_audiocd-4.0.4-15.1.x86_64
    downgrade of kde4-kmines-4.0.84-1.2.x86_64 to kde4-kmines-4.0.4-16.1.x86_64
    downgrade of kde4-kgamma-4.0.84-1.2.x86_64 to kde4-kgamma-4.0.4-14.1.x86_64
    downgrade of kde4-kgpg-4.0.84-1.2.x86_64 to kde4-kgpg-4.0.4-19.1.x86_64
    downgrade of kde4-kdm-4.0.84-2.1.x86_64 to kde4-kdm-4.0.4-24.2.x86_64
    downgrade of kde4-kscd-4.0.84-1.2.x86_64 to kde4-kscd-4.0.4-15.1.x86_64
    downgrade of kde4-konqueror-plugins-4.0.svn819877-4.3.x86_64 to kde4-konqueror-plugins-4.0.svn767780-72.1.x86_64
    downgrade of kde4-kpat-4.0.84-1.2.x86_64 to kde4-kpat-4.0.4-16.1.x86_64
    downgrade of kde4-kdnssd-4.0.84-1.2.x86_64 to kde4-kdnssd-4.0.4-19.1.x86_64
    downgrade of kde4-kreversi-4.0.84-1.2.x86_64 to kde4-kreversi-4.0.4-16.1.x86_64
    downgrade of kde4-kmahjongg-4.0.84-1.2.x86_64 to kde4-kmahjongg-4.0.4-16.1.x86_64
    downgrade of kde4-ark-4.0.84-1.2.x86_64 to kde4-ark-4.0.4-19.1.x86_64
    downgrade of kde4-keditbookmarks-4.0.84-1.2.x86_64 to kde4-keditbookmarks-4.0.4-18.1.x86_64
    downgrade of kde4-ksnapshot-4.0.84-1.2.x86_64 to kde4-ksnapshot-4.0.4-14.1.x86_64
    downgrade of kde4-kio_kamera-4.0.84-1.2.x86_64 to kde4-kio_kamera-4.0.4-14.1.x86_64
    downgrade of kde4-gwenview-4.0.84-1.2.x86_64 to kde4-gwenview-4.0.4-14.1.x86_64
    downgrade of kdebase4-nsplugin-4.0.84-1.2.x86_64 to kdebase4-nsplugin-4.0.4-18.1.x86_64
    downgrade of libkdegames4-4.0.84-1.2.x86_64 to libkdegames4-4.0.4-16.1.x86_64 [ ] Ignore some dependencies of PolicyKit-kde



    #### YaST2 conflicts list END ###
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Mar 2008
    Location
    Toronto, Canada
    Posts
    305

    Default Re: KDE4.0.x progression ? in opensuse11

    Quote Originally Posted by caf4926 View Post
    There is a policykit package which needs updating but asks for all the following:
    Yeah, I get that too. The fix is to select the "don't install policykit-kde" option. The basic problem is that the KDE 4.0 package for policykit-kde has a newer release-number than the 4.1 package, so Yast automatically selects that one, which forces a downgrade of the KDE 4.1 packages to meet the dependencies. It's a bug that should be addressed soon.

    It's safe to ignore it if you don't need it. If you do need it, then the work around in Yast is to force-select the KDE/Factory version by using the appropriate tab after selecting policykit-kde in the main screen. It's a kludge, but only a corner case unless you need it.

    Hope this helps...

    Cheers,
    KV

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: KDE4.0.x progression ? in opensuse11

    Quote Originally Posted by else_where View Post
    Yeah, I get that too. The fix is to select the "don't install policykit-kde" option. The basic problem is that the KDE 4.0 package for policykit-kde has a newer release-number than the 4.1 package, so Yast automatically selects that one, which forces a downgrade of the KDE 4.1 packages to meet the dependencies. It's a bug that should be addressed soon.

    It's safe to ignore it if you don't need it. If you do need it, then the work around in Yast is to force-select the KDE/Factory version by using the appropriate tab after selecting policykit-kde in the main screen. It's a kludge, but only a corner case unless you need it.

    Hope this helps...

    Cheers,
    KV
    KV,

    Thanks for that advice. I found later yesterday the policy kit installed without complaint. Nevertheless, although I did manage to upgrade to 4.1 using the factory/11 repo's, Plasma just kept crashing - so I had no desktop. The errors were QT related, so maybe I need to update those by adding the QT repo too? Not sure what others are doing here. I had read of others having plasma crash, but they all seem to report it as OK again now. But not for me. At least I have kde3 to fall back on until things stabalize for me.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Mar 2008
    Location
    Toronto, Canada
    Posts
    305

    Default Re: KDE4.0.x progression ? in opensuse11

    caf4926 wrote:

    > I found later yesterday the policy kit
    > installed without complaint.


    Saw that today, too. Looks like they put it properly into /factory:

    > The errors were QT related, so maybe I need to
    > update those by adding the QT repo too? Not sure what others are doing
    > here. I had read of others having plasma crash, but they all seem to
    > report it as OK again now. But not for me. At least I have kde3 to fall
    > back on until things stabalize for me.
    >
    >


    Ugh, I overlooked that. You need to have the KDE4/Qt44 repo enabled as well.

    Hope this helps...

    Cheers,
    KV

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: KDE4.0.x progression ? in opensuse11

    I found re-name of .kde4 to create new one at login made it work, however, as soon as I logout and come back, I end up with a blank pale grey screen, no errors, at least that I can see.
    Have enabled QT repo to see if that helps.

    EDIT:

    No luck with that. I can delete the newly created .kde4, and start again, and first login works, but after that NO.

    Any ideas?
    thanks
    /c
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •