Results 1 to 7 of 7

Thread: building dogtail

  1. #1
    Join Date
    Jun 2008
    Location
    Albuquerque, NM, USA
    Posts
    87

    Default building dogtail

    I'm trying to build dogtail and I need python bonobo and python libglade. Any idea what package provides these?
    It's really that much fun!
    Geeko Samurai (cc)
    My Recent Tracks

  2. #2
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: building dogtail

    What opensuse version are you using?

  3. #3
    Join Date
    Jun 2008
    Location
    Albuquerque, NM, USA
    Posts
    87

    Default Re: building dogtail

    I'm using openSUSE 11.0 on the build service. The project builds fine there is a dependency at runtime to bonobo. Fedora has a separate python libbonobo.
    It's really that much fun!
    Geeko Samurai (cc)
    My Recent Tracks

  4. #4
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: building dogtail

    It looks as if libbonobo is under the normal OSS repo, have you checked to see if it is installed. I don't see a specific python bonobo though. As for libglade if you still need it, seems that is also under the main OSS repo.

  5. #5

    Default Re: building dogtail

    Doing a google search implies it should be in gnome-python ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python/ but I can't find this what I keep finding is gnome-python-desktop. Which doesn't seem to have it looking at gnome-python it seems to include it.

    Both webpin and obs search weren't helping. Webpin

    Might need to do a tar.gz though do find it a little strange that there is gnome-python-desktop perhaps I just keep missing it.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  6. #6
    Join Date
    Jun 2008
    Location
    Albuquerque, NM, USA
    Posts
    87

    Thumbs up Re: building dogtail

    I believe the required libraries are included with the libbonobo and libglade packages. These both can be found in the OSS repository.

    Thanks for your help.
    It's really that much fun!
    Geeko Samurai (cc)
    My Recent Tracks

  7. #7
    Join Date
    Aug 2008
    Posts
    12

    Default Re: building dogtail

    You need to add
    Code:
    Requires:    python-gnome
    to the spec of your package.

    BTW, pin respectively webpin is the tool to solve such questions.

    Philipp

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •