Results 1 to 5 of 5

Thread: Firefox crashes when printing

  1. #1

    Default Firefox crashes when printing

    Hello,

    I'm running 10.2 and notice that Firefox crashes when trying to print web pages. The message reads:

    The application Gecko has crashed.

    However you don't have installed bug-buddy, the
    GNOME crash report tool. If you want to help us
    to make GNOME better, please, install it
    My version of Firefox is the newest available from the repos here on openSuSE, and the whole system is recently updated for that matter. Anyone else having the same problem?

  2. #2

    Default Re: Firefox crashes when printing

    Yeah, it prints fine from Konqueror which I believe uses Mozilla as a web browser. Strange how launching the print dialog causes standalone Firefox to crash

  3. #3
    Join Date
    Jun 2008
    Location
    Reading, UK
    Posts
    45

    Default Re: Firefox crashes when printing

    Konqueror does not use Mozilla. Konqueror uses KHTML as its engine and Mozilla uses Gecko as its engine.

    There was a bug in Firefox 2.0.0.xx which made it crash when you did a print preview although this was fixed later on. What is the exact version number of the Firefox you are using?

    "Help" > "About Mozilla Firefox"

  4. #4

    Default Re: Firefox crashes when printing

    Hi Gumer, thanks for clearing that up. I always assumed Konqueror uses a Mozilla component as its browser. I'm surprised to find out that it doesn't, and it explains why printing works fine in Konqueror.

    In any case, my version of Mozilla Firefox is 3.0-1.1. Do you think I should switch back to 2.0 ?

    Thanks.

    ----------------


    By the way, does anyone know if there's a way to keep track of one's own posts on this forum? Is there a link somewhere that provides a listing of all (or at least some) past entries?

  5. #5
    Join Date
    Jun 2008
    Location
    Reading, UK
    Posts
    45

    Default Re: Firefox crashes when printing

    I don't know, I just wanted to make sure what version of Firefox you had. To my knowledge the bug was fixed during version 2 so it will have been fixed in Firefox 3 too. This means that whatever is causing the bug isn't the same thing as last time. I don't know what to do - sorry I couldn't be more help.

    Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •