Results 1 to 8 of 8

Thread: openSUSE 11 - microphone problem

  1. #1
    a13x NNTP User

    Exclamation openSUSE 11 - microphone problem

    hi,

    my mic is not working on openSUSE 11
    it work in windows and ubuntu
    I already tried a lot of things, without success

    this is my hardware info:
    general pastebin - alex - post number 1057630

    tks

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: openSUSE 11 - microphone problem

    Quote Originally Posted by a13x View Post
    my mic is not working on openSUSE 11. this is my hardware info:
    general pastebin - alex - post number 1057630
    a13x, can you post the contents of:
    cat /etc/modprobe.d/sound

    The idea is to try some of the model options from here:
    general pastebin - stac9221 alsa options - post number 1057656
    but I need that /etc/modprobe.d/sound file contents to provide correct syntax.

    Also, can you paste the URL from the tsalsa script? Its summary of your mixer configuration is much easier to read than that of the alsa-info.sh script. To run the tsalsa script copy and paste this into an xterm/konsole:

    Code:
    su -c 'wget -O tsalsa wget http://home.cfl.rr.com/infofiles/tsalsa && bash tsalsa'
    enter root password when prompted and paste the output URL here.

    you may also wish to give consideration to removing your pulse audio apps.

  3. #3
    a13x NNTP User

    Default Re: openSUSE 11 - microphone problem

    I'm not sure I did everything right
    but is here:
    tsalsa.txt - nopaste.com (beta)

    Code:
    alex@linux-lhn7:~> cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel

    edit:
    maybe this help too
    Code:
    alex@linux-lhn7:~> rpm -qa | grep pulse
    alex@linux-lhn7:~> rpm -qa | grep alsa
    alsa-oss-1.0.15-48.1
    alsa-tools-gui-1.0.16-47.1
    alsa-utils-1.0.16-35.1
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-firmware-1.0.16-24.1
    alsa-tools-1.0.16-47.1
    alex@linux-lhn7:~> rpm -q libasound2
    libasound2-1.0.16-39.1
    alex@linux-lhn7:~> uname -a
    Linux linux-lhn7 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: openSUSE 11 - microphone problem

    Quote Originally Posted by a13x View Post
    I'm not sure I did everything right
    but is here:
    tsalsa.txt - nopaste.com (beta)

    Code:
    alex@linux-lhn7:~> cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    Looking at your mixer I see this:
    Code:
    Amixer contents for card 0 [Intel] _____________________________________        
    amixer set 'Capture',0 Capture 14 100%,Capture 14 100% on        
    amixer set 'Capture',1 Capture 0 0% off Capture 0 0% off        
    amixer set 'Digital',0 Capture 0 0% Capture 0 0%        
    amixer set 'Input Source',0 Items: 'Mic' 'CD' Item0: 'Mic'        
    amixer set 'Input Source',1 Items: 'Mic' 'CD' Item0: 'Mic'        
    amixer set 'Mux',0 Capture 0 0% Capture 0 0%        
    amixer set 'Mux',1 Capture 0 0% Capture 0 0%
    Looks like you have two inputs for a mic. Did you try both? You may wish to move up the "mux" value, which is at 0% now.

    Failing that, you could try an edit to your /etc/modprobe.d/sound file:

    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=3stack

    Save that change, then restart alsa with
    rcalsasound restart
    and test your mic.

  5. #5
    a13x NNTP User

    Default Re: openSUSE 11 - microphone problem

    neither the change in "mux" value
    or the change in /etc/modprobe.d/sound file worked


    there are some thing else I can try?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: openSUSE 11 - microphone problem

    Quote Originally Posted by a13x View Post
    neither the change in "mux" value or the change in /etc/modprobe.d/sound file worked there are some thing else I can try?
    Yes, try a different model option:
    general pastebin - stac9221 alsa options - post number 1057656

  7. #7
    a13x NNTP User

    Thumbs up Re: openSUSE 11 - microphone problem

    I tried all models
    dell-m82 works for me
    thanks oldcpu
    I love you

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: openSUSE 11 - microphone problem

    Quote Originally Posted by a13x View Post
    I tried all models
    dell-m82 works for me
    Wow! Thats great! CONGRATULATIONS !!

    Thanks for sharing your solution.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •