Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: keyboard stops working randomly

  1. #1

    Question keyboard stops working randomly

    hello, i have a huge problem with my opensuse 10.3 laptop.... never had this with 10.2 or below....

    About 0-3 times a day my keyboard on my laptop will stop accepting inputs.
    When this happens, my USB mouse and touchpad still works so I can close programs but i am unable to shutdown the system. When i attempt a shutdown it looks as if X ends but all i get then is a blinking cursor on the top left corner of my screen.
    Also, when i open a konsole window and click the X to close it, it will not close until i press the X a few times and the "terminate program" message appears.

    The only way to shutdown is by holding the power button in until my system turns off.

    it just happened again! i am writing this with xvkbd, one letter at a time..... please help...

  2. #2
    Join Date
    Mar 2008
    Bochum, Germany

    Default Re: keyboard stops working randomly

    * Skylinux Tux,

    this sounds very much like the problems I had with Opensuse 11 and /home being a Reiser partition. If yours is Reiser too and nobody has a less intrusive idea how to fix it, I'd say backup and reformat as ext3.

    As for the shutdown problems:

    The part with "Raising Elephants" at least.
    Note that not all of those keys work by default under Opensuse, you need to enable them in Yast, System, /etc/sysconfig Editor, search for ENABLE_SYSRQ.


  3. #3

    Default Re: keyboard stops working randomly

    Yes I am running reiserfs but I don't think it is the problem here. I have been using reiserfs for years and for the last four years I have also been using it inside my encrypted container which holds /home. openSuse makes encryption so easy, there is no excuse not to use it on a laptop.... anyway, back on topic.

    I did some more tests and I think my problem is caused by my wireless network card which is using the bcm43xx module. I am not sure what the exact model of the card is at the moment since I have the module unloaded but I will update this thread once I know for sure.

    The reason I think it is the card is because I tried to download the torrent of opensuse 11 yesterday, after I posted this plea for help. 10 seconds to 10 minutes after opening ktorrent or azures the keyboard would stop working AND the Internet connection would slow down to a crawl .... talking modem speeds here

    So, this morning I setup my good old Linksys Router into bridge mode with DD-WRT and connected my my laptop via the ethernet cable to my wireless network (realtek chip). I did a rmmod bcm43xx and turned the wireless switch on the back of my laptop to OFF. Since then I have downloaded the complete opensuse 11 download and a few other things without any problems.

    I can not be entirely sure if my issue is completely gone since it has only been 1 day but I am quite certain at this point since it rarely worked for more then a few hours. As I mentioned in my initial post, I did not have this problem with opensuse 10.2. I believe that is the case because I have been using ndiswrapper before 10.3 but since 10.3 made my card work out of the box I never installed ndiswrapper but used the included kernel module instead.

    So I will test this further and will keep the thread updated, then I will do the test with ndiswrapper and see if the problem comes back.
    Unfortunately I am unable to compile madwifi or I could try it with my atheros card...
    Getting this error and can't find a solution
    make[3]: *** No rule to make target `Software/madwifi-svn'. Stop.
    make[2]: *** [Software/madwifi-svn] Error 2
    make[1]: *** [Software/madwifi-svn] Error 2
    make[1]: Leaving directory `/usr/src/linux-'
    make: *** [modules] Error 2

  4. #4

    Default Re: keyboard stops working randomly

    This new forum blowz, first I get kicked out every two minutes now I can't edit a post after 10 minutes....

    EDIT: Wireless card is a: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)

  5. #5
    Join Date
    Jun 2008
    Earth - Denmark

    Default Re: keyboard stops working randomly

    > This new forum blowz, first I get kicked out every two minutes now I
    > can't edit a post after 10 minutes....

    kicked off every two minutes just started saturday, i think we wait for
    a monday-friday person to fix the server..

    as for Reiser and openSuSE 11.0 there IS a *new* the
    applications forum here, a threadtitiled "Is it normal for Suse 11.0 to
    freeze" of the messages says: "installing on reiserfs causes the
    system to freeze randomly"

    i _think_ somewhere someone said it is included in the 11.0 release
    note...but, i can't find that now....maybe i dreamed it..


  6. #6

    Default Re: keyboard stops working randomly

    I had the same problem.
    Just kill beagle and you will be fine.
    It is the worst piece of software ever forced on suse users.
    Four releases of suse, and still it does not work.
    Remove it as firefox plugin, and also go to
    /etc/beagle and edit the various
    craw-applications ... crawl-XXX
    and set
    It is nice to get your computer back by sending beagle to bitrot.

    There is also a lengthy discussion about this problem
    where they try to avoid the obvious:
    It is not a ReiserFS problem, it is a Beagle problem.
    ReiserFS has worked flawlessly for years, while Beagle never worked.

  7. #7
    Join Date
    Jun 2008
    Earth - Denmark

    Default Re: keyboard stops working randomly

    i wonder if you fixed your problem, and how?

    DenverD (Linux Counter 282315)
    A Texan in Denmark

  8. #8

    Default Re: keyboard stops working randomly

    I am expierencing some same sort of problem, i have a Fujitsu Siemens AMilo L1310G Laptop and if i compile madwifi from source and add ath_pci to the modules the keyboard and touchpad stop working (after a reboot) i have this same problem in Suse 10.3. If i Install madwifi with Yast my wifi doesn't seem to work. I haven't been able to get wifi working under SUSE, it worked on Ubuntu though.

  9. #9
    davek_2 NNTP User

    Default Re: keyboard stops working randomly

    I have the keyboard freeze problem as well. Using SuSE 11.0, ext2 (not reiser), no beagle. If I quit X (mouse still works), then I can type again. Maybe it's a KDE4 issue?

  10. #10
    ralesk NNTP User

    Default Re: keyboard stops working randomly

    Sorry for bumping an old post, but I have the same problem with openSUSE 11.0

    It never happened on any other distribution so far, and I tried a few on this computer

    The keyboard is a bog standard PS/2 keyboard plugged into a 32 bit PC. Sometimes it would lock up completely, and I think I have to mouse around while holding a modifier key such as shift down the assumption comes due to the fact that I tried to copy something from Midnight Commander which requires me to press the shift key to come back from application mouse mode.

    To make things worse, virtual keyboards also do not work, so I think the issue is in X. It is also not possible to type anything into the locked up computer using Synergy.

    The only solution is to restart X, which is terribly annoying.

    My X config is standard, with the exception of fglrx being enabled (but fglrx vs. radeon doesnt make a difference). My keyboard layout is custom but it too has worked for the last 4 or so years flawlessly so I doubt its that.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts