Results 1 to 7 of 7

Thread: Need help nvidia driver sax2

  1. #1

    Question Need help nvidia driver sax2

    hey everyone

    i just installed the latest nvidia driver for my geforce fx. after installing it with yast i ran sax2 -r as root which says:

    Code:
    SaX: initializing please wait...
    SaX: your current configuration will not be read in
    
    SaX: access to your display has been granted
    *** buffer overflow detected ***: /usr/sbin/sysp terminated
    ======= Backtrace: =========
    /lib/libc.so.6(__fortify_fail+0x48)[0xb7ad34c8]
    /lib/libc.so.6[0xb7ad1500]
    /lib/libc.so.6[0xb7ad079d]
    /usr/sbin/sysp[0x8081038]
    /usr/sbin/sysp[0x80813e7]
    /usr/sbin/sysp[0x806e416]
    /usr/sbin/sysp[0x8064610]
    /usr/sbin/sysp[0x80506fc]
    /usr/sbin/sysp[0x805117a]
    /lib/libc.so.6(__libc_start_main+0xe5)[0xb7a065f5]
    /usr/sbin/sysp(__gxx_personality_v0+0x121)[0x804ba11]
    ======= Memory map: ========
    08048000-08096000 r-xp 00000000 08:01 762559     /usr/sbin/sysp
    08096000-08097000 r--p 0004d000 08:01 762559     /usr/sbin/sysp
    08097000-08098000 rw-p 0004e000 08:01 762559     /usr/sbin/sysp
    08098000-0858a000 rw-p 08098000 00:00 0          [heap]
    b7808000-b7852000 rw-p b7877000 00:00 0 
    b789b000-b78dc000 rw-p b789b000 00:00 0 
    b78dc000-b791c000 rw-s 00000000 00:09 18120723   /SYSV00000000 (deleted)
    b791c000-b7975000 rw-p b791c000 00:00 0 
    b7975000-b7977000 r-xp 00000000 08:01 591430     /usr/lib/libXau.so.6.0.0
    b7977000-b7978000 r--p 00001000 08:01 591430     /usr/lib/libXau.so.6.0.0
    b7978000-b7979000 rw-p 00002000 08:01 591430     /usr/lib/libXau.so.6.0.0
    b7979000-b797c000 r-xp 00000000 08:01 362637     /lib/libuuid.so.1.2
    b797c000-b797d000 r--p 00002000 08:01 362637     /lib/libuuid.so.1.2
    b797d000-b797e000 rw-p 00003000 08:01 362637     /lib/libuuid.so.1.2
    b797e000-b7986000 r-xp 00000000 08:01 591487     /usr/lib/libXrender.so.1.3.0
    b7986000-b7987000 r--p 00007000 08:01 591487     /usr/lib/libXrender.so.1.3.0
    b7987000-b7988000 rw-p 00008000 08:01 591487     /usr/lib/libXrender.so.1.3.0
    b7988000-b7995000 r-xp 00000000 08:01 591457     /usr/lib/libXext.so.6.4.0
    b7995000-b7996000 r--p 0000c000 08:01 591457     /usr/lib/libXext.so.6.4.0
    b7996000-b7997000 rw-p 0000d000 08:01 591457     /usr/lib/libXext.so.6.4.0
    b7997000-b7999000 r-xp 00000000 08:01 362547     /lib/libdl-2.8.so
    b7999000-b799a000 r--p 00001000 08:01 362547     /lib/libdl-2.8.so
    b799a000-b799b000 rw-p 00002000 08:01 362547     /lib/libdl-2.8.so
    b799b000-b799c000 rw-p b799b000 00:00 0 
    b799c000-b79b3000 r-xp 00000000 08:01 592460     /usr/lib/libxcb.so.1.0.0
    b79b3000-b79b4000 r--p 00016000 08:01 592460     /usr/lib/libxcb.so.1.0.0
    b79b4000-b79b5000 rw-p 00017000 08:01 592460     /usr/lib/libxcb.so.1.0.0
    b79b5000-b79b6000 r-xp 00000000 08:01 592450     /usr/lib/libxcb-xlib.so.0.0.0
    b79b6000-b79b7000 r--p 00000000 08:01 592450     /usr/lib/libxcb-xlib.so.0.0.0
    b79b7000-b79b8000 rw-p 00001000 08:01 592450     /usr/lib/libxcb-xlib.so.0.0.0
    b79b8000-b79ee000 r-xp 00000000 08:01 362542     /lib/libdbus-1.so.3.4.0
    b79ee000-b79ef000 r--p 00035000 08:01 362542     /lib/libdbus-1.so.3.4.0
    b79ef000-b79f0000 rw-p 00036000 08:01 362542     /lib/libdbus-1.so.3.4.0
    b79f0000-b7b2d000 r-xp 00000000 08:01 362529     /lib/libc-2.8.so
    b7b2d000-b7b2f000 r--p 0013d000 08:01 362529     /lib/libc-2.8.so
    b7b2f000-b7b30000 rw-p 0013f000 08:01 362529     /lib/libc-2.8.so
    b7b30000-b7b33000 rw-p b7b30000 00:00 0 
    b7b33000-b7b3f000 r-xp 00000000 08:01 362557     /lib/libgcc_s.so.1
    b7b3f000-b7b40000 r--p 0000b000 08:01 362557     /lib/libgcc_s.so.1
    b7b40000-b7b41000 rw-p 0000c000 08:01 362557     /lib/libgcc_s.so.1
    b7b41000-b7b65000 r-xp 00000000 08:01 362573     /lib/libm-2.8.so
    b7b65000-b7b66000 r--p 00023000 08:01 362573     /lib/libm-2.8.so
    b7b66000-b7b67000 rw-p 00024000 08:01 362573     /lib/libm-2.8.so
    b7b67000-b7b68000 rw-p b7b67000 00:00 0 
    b7b68000-b7b6a000 r-xp 00000000 08:01 591503     /usr/lib/libXxf86misc.so.1.1.0
    b7b6a000-b7b6b000 r--p 00001000 08:01 591503     /usr/lib/libXxf86misc.so.1.1.0
    b7b6b000-b7b6c000 rw-p 00002000 08:01 591503     /usr/lib/libXxf86misc.so.1.1.0
    b7b6c000-b7b7c000 r-xp 00000000 08:01 591954     /usr/lib/libhal.so.1.0.0
    b7b7c000-b7b7d000 r--p 0000f000 08:01 591954     /usr/lib/libhal.so.1.0.0
    b7b7d000-b7b7e000 rw-p 00010000 08:01 591954     /usr/lib/libhal.so.1.0.0
    b7b7e000-b7b84000 r-xp 00000000 08:01 591485     /usr/lib/libXrandr.so.2.1.0
    b7b84000-b7b85000 r--p 00005000 08:01 591485     /usr/lib/libXrandr.so.2.1.0
    b7b85000-b7b86000 rw-p 00006000 08:01 591485     /usr/lib/libXrandr.so.2.1.0
    b7b86000-b7ca3000 r-xp 00000000 08:01 591424     /usr/lib/libX11.so.6.2.0
    b7ca3000-b7ca4000 r--p 0011c000 08:01 591424     /usr/lib/libX11.so.6.2.0
    b7ca4000-b7ca7000 rw-p 0011d000 08:01 591424     /usr/lib/libX11.so.6.2.0
    b7ca7000-b7d8c000 r-xp 00000000 08:01 592303     /usr/lib/libstdc++.so.6.0.10
    b7d8c000-b7d90000 r--p 000e5000 08:01 592303     /usr/lib/libstdc++.so.6.0.10
    b7d90000-b7d91000 rw-p 000e9000 08:01 592303     /usr/lib/libstdc++.so.6.0.10
    b7d91000-b7d97000 rw-p b7d91000 00:00 0 
    b7d97000-b7e4c000 r-xp 00000000 08:01 591956     /usr/lib/libhd.so.14.19
    b7e4c000-b7e4d000 r--p 000b5000 08:01 591956     /usr/lib/libhd.so.14.19
    b7e4d000-b7f4b000 rw-p 000b6000 08:01 591956     /usr/lib/libhd.so.14.19
    b7f4b000-b7f4d000 rw-p b7f4b000 00:00 0 
    b7f62000-b7f63000 rw-p b7f62000 00:00 0 
    b7f63000-b7f7e000 r-xp 00000000 08:01 362506     /lib/ld-2.8.so
    b7f7e000-b7f7f000 r--p 0001a000 08:01 362506     /lib/ld-2.8.so
    b7f7f000-b7f80000 rw-p 0001b000 08:01 362506     /lib/ld-2.8.so
    bfa66000-bfa80000 rw-p bffe6000 00:00 0          [stack]
    ffffe000-fffff000 r-xp 00000000 00:00 0          [vdso]
    Died at /usr/share/sax/init.pl line 653.
    now when i try to run any opengl apps (like mythtv) it says:

    Code:
    NVIDIA OpenGL Driver requires CPUs with SSE to run.
    
    The current CPU does not support SSE.
    and wont start.

    anyone have any suggestions?

    i have SUSE 11.0 and an AMD Duron processor

    Thanks in advance,
    Chris

  2. #2

    Default wrong section

    Sorry i put this in the wrong spot.

    How to i move it?

  3. #3

    Default Re: Need help nvidia driver sax2

    Chris
    Knowing nothing about the vid card, what does 3Ddiag say?

    inhaler

  4. #4

    Default Re: Need help nvidia driver sax2

    Thanks for your reply heres what it said:

    Code:
    # 3Ddiag
    3Ddiag version 0.742
    Verifying 3D configuration:
    Using 3dinfo
    ************************************************************
    
    Verifying 3D configuration for 3D board "nVidia Corporation GeForce FX 5200 (10de@0322)":
    
    
    Verifying driver installation:
      nvidia ... done.
    
    Tests for X.Org configuration:
      Config File /etc/X11/xorg.conf ... done.
      Driver ... done.
      Extensions ... done.
      Options ... done.
    
    
    Checking GL/GLU/glut runtime configuration:
      GL/GLU  ... done (package Mesa)
      glut ... done (package freeglut)

  5. #5

    Default Re: Need help nvidia driver sax2

    I did a google search of NVIDIA OpenGL Driver requires CPUs with SSE to run
    It appears to be a nvidia issue. The only resolution I found was to go back to the previous driver

  6. #6

    Default Re: Need help nvidia driver sax2

    Thanks
    i uninstalled the nvidia driver and now i dont get
    Code:
    NVIDIA OpenGL Driver requires CPUs with SSE to run.
    
    The current CPU does not support SSE.
    but sax2 still wont work. any suggestions.

    chris

  7. #7
    SandorZoo NNTP User

    Default Re: Need help nvidia driver sax2

    NVidia have released beta driver 173.14.15 that supports CPUs without SSE: 173.14.15 (legacy, BETA) for Linux x86/x86-64 released - nV News Forums

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •