Results 1 to 9 of 9

Thread: Compiz

  1. #1
    Join Date
    Jun 2008
    Location
    Greece
    Posts
    56

    Default Compiz

    Hi everyone! I can't use compiz and i was wondering how i could activate it. I use suse 11 but my pc it's not connected on the internet.

  2. #2
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Compiz

    Open the application menu and search for Desktop Effects. When you open the Desktop Effects window, there will be a checkbox on the top-left of the window called Enable desktop effects. Check that and your desktop may lock up for a second while the effects are enabled, and then you can choose the amount of animation you want from the dropdown menu and with all the tabs.

    Folding@Home
    Help save lives with Folding@Home

  3. #3
    Join Date
    Jun 2008
    Location
    Greece
    Posts
    56

    Default Re: Compiz

    I'm not sure but i think that this option is not availiable (i'm not infront of my pc at this moment.). I have not install the driver for my graphics card yet. Could this be the problem??

  4. #4
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Compiz

    Yep, no drivers could definitely cause that.

    Nvidia Drivers | ATI Drivers

    Just install the 1-click installer (it'll walk you through it) and then restart your computer.

    Log back in and open a terminal.

    Login as root (su command) and run sax2 -r

    When Sax2 loads, make sure that Activate 3D Acceleration is checked on the bottom of the window. Once you do that, save the settings. Now you have to restart X-Server: to do this, run nit 3 in a terminal window (NOTE that any unsaved information will be lost and you will not be able to keep Firefox open). While you're in the CLI, login with your username and then enter your password. Lastly, run startx or init 5 (both will do the same function).

    Then do the desktop effects thing.

    Hope that helps.

    Folding@Home
    Help save lives with Folding@Home

  5. #5
    Join Date
    Jun 2008
    Location
    Greece
    Posts
    56

    Default Re: Compiz

    I downloaded this one Linux Display Driver - x86
    I 'll compile the kernel.
    i think it's the right one. Thank you for your help!

  6. #6
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Compiz

    No Problem. Gladto help.

    Folding@Home
    Help save lives with Folding@Home

  7. #7
    Join Date
    Jun 2008
    Location
    Greece
    Posts
    56

    Default Re: Compiz

    I manage to install the nvidia driver and activate the desktop effects but i din't change the window manager to compiz. There are some problem though some effects doesnt work and my system froze 2-3 times and needed to reboot. After i change the windows manager to compiz the desktop effects didn't work at all. Any suggestions?

  8. #8
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Compiz

    Are you sure that when you ran Sax2 that the 3D Acceleration check is checked if it is available. Also, how did you install Compiz, by the way: manual or the 1-click installer?

    Folding@Home
    Help save lives with Folding@Home

  9. #9
    Join Date
    Jun 2008
    Location
    Greece
    Posts
    56

    Default Re: Compiz

    Check the note here Nvidia Installer HOWTO for SUSE LINUX users

    NOTE: There is no need to try to enable 3D support. It's already
    enabled, when the nvidia driver is running.


    But i'll check it. I think that compiz is installed by default on suse 11 so i din't install anything, if you are asking about the nvidia driver i compiled the kernel manually.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •