Results 1 to 5 of 5

Thread: $DISPLAY Not Set at Start

  1. #1
    LWGreen99 NNTP User

    Default $DISPLAY Not Set at Start

    I am running OpenSuse 11.0 and when I start up I go to a console instead of KDE.

    The boot display gives a message that $DISPLAY is not set. How can I set this and what are acceptable values.

    I have run Sax2 after logging in as root at the console.
    I type kdm at the console and then get the login display where I can login as a user. This starts KDE but I have to supply the root password for Konqueror to display. I then receive the KDE GUI.

    I have used YAST to examine /etc/sysconfig and have KDE set as the display.

    When I shut the system down and restart I do not get KDE GUI but go back to console and have to type kdm as per above to get GUI.

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: $DISPLAY Not Set at Start

    When you say 'console'... I assume you're meaning a text shell from tty's 1-6, correct?

    Those consoles (shells) have no idea you've got a gui running anywhere and will not auto-set the DISPLAY variable. I mean, what would they set it to?

    Starting kdm essentially sets up the entire gui system, which then notifies any shells "started from the kdm" that there IS a gui in place and it is found at $DISPLAY.

    Now, if you have a gui already running somewhere, on the same system, or elsewhere... it IS possible to manually set DISPLAY to point to that. There ARE caveats though.

    The X protocol USED to be used only by trusted souls and used port 6000 on a machine to talk to the X-servers and clients. With the advent of script-kiddies, this port is now by-default, closed and you must have a 'key' to talk to the X-server/clients. This is why you had to give the root password to make things work. (although this often doesn't work either)

    See /etc/sysconfig/displaymanager to open port 6000 if you need it. (you'll need to restart your X-server if you change that)

    Starting the gui from a users point-of-view is generally done using the 'startx' command. This will bring up your own 'gui universe', instead of using the kdm command to start the 'global gui' in which you need to log in.

    Take Care,

    Lornix
    lornix@lornix.com

  3. #3
    LWGreen99 NNTP User

    Default Re: $DISPLAY Not Set at Start

    Lornix,

    Thanks for the reply.

    I have not made my problem clear.

    I had an install of OpenSuSE 11.0 which went through startup sequence and took me to the OpenSuSE GUI user login screen. I used YAST and installed various Chinese character sets (in addition to English) and some packages and upgrades to handle the Chinese.

    At the end of this process when I started OpenSuSE I no longer go to a GUI logon screen but get various error messages about $DISPLAY and go to the text shell.

    I am trying to get back to going direct to the login GUI rather than the shell.

    I have gone to YAST, SYSTEM, System Services (Runlevel) and given the Font Server xfs a runlevel of 5. This now gives me a Grey SuSE login screen (Not the SuSE login that Ihad after the upgrade to 11.0) where I first enter my userid and then the input box changes title and asks me to enter my password. When I have done this KDE desktop displays but I get a request asking for the root password to continue running.

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: $DISPLAY Not Set at Start

    LWGreen99 wrote:

    >
    > Lornix,
    >
    > Thanks for the reply.
    >
    > I have not made my problem clear.
    >
    > I had an install of OpenSuSE 11.0 which went through startup sequence
    > and took me to the OpenSuSE GUI user login screen. I used YAST and
    > installed various Chinese character sets (in addition to English) and
    > some packages and upgrades to handle the Chinese.
    >
    > At the end of this process when I started OpenSuSE I no longer go to a
    > GUI logon screen but get various error messages about $DISPLAY and go
    > to the text shell.
    >
    > I am trying to get back to going direct to the login GUI rather than
    > the shell.
    >
    > I have gone to YAST, SYSTEM, System Services (Runlevel) and given the
    > Font Server xfs a runlevel of 5. This now gives me a Grey SuSE login
    > screen (Not the SuSE login that Ihad after the upgrade to 11.0) where I
    > first enter my userid and then the input box changes title and asks me
    > to enter my password. When I have done this KDE desktop displays but I
    > get a request asking for the root password to continue running.
    >
    >


    Hmmm, strange for sure!

    you might delete the .kde, .kde4 subdirs from your home directory and allow
    them to be rebuilt from scratch.

    Otherwise... {shrug} got nothing.

    Ok, reread...

    The gui you get after entering the root password... is it red and got bombs
    on it? or your usual background? Trying to determine who you're logging
    in as... yourself, or root.

    aaaaand we circle back to "delete .kde and .kde4 subdirs in your home
    directory"

    Really sounds like something in your Autostart or saved-session information
    is causing something to be executed that wants root privileges. (too many
    somethings in that sentence!)

    Can you maybe post contents of /var/log/boot.msg ? That would give us the
    error messages to work with...

    --
    L R Nix
    lornix@lornix.com

  5. #5
    LWGreen99 NNTP User

    Default Re: $DISPLAY Not Set at Start

    I am logging in as myself -- No Red Background or bombs.

    I have deleted .kde and .kde4 but still get the grey logon screen.

    I have removed Runlevel 5 from gfs and I have disabled the Firewall but still get the grey logon screen.

    Here is \var\log\boot.msg

    Inspecting /boot/System.map-2.6.25.5-1.1-default
    Loaded 28946 symbols from /boot/System.map-2.6.25.5-1.1-default.
    Symbols match kernel version 2.6.25.
    No module symbols loaded - kernel modules not enabled.

    klogd 1.4.1, log source = ksyslog started.
    <5>Linux version 2.6.25.5-1.1-default (geeko@buildhost) (gcc version 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036] (SUSE Linux) ) #1 SMP 2008-06-07 01:55:22 +0200
    <6>Command line: root=/dev/disk/by-id/scsi-SATA_ST3120023A_3KA171DJ-part6 resume=/dev/sda5 splash=silent PROFILE=default vga=0x31a
    <6>BIOS-provided physical RAM map:
    <6> BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
    <6> BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
    <6> BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    <6> BIOS-e820: 0000000000100000 - 000000007dff0000 (usable)
    <6> BIOS-e820: 000000007dff0000 - 000000007dff3000 (ACPI NVS)
    <6> BIOS-e820: 000000007dff3000 - 000000007e000000 (ACPI data)
    <6> BIOS-e820: 000000007e000000 - 0000000080000000 (reserved)
    <6> BIOS-e820: 00000000f0000000 - 00000000f4000000 (reserved)
    <6> BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
    <7>Entering add_active_range(0, 0, 159) 0 entries of 3200 used
    <7>Entering add_active_range(0, 256, 516080) 1 entries of 3200 used
    <6>end_pfn_map = 1048576
    <6>DMI 2.2 present.
    <4>ACPI: RSDP 000F7AC0, 0014 (r0 Nvidia)
    <4>ACPI: RSDT 7DFF3040, 0034 (r1 Nvidia AWRDACPI 42302E31 AWRD 0)
    <4>ACPI: FACP 7DFF30C0, 0074 (r1 Nvidia AWRDACPI 42302E31 AWRD 0)
    <4>ACPI: DSDT 7DFF3180, 6154 (r1 NVIDIA AWRDACPI 1000 MSFT 100000E)
    <4>ACPI: FACS 7DFF0000, 0040
    <4>ACPI: SSDT 7DFF9400, 01C4 (r1 PTLTD POWERNOW 1 LTP 1)
    <4>ACPI: MCFG 7DFF9640, 003C (r1 Nvidia AWRDACPI 42302E31 AWRD 0)
    <4>ACPI: APIC 7DFF9340, 0072 (r1 Nvidia AWRDACPI 42302E31 AWRD 0)
    <6>Scanning NUMA topology in Northbridge 24
    <6>No NUMA configuration found
    <6>Faking a node at 0000000000000000-000000007dff0000
    <7>Entering add_active_range(0, 0, 159) 0 entries of 3200 used
    <7>Entering add_active_range(0, 256, 516080) 1 entries of 3200 used
    <6>Bootmem setup node 0 0000000000000000-000000007dff0000
    <6> NODE_DATA [000000000000c000 - 0000000000013fff]
    <6> bootmap [0000000000014000 - 0000000000023bff] pages 10
    <6>early res: 0 [0-fff] BIOS data page
    <6>early res: 1 [6000-7fff] SMP_TRAMPOLINE
    <6>early res: 2 [200000-8b5bd7] TEXT DATA BSS
    <6>early res: 3 [37a5a000-37fef084] RAMDISK
    <6>early res: 4 [9f000-aefff] EBDA
    <6>early res: 5 [8000-bfff] PGTABLE
    <7> [ffffe20000000000-ffffe200001fffff] PMD ->ffff810001200000 on node 0
    <7> [ffffe20000200000-ffffe200003fffff] PMD ->ffff810001600000 on node 0
    <7> [ffffe20000400000-ffffe200005fffff] PMD ->ffff810001a00000 on node 0
    <7> [ffffe20000600000-ffffe200007fffff] PMD ->ffff810001e00000 on node 0
    <7> [ffffe20000800000-ffffe200009fffff] PMD ->ffff810002200000 on node 0
    <7> [ffffe20000a00000-ffffe20000bfffff] PMD ->ffff810002600000 on node 0
    <7> [ffffe20000c00000-ffffe20000dfffff] PMD ->ffff810002a00000 on node 0
    <7> [ffffe20000e00000-ffffe20000ffffff] PMD ->ffff810002e00000 on node 0
    <7> [ffffe20001000000-ffffe200011fffff] PMD ->ffff810003200000 on node 0
    <7> [ffffe20001200000-ffffe200013fffff] PMD ->ffff810003600000 on node 0
    <7> [ffffe20001400000-ffffe200015fffff] PMD ->ffff810003a00000 on node 0
    <7> [ffffe20001600000-ffffe200017fffff] PMD ->ffff810003e00000 on node 0
    <7> [ffffe20001800000-ffffe200019fffff] PMD ->ffff810004200000 on node 0
    <7> [ffffe20001a00000-ffffe20001bfffff] PMD ->ffff810004600000 on node 0
    <4>Zone PFN ranges:
    <4> DMA 0 -> 4096
    <4> DMA32 4096 -> 1048576
    <4> Normal 1048576 -> 1048576
    <4>Movable zone start PFN for each node
    <4>early_node_map[2] active PFN ranges
    <4> 0: 0 -> 159
    <4> 0: 256 -> 516080
    <7>On node 0 totalpages: 515983
    <7> DMA zone: 56 pages used for memmap
    <7> DMA zone: 1742 pages reserved
    <7> DMA zone: 2201 pages, LIFO batch:0
    <7> DMA32 zone: 6999 pages used for memmap
    <7> DMA32 zone: 504985 pages, LIFO batch:31
    <7> Normal zone: 0 pages used for memmap
    <7> Movable zone: 0 pages used for memmap
    <6>Nvidia board detected. Ignoring ACPI timer override.
    <6>If you got timer trouble try acpi_use_timer_override
    <6>Detected use of extended apic ids on hypertransport bus
    <6>ACPI: PM-Timer IO Port: 0x1008
    <7>ACPI: Local APIC address 0xfee00000
    <6>ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    <6>Processor #0 (Bootup-CPU)
    <6>ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
    <6>Processor #1
    <6>ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    <6>ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
    <6>ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
    <6>IOAPIC[0]: apic_id 2, address 0xfec00000, GSI 0-23
    <6>ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
    <6>ACPI: INT_SRC_OVR (bus 0 bus_irq 14 global_irq 14 high edge)
    <6>ACPI: INT_SRC_OVR (bus 0 bus_irq 15 global_irq 15 high edge)
    <7>ACPI: IRQ9 used by override.
    <7>ACPI: IRQ14 used by override.
    <7>ACPI: IRQ15 used by override.
    <6>Setting APIC routing to flat
    <6>Using ACPI (MADT) for SMP configuration information
    <6>PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
    <6>PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
    <6>PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
    <6>Allocating PCI resources starting at 88000000 (gap: 80000000:70000000)
    <6>SMP: Allowing 2 CPUs, 0 hotplug CPUs
    <6>PERCPU: Allocating 47936 bytes of per cpu data
    <4>Built 1 zonelists in Node order, mobility grouping on. Total pages: 507186
    <4>Policy zone: DMA32
    <5>Kernel command line: root=/dev/disk/by-id/scsi-SATA_ST3120023A_3KA171DJ-part6 resume=/dev/sda5 splash=silent PROFILE=default vga=0x31a
    <6>bootsplash: silent mode.
    <4>Initializing CPU#0
    <

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •