Results 1 to 6 of 6

Thread: Opensuse 11.0 hangs on startup

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    6

    Default Opensuse 11.0 hangs on startup

    Hi,

    I recently installed a fresh copy of Opensuse 11.0 and it hangs when I start it normally way before it gets to the login part. If I start up using sax or Failsafe it's ok.

    The last printed message is:

    "input: SynPS/2 Synaptics Touchpad as /devices/platform/i8042/serio4/input/input2 "

    I don't know what was supposed to come next... is this anywhere in the var/log. I am using a ATI mobile radeon X1600, don't know if it has something to do with it.

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Iowa, USA
    Posts
    24

    Default Re: Opensuse 11.0 hangs on startup

    The boot log is /var/log/boot.msg

    I doubt it has to do with your ATi video card as this should run without 3D support using the oss drivers as far as I know. What are you running this on? You might search to see if someone else has tried to get it running on the same machine.

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Opensuse 11.0 hangs on startup

    Try acpi=off and see if you can progress with the normal bootup using that parameter in grub.

    You can just type it into the bootloader after the vga=xx statement if you have one (a space between them however).

  4. #4
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    6

    Default Re: Opensuse 11.0 hangs on startup

    Thank you all for the assistance. Thanks Chrysantine it solved my problem, it is working very well now . By the way, just for wisdom's sake, is this an ACPI compatibility issue? Is it a hardware incompability or is it some bug yet to be solved?

  5. #5
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: Opensuse 11.0 hangs on startup

    Sounds like one - it may be resolved in a future kernel update.

  6. #6
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: Opensuse 11.0 hangs on startup

    Quote Originally Posted by valg8 View Post
    By the way, just for wisdom's sake, is this an ACPI compatibility issue? Is it a hardware incompability or is it some bug yet to be solved?
    ACPI involves power management; there is an inter-dependency between the hardware, the BIOS, and OS. While an industry-standard that has evolved for 10 yrs, it is controversial due to its being exceedingly complex and not consistently and rigorously implemented in all hardware and BIOS's. Consesquently, there are occasionally problems which can be very difficult to pinpoint. Hence the acpi-off switch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •