Results 1 to 6 of 6

Thread: Desktop doesn't fill screen

  1. #1

    Default Desktop doesn't fill screen

    Hi there,

    I run openSUSE 11.0 on an IBM ThinkPad T30 (ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]), and I am quite happy that now the desktops effects run quite smoothly although the hardware might already be a bit dusty

    The current issue is, that the desktop (KDE 3.5.9) does not use the entire screen of 1400x1050, it rather ends after 1024 pixel columns (task bar ends here). Although the remaining area may be used by windows, unused regions are not updated properly, e.g. I move a windows and the window is displayed nicely, but there is a trail of my window movement remaining.

    I understood that xrandr is a kind of important to issues like that, so I include its output:
    # xrandr
    Screen 0: minimum 320 x 240, current 1400 x 1050, maximum 1400 x 1050
    default connected 1400x1050+0+0 0mm x 0mm
    1400x1050 50.0*
    1280x1024 50.0
    1280x960 50.0
    1366x768 50.0
    1280x800 50.0
    1152x864 50.0
    1280x768 50.0
    1024x768 50.0
    1280x600 50.0
    1024x600 50.0
    800x600 50.0
    768x576 50.0
    640x480 50.0
    1360x768 50.0
    1368x768 50.0
    640x350 50.0
    640x400 50.0
    720x400 50.0
    320x240 50.0
    400x300 50.0
    512x384 50.0
    576x432 50.0
    640x512 50.0
    896x672 50.0
    928x696 50.0
    960x720 50.0
    416x312 50.0
    576x384 50.0
    700x525 50.0
    800x512 50.0

    I also found the following entry in my /etc/sysconfig/displaymanager:
    DISPLAYMANAGER_RANDR_MODE_auto="1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync"
    Since there is a big chance of messing things etirely up I prefer asking first...

    Whenever I activate the cube desktop effect, the unused area beyond 1024 pixel columns is rendered black.

    I would be happy if there was anybody providing advices and pointers. Let me know if there is more you need to know about the system.

    Thanks in advance & cheers,

    Reinhard.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Desktop doesn't fill screen

    Look for SaX2 in your applications. This should be able to sort out your configuration.

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: Desktop doesn't fill screen

    Sounds like your IBM thinkpad uses an older intel graphics chip which Opensuse has had problems with since 10.3
    The solution is to downgrade to the oder intel dirver which should fix things up.

    from command go to

    init 3

    then

    sax2 -r -m 0=i810

    then reboot.

    If it doesn't fix your problem and you want to go back to the default driver just do

    sax2 -r

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: Desktop doesn't fill screen

    oops - I don't think I read your initial post thoroughly - sorry

  5. #5

    Default Re: Desktop doesn't fill screen

    ... as expected, the i810 drivers did not work out

    @john_hudson: sax2 does not offer this option. For better understanding, I try to scetch what is happening:


    my screen:1400x1050
    +----------------+-----+
    |................|.no..|
    |.desktop........|.desk|
    |..1024x1050.....|..top|
    |................|.....|
    |................|.....|
    |................|.....|
    |................|.....|
    +----------------+-----+


    all effects work nicely on the entire screen. The area I call "no desktop" contains no desktop background, no task bar, and the background is not cleared (e.g. when dragging a window across the area).

    Still grateful for advices!

    Reinhard.

  6. #6

    Default Re: Desktop doesn't fill screen

    ... after playing around with several parameters I found, that

    sax2 -r

    does the trick

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •