All:

I've been seeing a number of postings regarding issues with wireless
connectivity, and thought I'd share my experiences so far.

After initial install of OpenSuSE 11.0, I saw some issues connecting as
well. Even though I had configured my home network SSID and WEP key into
Kinternet, it wouldn't connect. It would see the network, and see the
signal strength, but wouldn't connect.

So, I fiddled with 'iwconfig' and finally found what works for me. It's
really just a workaround, but it works consistently.

I wrote a small script to automagically run the iwconfig parms. After I run
the script, I can connect immediately to my network through Kinternet
(sometimes it connects itself). Here's the script:

-----------
#!/bin/bash

/usr/bin/sudo /usr/sbin/iwconfig eth1 essid $my_essid
/usr/bin/sudo /usr/sbin/iwconfig eth1 mode managed
-----------

Here are the details of my controller:

-----------
hwinfo --netcard
09: PCI 303.0: 0282 WLAN controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_8086_4223
Unique ID: JNkJ._EY5xScnyf2
Parent ID: 6NW+.InKz0bgid89
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:03:03.0
SysFS BusID: 0000:03:03.0
Hardware Class: network
Model: "Intel PRO/Wireless 2915ABG Network Connection"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x4223 "PRO/Wireless 2915ABG Network Connection"
SubVendor: pci 0x8086 "Intel Corporation"
SubDevice: pci 0x1020
Revision: 0x05
Driver: "ipw2200"
Driver Modules: "ipw2200"
Device File: eth1
Features: WLAN
Memory Range: 0xdfbff000-0xdfbfffff (rw,non-prefetchable)
IRQ: 17 (101301 events)
HW Address: 00:13:ce:d7:be:9a
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 149 153 157
161 165
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452
2.457 2.462 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.745 5.765 5.785 5.805
5.825
WLAN bitrates: 1 2 5.5 11 6 9 12 18 24 36 48 54
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Requires: ipw-firmware
Module Alias: "pci:v00008086d00004223sv00008086sd00001020bc02sc80i00"
Driver Info #0:
Driver Status: ipw2200 is active
Driver Activation Cmd: "modprobe ipw2200"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #18 (PCI bridge)
-----------

HTH!

--
Menes Narmer
menesofmemphis [at] gmail [dot] com

"Unity and humility is the lesson all of history teaches."