Results 1 to 8 of 8

Thread: I can no longer play any media in OS11.0

  1. #1

    Angry I can no longer play any media in OS11.0

    I am using OS11.0 and Gnome and I have installed all of the GStreamer packages in the repositories (inc. packman).

    Just after I installed the GStreamer stuff, I could play ALL my media (mp3, wma and dvd). Now when I try (only about an hour later) I cannot play anything.

    Attempting to play a track in banshee (1.0) results in a red cross next to the track, it then progresses to the next track and the same happens etc. When this happens, I get the error "GStreamer resource error: Failed" in the terminal.

    When I try and play a dvd (or a wmv file) in Totem, I get the error "Failed to connect stream: Invalid argument".

    Does anyone know why this might have happened? and how I can return to being able to play my media in banshee and totem?

  2. #2

    Default Re: I can no longer play any media in OS11.0

    Update: I just decided to restart and have found that everything works again, including all of the tracks that created the error previously in Banshee and also dvds in Totem.

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/belgium
    Posts
    1,946

    Default Re: I can no longer play any media in OS11.0

    not sure why you get these errors from gstreamer, but if you want to play DVDs, install packman's Xine together with libdvdcss2. Also MPlayer plays virtually all know audio and video files, including encrypted DVDs without the need to install extra libs. For music, you can try packman's Amarok with the Xine engine

  4. #4

    Smile Re: I can no longer play any media in OS11.0

    Thanks for the reply, although it all seems to be working fine now (not a clue why though!)

    I do have mplayer installed, its just that I prefer the ui of banshee for music and totem (or VLC but I am also having troubles on this front) for movies. With mplayer, you dont get the dvd menus etc so you have to choose the right chapters and audio etc (unless I am mistaken). (mencoder is also great!)

    I am using Gnome and dont really what the additional overhead associated with using Amarok. (also banshee 1.0 is a massive improvement and I really like the interface)

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: I can no longer play any media in OS11.0

    Quote Originally Posted by Tubfish View Post
    I do have mplayer installed, its just that I prefer the ui of banshee for music and totem (or VLC ....
    Check out smplayer frontend gui for mplayer.

    smplayer site: SMPlayer - General Info
    packman packaged version: PackMan :: Informationen zum Paket smplayer

  6. #6

    Default Re: I can no longer play any media in OS11.0

    cheers for that, smplayer is definitely a better interface than the default (g)mplayer (I dislike the separate controls and video screen) but I still cant see how to get to the disc menus - is it possible? as this is what I really want rather than scanning through the chapters until I find the right one.

    I do like vlc but am having some problems getting it to autoplay dvds - any ideas? It also always reports a bug when I close it.

  7. #7

    Default Re: I can no longer play any media in OS11.0

    Quote Originally Posted by Tubfish View Post
    I am using OS11.0 and Gnome and I have installed all of the GStreamer packages in the repositories (inc. packman).

    Just after I installed the GStreamer stuff, I could play ALL my media (mp3, wma and dvd). Now when I try (only about an hour later) I cannot play anything.

    Attempting to play a track in banshee (1.0) results in a red cross next to the track, it then progresses to the next track and the same happens etc. When this happens, I get the error "GStreamer resource error: Failed" in the terminal.

    When I try and play a dvd (or a wmv file) in Totem, I get the error "Failed to connect stream: Invalid argument".

    Does anyone know why this might have happened? and how I can return to being able to play my media in banshee and totem?
    hi newbee,

    Yesterday i'd install opensuse 11 , I can't play DVD movies can you please explain how you installed the missing files to run VCD/DVD movies.

    I still could not able under how to install packages from Packman.

    thanks & regards
    suresh



    Packman FTP server.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: I can no longer play any media in OS11.0

    Quote Originally Posted by sureshmenon View Post
    Yesterday i'd install opensuse 11 , I can't play DVD movies can you please explain how you installed the missing files to run VCD/DVD movies.

    I still could not able under how to install packages from Packman.
    Please read the stickie to our multimedia area:
    Welcome to multimedia sub-area - openSUSE Forums

    In there you will note instructions how to setup your repositories in this link:
    Repositories/11.0 - openSUSE-Community - setup your repositories
    Please follow the instructions there.

    Once that is done, it is easy to install software from YaST > Software.

    Also, it might help you get a better understanding of openSUSE linux if you read the openSUSE Linux concepts page:
    Concepts - openSUSE

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •