Results 1 to 2 of 2

Thread: Input Actions Error: Could not find the program...

  1. #1

    Default Input Actions Error: Could not find the program...

    I'm trying to setup Input Actions on KDE 4, OpenSuSE 11, for my HP DV6500T laptop. I had it working before but wanted to call scripts instead of amixer xxxx, notably so I could just add an if statement into my mute button.

    In Input Actions I have commands like the following:
    Group: Multimedia Keys
    Action: VolumeMute
    Action-type: Keyboard Shortcut -> Command/URL (simple)
    Keyboard Shortcut: VolumeMute
    Command/URL to execute: /home/xxx/Config/kybrd/volmute.sh

    This -works-, but it also pops up a dialog box:
    Title: Sorry - KDE Daemon
    Could not find the program volmute.sh

    Again, what I'm doing works, but I get this message from KDE that I'm not figuring out how to suppress, or what I'm doing wrong to register it so that Input Actions allows me to just run scripts (which is important, I'm mapping another button to suspend to ram and i dont want to just run a straight 'powersave --suspend-to-ram', I want to run it through a script file so I can ensure that the network stuff comes back up on resume (which it doesn't otherwise :x)

    Thanks in advance for any help/advice/etc :x

  2. #2
    tonyb_lx NNTP User

    Default Re: Input Actions Error: Could not find the program...

    The only way I could get this to work was by creating a symlink between my shell script and /bin/<xyz>, and setting the action to execute <xyz>. Incidentally, it appears that you have to logout of KDE and start a new session for Input Action changes to take effect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •