Results 1 to 4 of 4

Thread: Fixing a dual boot

  1. #1

    Default Fixing a dual boot

    I was having a problem even getting the grub menu to come up, so I ran the automated recovery section of the installation DVD. Read more here: [ubuntu] Severe Problem, Can't Boot - Ubuntu Forums
    Anyway, after all that, now I can boot openSUSE, but Ubuntu 8.04 does not show up on the grub menu any more. Can you help me put it back on? Also now openSUSE boots in verbose mode, Can you help me change that back also?

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Fixing a dual boot

    Quote Originally Posted by PatrickAupperle View Post
    I was having a problem even getting the grub menu to come up, so I ran the automated recovery section of the installation DVD. Read more here: [ubuntu] Severe Problem, Can't Boot - Ubuntu Forums
    Anyway, after all that, now I can boot openSUSE, but Ubuntu 8.04 does not show up on the grub menu any more. Can you help me put it back on? Also now openSUSE boots in verbose mode, Can you help me change that back also?
    There's another fairly easy step to get Ubu back. GoTo Yast and recalculate and reinstall Grub, in a specific fashion. Here's an extract from this tutorial: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
    Step 2 - Reinitialise and Reinstall Grug: Once Suse has fully booted and settled down, go to Yast --> System --> Boot Loader. The Grub configuration screen comes up with the Tab "Section Management" activated. In the lower right is a drop-down selector labelled "Other". Select from "Other" the option "Propose New Configuration" and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled "Boot Loader Installation" and select to "Boot from the Master Boot Record". [Yast will often default to booting from the root or boot partition rather than from the MBR but that's for experts only -- always choose the MBR.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive's MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk" ......... don't bother with the floppy -- just click OK to proceed and install to the MBR. Reboot and you should be able to boot to openSUSE using the more-complete Grub menu screen.
    Luck
    Swerdna
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3

    Default Re: Fixing a dual boot

    Quote Originally Posted by swerdna View Post
    There's another fairly easy step to get Ubu back. GoTo Yast and recalculate and reinstall Grub, in a specific fashion. Here's an extract from this tutorial: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.


    Luck
    Swerdna
    Thank you, but unfortunately I already killed Ubuntu. Gone forever. I deleted it's partition and reinstalled openSUSE over everything. Thank you anyway.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Fixing a dual boot

    Also now openSUSE boots in verbose mode, Can you help me change that back also?
    I forgot that: Put splash=silent into the line like mine:
    kernel /boot/vmlinuz-2.6.25.5-1.1-pae root=/dev/disk/by-id/scsi-SATA_Maxtor_6L200M0_L41WZVVG-part1 resume=/dev/sdb2 splash=silent showopts
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •