Results 1 to 5 of 5

Thread: emerald process

  1. #1
    Gr1eVeR NNTP User

    Default emerald process

    Hey guys!

    I am having some trouble with OpenSUSE 11.0
    Everything seems to work just fine except one little thing. I have changed the Theme editor and have tried to use Emerald Theme Manager but the theme i have chosen only appears when i run emerald --replace in a terminal. If i kill the process i have manually started or close the terminal window i lose all window decorations. Obviously i need to make that process run on startup but i don't know how. Can anyone help or redirect me to an appropriate thread? (first time using the forum).

    Thanks in advance for your time

  2. #2
    Gr1eVeR NNTP User

    Default Re: emerald process

    sorry for double posting but i didn't see an "edit" button anywhere.

    I tried that:

    If you are using KDE go to ~/home/yourname/.kde/Autostart and add a file like this:


    #! /bin/sh
    sleep 5
    emerald --replace ccp &

    This should start emerald when you start KDE.
    Make sure you select compiz & emerald in the fusion -icon options.

    I am using KDE4 so i used the /home/<name>/.kde4/Autostart directory but when i rebooted the system i got a message that i needed to specify which application should this file be treated with.

    What am i missing here?
    Last edited by Gr1eVeR; 27-Jun-2008 at 06:49. Reason: typo

  3. #3
    Join Date
    Jun 2008
    Rotterdam, Port to Europe

    Default Re: emerald process

    That's right in KDE4.0 it does not seem to work, I get the same message. Don't know why KDE4.0 would not recognise it as such. Maybe make it executable with: chmod +x emerald
    OpenSuSE Leap 42.3 / KDE 5.8 | Intel i7 3770 | 16GBRam | 120 + 80GB SSD's | Benq 27" | DVD | PhilipsToUcam 740 | HPpsc2355p | Logitech KB & mouse | 320 +160 + 80 + 80 GB USB HDD's | Fritz!Box Fon WLAN 7360 | (V)DSL 12 MB/s | SuSE since 2001

  4. #4
    Gr1eVeR NNTP User

    Default Re: emerald process

    I actually was able to solve the problem by performing in a terminal the following:
    echo "USE_EMERALD=yes" >> ~/.config/compiz/compiz-manager
    as a simple user.

  5. #5
    Join Date
    Jun 2008
    Cairo, Egypt

    Lightbulb Re: emerald process

    If I understand your problem well,

    I think yo make Emerald work when you start your computer in (KDE):

    1) if the compiz did't work when the KDE boot:

    >> for [KDE3.x] go to (KDE Control Center) -> KDE Components -> Session Manager -> compiz

    >> and for [KDE4] (KDE Configure Desktop) -> Advanced -> Session Manager -> Window Manager -> Compiz

    2) after that we need Emerald work:
    go to (ccsm) -> decoration -> commandline write -> (emerald --replace)

    3) and as a normal user write this command:
    echo "USE_EMERALD=yes" >> ~/.config/compiz/compiz-manager
    I hope I understand what you need.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts