Results 1 to 7 of 7

Thread: Screen blanking even though standby for display disabled

  1. #1
    Join Date
    Jun 2008
    Posts
    15

    Default Screen blanking even though standby for display disabled

    I've disabled all energy saving settings for my display (Fujitsu-Siemens L22W3) in openSUSE 11 (KDE 4.0.4) in system settings, yet my screen nevertheless blanks after about two minutes. The same thing happens when I set all energy saving options to 120 Minutes - screen blanks after ~2 minutes no matter what.

    Where else can this setting be found? It's not a BIOS-Setup issue, I've disabled all energy settings in there.

  2. #2
    oimon NNTP User

    Default Re: Screen blanking even though standby for display disabled

    i have the same issue using opensuse 11 with kde 4.0.83
    anyone know the answer?

  3. #3
    miha_mvp NNTP User

    Default Re: Screen blanking even though standby for display disabled

    Guys, this is screensaver. Just blank screensaver.
    I don't know why did they do it. It's really confusing.
    Anyway, disabling screensaver helped me.

  4. #4
    oimon NNTP User

    Default Re: Screen blanking even though standby for display disabled

    Thanks for your reply, however, when the screensaver is disabled, the blank screen kicks in after a couple of minutes (maybe something else is blanking the screen)
    However i selected a screensaver "euphoria" and chose "start automatically after 60 minutes", then the 2 minute blanking doesn't happen. so this works as a workaround for me - 60 minutes is OK for my needs.
    however i did find another bug, euphoria screensaver only uses 1/4 of the screen...my first few days of trying opensuse (after kubuntu) are proving rather buggy. i'd suspect that quite a few of the bugs are due to the kde4.1 beta i'm running!

  5. #5

    Default Re: Screen blanking even though standby for display disabled

    A work around that works for me so far is going into Personal Settings (Configure Desktop), "Display" under Computer Administration, and then Power Control. Instead of disabling Standby, Suspend, and Power Off individually, I uncheck "Enable display power management".

    A disadvantage of that is that you can't set enable the other features if by chance you still want, for example, to power off your display. I'd prefer not to have to go the "all or nothing" route, but I haven't found anything else that seems to help. Unchecking "Enable display power management" did not work in previous versions of openSUSE; but, it seems to work with version 11.0.

    If anyone has a more efficient way to enable screensaver without the monitor going into standby after a couple of minutes or so, please post it. It may be something simple that we're all missing here.

  6. #6

    Default Re: Screen blanking even though standby for display disabled

    ... oimon, I prefer to keep the version of KDE 4 that is packaged with openSUSE 11.0. With previous versions of openSUSE, I used to add the KDE repositories to YAST to keep up with the latest KDE. The updates usually contained "under the hood" changes and fixes, but occasionally included some nice new features. In the case of KDE 4, the latest available version through the repositories (at the time of this post, KDE 4.1 beta 2), I actually lose features such as being able to move widgets within a panel, I lose plasmoids, and there are a quite a few other things that I don't like. Instead, I prefer to keep my stable version, and I will *consider* upgrading to 4.1 when a stable release is available and after I read reviews and user comments.

  7. #7
    fbe2 NNTP User

    Default Re: Screen blanking even though standby for display disabled

    I just wanted to add my voice to the frustration with this bug. The only thing that works for me is the '60 minute screensaver' workaround. This smells too much like defeat, but it's less frustrating than having my screen go blank every minute or so when I'm not currently typing.

    Here's an interesting google (now a noun: "an item returned from a google search") that I found when researching this bug:


    SCREEN BLANKING - How Do I Turn It Off?
    Feb 26, 2007 ... this is probably a bug in suse handling screen blanking which I submitted and supposedly it should be fixed in 10.2 but apparently is not
    forums.suselinuxsupport.de/index.php?showtopic=51788


    When clicked on the page returned is the home page of this forum. I haven't yet been able to see this post, due, no doubt, to my inadequate knowledge of how to properly search this forum.

    But the important thing is to note that this was reported as a bug as far back as 10.1 and it is still extant. I realize that every single bug can't be fixed, and this one is more annoying than dangerous or crippling, but still....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •