Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Pre-install MBR advice

  1. #1

    Default Pre-install MBR advice

    Hei all

    Its a long time since I ran SUSE on my system, in fact its a long time since I actively ran 2x Gentoo copies, 2x SLAX and a Kanotix on my 2x IDE drive XP system - I have been running OSX for a couple of years

    With so many distribution copies I have always used a Grub floppy and/or later an Eltorito Boot CD to avoid touching the XP MBR. Thats the background..

    Now I would like to install OpenSUSE 11 on my 2nd drive. It still contains an old copy of Gentoo and a Fat32 partition, and I still don't want to touch XP's MBR on drive 0!

    Can I prevent writing to drive 0 MBR in the YAST install setup, e.g. by choosing drive 1 MBR?

    If so, where do I look for the menu.lst entry the installation then makes?

    Thanks for your ideas

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Pre-install MBR advice

    I have 2 HD's and suse's boot loader is on the one without xp on it, just make sure which drive is which and make sure during install the grub is going to be written to the correct drive.

    you will need to set the drive with the grub on to be 1st to boot in bios setup

    N.B.
    You can still have suse partitions on the xp drive though if you want.

    Use custom partitioning to get everything just right
    set mount point for xp as eg: /windows c or /xp

    you may have to edit menu.lst once install is done, as with mine xp did not boot (though I never use it)
    if you have a problem pm me

    ps.
    menu.lst is /boot/grub/menu.lst
    Last edited by caf4926; 27-Jun-2008 at 00:26. Reason: add ps
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Pre-install MBR advice

    Many thanks for your helpful reply

    I have made 5 new partitions so I can configure a couple of OpenSUSE installs.. a practice with the LiveCD first perhaps, while waiting for the dvd

    I've also refreshed my rusty Grub skills - shiver! Will edit this with the results..

  4. #4

    Default Re: Pre-install MBR advice

    I ran into trouble with the dvd Is it possible to install a full system to hard drive from the Live CD?

  5. #5

    Default Re: Pre-install MBR advice

    Quote Originally Posted by cintra2 View Post
    I ran into trouble with the dvd Is it possible to install a full system to hard drive from the Live CD?
    Guess I need to reply to myself as finger trouble caused a previous edit of the above post to abort.. what I wanted to say is that I tried to install from the Live CD, but it simply exits after getting to the entering of name and password. So, I've ordered a new dvd.

    I get media errors on both my dvd devices, and they are little used, so I assume its dvd trouble.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Pre-install MBR advice

    Burning of dvd's needs to be done as slow a possible. It took me two attempts this time with suse 11. So always use the media check from the cd or dvd menu before install. Even if you have done the md5sum check, still use the media check too.
    My md5check was ok on both the .iso and then too on the burned dvd, but failed the suse media check.

    Second time round worked fine though.
    Last edited by caf4926; 27-Jun-2008 at 08:48. Reason: Add and typo
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Pre-install MBR advice

    Thanks for the tip.. its going to take ages at the current rate (half my usual dl speed) but I will burn slowly. It would almost seem as though the media checker is hyper sensitive in some way.. I' can't remember having any errors on my NEC dvd devices, so I'm trying once again now. Cross fingers as they say

  8. #8

    Default Re: Pre-install MBR advice

    After 6 hours my torrent dl gave ok checksum, and I have just used it to install 11.0 right up to the final window which loads the desktop.. its totally unreadable, so I assume its an nvidia issue. Excuse me for saying so, but why on earth couldn't it manage to sort out the standard nv driver. It recognizes my (quiet) FX5200 ok...

    So now its the usual (regretable) Linux matter of getting 'under the bonnet' and sorting it out.

  9. #9

    Default Re: Pre-install MBR advice

    Here is my fstab:
    /dev/disk/by-id/scsi-SATA_WDC_WD1600JB-00WD-WMAES1643139-part5 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD3200JB-00_WD-WCAMR2246678-part6 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD3200JB-00_WD-WCAMR2246678-part14 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_WDC_WD3200JB-00_WD-WCAMR2246678-part15 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_WDC_WD1600JB-00WD-WMAES1643139-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD1600JB-00WD-WMAES1643139-part8 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD3200JB-00_WD-WCAMR2246678-part10 /windows/E vfat users,gid=users,umask=0002,utf8=true 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

    and the menu.lst which gives error 2:
    # Modified by YaST2. Last modification on Sat Jun 28 14:01:04 CEST 2008
    default 0
    timeout 8
    gfxmenu (hd1,13)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.0
    root (hd1,13)
    kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_WDC_WD3200JB-00_WD-WCAMR2246678-part14 splash=silent showopts vga=normal brokenmodules=pegasus
    initrd /boot/initrd

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.0
    root (hd1,13)
    kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_WDC_WD3200JB-00_WD-WCAMR2246678-part14 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe
    initrd /boot/initrd

    Btw, it also errors on the message file before getting to error 2, i.e. it doesn't seem to see sdb14

    Hope you notice something

    mvh

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Pre-install MBR advice

    You seem to have 2 swap partitions?

    This is how my fstab looks:

    /dev/disk/by-id/scsi-SATA_Maxtor_6Y160P0_Y454TYNE-part2 /MaxtorMini ext3 acl,user_xattr 1 2
    /dev/disk/by-id/scsi-SATA_Maxtor_6Y160P0_Y454TYNE-part1 swap swap defaults 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part6 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/scsi-SATA_Maxtor_6Y160P0_Y454TYNE-part3 /Maxtor ext3 defaults 1 2
    /dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part5 /STORE vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part1 /XP ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
    /dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part7 /home ext3 defaults 1 2
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0


    My menu.lst:

    # Modified by YaST2. Last modification on Sun Jun 22 04:42:57 BST 2008
    default 1
    timeout 8
    gfxmenu (hd1,5)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Debug -- openSUSE 11.0 - 2.6.25.5-1.1
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.25.5-1.1-debug root=/dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part6 resume=/dev/sdb1 splash=silent showopts vga=0x31a
    initrd /boot/initrd-2.6.25.5-1.1-debug

    ###Don't change this comment - YaST2 identifier: Original name: linux-2.6.25.5-1.1-default###
    title openSUSE 11.0 - 2.6.25.5-1.1
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.25.5-1.1-default root=/dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part6 resume=/dev/sdb1 splash=silent showopts vga=0x31a
    initrd /boot/initrd-2.6.25.5-1.1-default

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.0 - 2.6.25.5-1.1
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.25.5-1.1-default root=/dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WMAPZ0196427-part6 showopts ide=nodma apm=off acpi=off noresume edd=off x11failsafe vga=0x31a
    initrd /boot/initrd-2.6.25.5-1.1-default

    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title WIN XP
    map (hd0) (hd1)
    map (hd1) (hd0)
    rootnoverify (hd1,0)
    chainloader +1

    Wester Digital is sata and holds a xp partition - as I have already said
    Maxtor id pata (ide) drive and actually only holds swap and 2 ext3 partitions which are only storage partitions.
    All my suse partitions are on the WD drive
    But my boot loader is on Maxtor MBR
    And Maxtor is first boot device in bios

    If I switch my WD drive to first boot, XP boots, no grub at all.

    I hardly ever use XP for real, but use it in a VBox from suse, saves ever needing to re-boot. That said, I rarely use it in VBox either, as suse does all I need.

    To get vesa display, so you can work on adding the repos:


    If graphics driver gets messed up, type 3 in the boot line to get runlevel 3 - login as root

    type
    sax2 -r -m 0=vesa

    reboot
    this should enable a display using vesa

    GRUB ERRORS:

    GRUB Error Messages
    GRUB Error 2 on booting 1st time - Ubuntu Forums
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •