Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Problems with Laptop openSUSE 11.0 64-bit

  1. #1

    Exclamation Problems with Laptop openSUSE 11.0 64-bit

    I am having a couple of problems with my Hp dv2000 opensuse 11.0 system:

    > Wireless not working (Intel Wireless)

    > Sound not working (Intel Sound Card)

    Any ideas?

    Thanks

  2. #2

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    Run the following command in a console as su (root) and post the results here;

    Code:
    lspci

    Also, can you describe your hardware in more detail than simply 'Intel'?

  3. #3

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    I got the following

    zaid@linux-rmkm:~> lspci
    bash: lspci: command not found

  4. #4

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    try;
    sudo lspci

    Then enter roots password.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,158
    Blog Entries
    40

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    Quote Originally Posted by ZERO_SHIFT View Post
    I am having a couple of problems with my Hp dv2000 opensuse 11.0 system:> Sound not working (Intel Sound Card)
    Please try to work your way through the open suse audio troubleshooting guide:
    SDB:AudioTroubleshooting - openSUSE

    If that does not help you, then please post here the output URL(s) provided to you by running the two diagnostic scripts: Scripts_to_run_to_obtain_detailed_information

    and please also provide the output of the following commands run in a terminal/xterm/konsole:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

  6. #6

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    This is what I got from the output.

    btw my Network Card is Intel Pro Wireless 3945BG
    Sound Card 82801G (ICH7 Family) High Definition Audio Controller


    Code:
    zaid@linux-rmkm:~> rpm -qa | grep alsa
    alsa-oss-1.0.15-48.1
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-utils-1.0.16-35.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-oss-32bit-1.0.15-48.1
    zaid@linux-rmkm:~> rpm -qa | grep pulse
    libpulse-mainloop-glib0-0.9.10-26.1
    libpulse-browse0-0.9.10-26.1
    libpulse0-32bit-0.9.10-26.1
    pulseaudio-utils-0.9.10-26.1
    pulseaudio-module-bluetooth-0.9.10-26.1
    pulseaudio-module-x11-0.9.10-26.1
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    libpulse0-0.9.10-26.1
    alsa-plugins-pulse-1.0.16-57.1
    libpulsecore4-0.9.10-26.1
    pulseaudio-module-lirc-0.9.10-26.1
    pulseaudio-esound-compat-0.9.10-26.1
    pulseaudio-0.9.10-26.1
    pulseaudio-module-zeroconf-0.9.10-26.1
    pulseaudio-module-gconf-0.9.10-26.1
    zaid@linux-rmkm:~> rpm -q libasound2
    libasound2-1.0.16-39.1
    zaid@linux-rmkm:~> uname -a
    Linux linux-rmkm 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux
    zaid@linux-rmkm:~> cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    # u1Nb.uHk6lYgTyh8:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    zaid@linux-rmkm:~>

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,158
    Blog Entries
    40

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    Quote Originally Posted by ZERO_SHIFT View Post
    This is what I got from the output.
    Thankyou for that. It appears you have installed way too many "pulse audio" applications. IMHO the pulse audio is still not completely mature in 11.0, and its far better to remove them all, than install them all.

    Please, could you run the diagnostic scripts that I asked previous:
    Quote Originally Posted by oldcpu View Post
    please post here the output URL(s) provided to you by running the two diagnostic scripts: Scripts_to_run_to_obtain_detailed_information
    If you have a problem running those scripts, please advise. If the wget command does not work for you, then just right click and download the files to your hard drive.
    alsa-info.sh: http://hg.alsa-project.org/alsa/raw-...p/alsa-info.sh #and run with: bash alsa-info.sh
    tsalsa: http://home.cfl.rr.com/infofiles/tsalsa #and run (with root permissions): bash tsalsa

    I need you to run those as they help me confirm you have the correct mixer settings, and they also provide me your audio codec. There is a possibilty the command
    cat /proc/asound/cards
    will provide your codec, but it is not always successful, hence I need you to run the scripts.

  8. #8

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    Thanks Sound Works, but it does not work with skype for some reason plus when multiple apps are open only one can use the sound.

    i still have problems with wireless

  9. #9

    Exclamation Re: Problems with Laptop openSUSE 11.0 64-bit

    Quote Originally Posted by ZERO_SHIFT View Post
    Thanks Sound Works, but it does not work with skype for some reason plus when multiple apps are open only one can use the sound.

    i still have problems with wireless
    Please Check http://pastebin.com/m32352b30

  10. #10
    Join Date
    Jun 2008
    Location
    NSW, Australia
    Posts
    55

    Default Re: Problems with Laptop openSUSE 11.0 64-bit

    I have a similar puter running 10.3 and KDE 3.5.9 with skype working. 11.0 is probably similar to set up.

    If you sound works, for skype sound go into kcontrol and set your sound to full duplex. Try that.

    Could also be a microphone switch issue in your sound mixer app. HPs are bit tricky as they have internal and external microphones.

    If the above fails one of the forum mods may be able to help with 11.0/KDE4.

    Have fun...

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •