I have a Gateway T-1616 laptop (AMD Turion X2, Radeon X1270) running openSUSE 10.3. The machine cannot suspend to RAM regardless of video driver and I haven't really tried to figure out if it can (s2ram investigation). Would be nice, but I'm willing to compromise as it's a cheap machine and I don't expect all things to work perfectly.

However it can hibernate to disk just fine, pretty much regardless of video driver (fglrx or radeonhd). The problem is this only works if the RAM in the machine is 2GB. Anything more (3 or 4Gb) and it locks up when hibernating. The machine otherwise seems fine with more RAM, no crashes or other problems. And the RAM works just fine in a different computer that can suspend and hibernate. So I don't think it's specifically the RAM. The machine is spec'd to support up to 4Gb or RAM.

What happens is that I get the sleeping splash screen which goes about 1/6 of the way and then stops - forever until I power down the machine.

To be clear, there is a 4Gb+ swap partition, so swap disk space should not be the issue. This isn't related to SUSE in particular because I've tried other distros with the same results.

Can anyone give me some clues on where to look for what is failing? I'm not even sure what command is being called to hibernate. Thanks.