Results 1 to 8 of 8

Thread: Brother CUPS driver MFC-210C not installable

  1. #1
    magl NNTP User

    Default Brother CUPS driver MFC-210C not installable

    The CUPS driver MFC210C-1.0.0-1 rpm package will not be installed on openSuse 11.0 (Worked 100% on 10.3)

    It is complaining on a not existing requirement
    csh

    but tcsh are installed and csh works

    Could any one guide my?

    --- cut (yast)---

    Requires:
    MFC210Clpr
    /bin/csh
    csh
    cups
    /bin/sh
    /bin/sh
    /bin/sh
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1

    --- end cut ---
    --- cut (install) ---
    nothing provides csh needed by cupswrapperMFC210C-1.0.0-1.i386
    --- end cut ---

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,656

    Default Re: Brother CUPS driver MFC-210C not installable

    Quote Originally Posted by magl View Post
    but tcsh are installed and csh works
    Stupid question, but is it in /bin/csh? you say 'working' imho that means that it is found somewhere in your PATH when called by you, but not nesessecary in /bin.
    Henk van Velden

  3. #3
    magl NNTP User

    Default Re: Brother CUPS driver MFC-210C not installable

    The csh exists as an soft link in /usr/bin (soft link pointing to tcsh).
    The csh is found in the path to both my normal user and root.

  4. #4
    magl NNTP User

    Default Re: Brother CUPS driver MFC-210C not installable

    Sorry, I responded whit an incorrect answer. Lot in my mind ;-)

    What I was trying to say
    -- cut ---
    /bin> pwd
    /bin
    /bin> ls -l *csh
    lrwxrwxrwx 1 root root 4 21 jun 13.29 csh -> tcsh
    -rwxr-xr-x 1 root root 334380 6 jun 21.48 tcsh
    /bin>
    --- end cut ---

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,656

    Default Re: Brother CUPS driver MFC-210C not installable

    Thanks, correct, that was missing in your 'prove of existence'.

    But now I am convinced that csh exist where it belongs to. Why can't it be found by the cupswrapper? Will think it over, but hope someone else will have a bright idea.
    Henk van Velden

  6. #6
    magl NNTP User

    Default Re: Brother CUPS driver MFC-210C not installable

    Quote Originally Posted by hcvv View Post
    Thanks, correct, that was missing in your 'prove of existence'.

    But now I am convinced that csh exist where it belongs to. Why can't it be found by the cupswrapper? Will think it over, but hope someone else will have a bright idea.
    Sorry but I do not believe that it's the cupswrapper thats do not find the csh. I do not know the mechanism behind the check of requirements when installing from a RPM package. I thought that the requirements was stated in the package and that YAST checked the requirements prior to the installation step. As I know that csh exists could I find a way to force YAST to install ignoring the missing requirement?

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,656

    Default Re: Brother CUPS driver MFC-210C not installable

    I never called zypper directly, but man zypper may give you a clue.

    else download the RPM as a file and use rpm directly. rpm certainly has options for ignoring such dependencies (man rpm.
    Henk van Velden

  8. #8
    magl NNTP User

    Thumbs up Re: Brother CUPS driver MFC-210C not installable

    Quote Originally Posted by hcvv View Post
    I never called zypper directly, but man zypper may give you a clue.

    else download the RPM as a file and use rpm directly. rpm certainly has options for ignoring such dependencies (man rpm.

    This was the solution! Thank you. In my pressent new 11.0 environment there exists only one user. For some reason that I do not know the installation tried to tuch a file own by that user in spite that the installation was made by root. In any case. The installation ended with a success and now I can print
    --- cut ---
    :/home2/install # rpm -i --nodeps cupswrapperMFC210C-1.0.0-1.i386.rpm
    error: failed to stat /home/matgra/.gvfs: Permission denied
    rm -f /usr/lib/cups/filter/brlpdwrapperMFC210C
    Shutting down cupsd done
    Starting cupsd done
    :/home2/install # whoami
    root
    :/home2/install #
    --- end cut ---

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •