Results 1 to 9 of 9

Thread: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

  1. #1
    Join Date
    Jun 2008
    Posts
    15

    Default openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    Ignoring the fact that suspend from the K-Menu or the Gnome-Menu does not work either way (neither suspend to RAM nor suspend to disk.... it's a shame, really... c'mon, Windows has been capable of suspending since at least 2001 and even Ubuntu does it these days), is there a reasonable explanation why openSUSE 11/KDE won't suspend with s2ram while openSUSE 11/GNome does exactly what it should do after launching s2ram?

    I'm talking about the same computer here of course, no changes whatsoever. To simplify matters I'll be referring to the Gnome-installation as 11/Gnome, and to the KDE-installation as 11/KDE. With 11/Gnome starting s2ram manually results in a sleeping Computer, and after pressing the power-button it immediately wakes up. With 11/KDE starting s2ram manually results in a sleeping Comptuer, yet waking up does not work - LEDs, fans, harddrive, etc. - everything spinning up as usual, optical mouse on, keyboard-leds on - but screen remains forever blank. The computer remains inaccessible, even SSH is a no-go.

    In both cases I've been using the same hardware, and the same drivers (radeonhd for the video card). Can someone brighten my day?

  2. #2

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    Alright r both kde and gnome installations configured the same way cause from what I could tell it seems like u have installed them separately.

    r both up to date?
    same graphics driver version?
    same xorg.conf?
    same s2ram options?

    desktop environment should have no effect on this........
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  3. #3
    Join Date
    Jun 2008
    Posts
    15

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    Both installed separately of course. No changes made in the configuration - installed 11/GNome, s2ram works. Installed 11/KDE afterwards, s2ram does not work.

    I installed Atis fglrx-driver on 11/KDE now and s2ram seems to be working. However, for some weird reason, it takes KDE4 ~2 seconds to show me my desktop after I click the "show desktop" button right next to the K-Menu. With the radeonhd-driver, all windows disappear instantly

    This is *really* bugging the hell out of me, could someone with a fairly recent Ati video card (mine is a 3850) try whether it's just me?

  4. #4

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    does this happen on both kde and gnome? I still suggest check your xorg.conf just incase on both installations.
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  5. #5
    Join Date
    Jun 2008
    Posts
    15

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    It only happens in KDE4.

    This is the current situation, after conducting some experiments: suspend via s2ram works with the fglrx-driver in 11/KDE, however it does not work with the radeonhd-driver in 11/KDE. It works perfectly fine with both drivers in 11/Gnome.

    However, using the fglrx-driver with 11/KDE results in a general lagginess on the desktop - I found out that it's not only the "show desktop" button that only works after a ~2s lag but also maximizing windows - clicking the maximize window button on the titlebar also results in a ~2s lag, after which the window maximizes. Neither of these lags occur when using the radeonhd-driver with 11/KDE or either driver with 11/GNome. My xorg.conf files are identical on both 11/KDE and 11/GNome.

    Confusing, ain't it?

  6. #6

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    yes it is

    anyone with an ati card know if using a different desktop environment can cause performance issues with the same driver and card?
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

  7. #7

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    I can't help with that since I have to run with the regular radeon driver.

    but in my case I get suspend and resume under OpenSuse.

    I had to tell it to ignore the DCOP message about possible mounted external devices in order to get it to suspend. But other then that it was no different then a 10.3 for getting it to suspend

  8. #8
    Join Date
    Jun 2008
    Posts
    15

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    I was able to solve this problem by editing s2ram options, adding -f -p -m actually solves the problem with the radeonhd driver. However, as I have already noted, this is not necessary for 11/Gnome, only 11/KDE. The issue with laggy KDE behavior has remained the same though - as soon as I switch over to fglrx KDE4 becomes practically unusable.

  9. #9

    Default Re: openSUSE 11/GNome suspends with s2ram, 11/KDE does not

    Quote Originally Posted by mj42 View Post
    I was able to solve this problem by editing s2ram options, adding -f -p -m actually solves the problem with the radeonhd driver. However, as I have already noted, this is not necessary for 11/Gnome, only 11/KDE. The issue with laggy KDE behavior has remained the same though - as soon as I switch over to fglrx KDE4 becomes practically unusable.
    please remember the kde 4 is still in development and obviously not as mature as kde 3.5.9 or gnome 2.22.1 so that maybe the reason its not working as well with your drivers so why not open up a bug report or something?
    openSUSE 11.0 Kde 3.5.9 Linux kernel 2.6.26.1

    My Blog: http://snake1990.wordpress.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •