Results 1 to 7 of 7

Thread: SuSE 11 as VM in Hyper-V

  1. #1
    wadamw NNTP User

    Default SuSE 11 as VM in Hyper-V

    I know that Novell and Microsoft state that only SuSE Enterprise Server 10 is supported, but I was interested in installing SuSE 11. Has anyone on here successfully set up an OpenSuSE VM inside Hyper-V? If so, can I follow the instructions in the Integration Components read-me, or is there more to do? Any help is appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: SuSE 11 as VM in Hyper-V

    I haven't done it yet, but I hardly think there should be any issue.

    IMO Novell and MS "only support" or "recommend" SuSE Enterprise 10 because that's how they make their money (it's not free)

    Was that way also with MS Virtual Server 2005...

  3. #3
    Borg1of1 NNTP User

    Default Re: SuSE 11 as VM in Hyper-V

    I plan on doing an install this week sometime. Hopefully, it will go smooth as silk. I have noticed that compaired to Virtual PC 2007, that Hyper-V plays nicer with Linux distros. We'll see and I'll let you know.

  4. #4
    tankh88 NNTP User

    Default Re: SuSE 11 as VM in Hyper-V

    Am trying the same this week too.

  5. #5
    Laurence_Bates2 NNTP User

    Default Re: SuSE 11 as VM in Hyper-V

    That's what I am running at the moment. It appears to work well but I have only just started to test it out. The biggest problem that I had was in getting the network adapter to work. The trick for me was to first create an external network in Hyper-V and name it "public", then create the OpenSUSE VM and close it, then right click the VM name in the Hyper-V MMC, select "settings" and then add the "legacy Network Adapter" and link it to the external network "public". It also helps to drop the IPV6 compatibility as has been mentioned in many forums.

  6. #6

    Default Re: SuSE 11 as VM in Hyper-V

    Have you had any issues with input devices?

    I'm trying to use a virtual appliance on a Hyper-V VM. The appliance is packaged with SuSE 11. Everything installed ok and starts up ok - but I cannot use a mouse (keep getting requests to install integration tools).

    All of the references I've found online say that there are no integration tools for v.11 (Microsoft apparently built them for 10.x - but as far as I can tell - not for 11.x)

    There appears to be a virtual disk in the SUSE GUI - but I'm unable to access it (can't click on it) and can't exit the GUI - except by shutting down the machine.

    Does anyone have any experience with this or thoughts about how to enable the mouse?

  7. #7

    Angry Re: SuSE 11 as VM in Hyper-V

    I am trying to do the same - Please help - somebody ! anybody !!

    I haven't been able to do the following:

    1. use legacy adapter - but am trying again...
    2. install the IC from microsoft - using make for the current Microsoft 'RTM' 2.1 version - or - using './setup.pl drivers' for the previous Microsoft RC version 2.1
    3. install the Project Satori input drivers - due to failing to do #2 above - error - 'vmbus driver not installed'

    so frustrated after many hours of searching and trying .

    martian

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •