Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: sony vaio laptop and Fn keys not working in 11.0

  1. #1

    Default sony vaio laptop and Fn keys not working in 11.0

    Hi All,
    I've just installed several days ago opensuse 11.0 nearly in the default presets apart from selecting KDE 3.5 and found that no Fn keys are working.
    I also installed spicctrl and found that the command line can change the screen brightness but nothing works using the Fn key. On the same Sony Vaio S2HP (European name) the Linux Mint 4 KDE edition works with Fn keys.
    I found in lsmod that sony_laptop module was added by default and I even added sonypi and still nothing.
    After that I've installed KDE 4 and as the Fn didn't work I also installed kde4-kmilo and still nothing.
    Can you please help me solve this issue?
    Once I solve this problem I will be able to install it also on another desktop and laptop as I do not want to use more than one distro.

    Thank you very much for your help,
    Radu

  2. #2

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    Should I submit a bug as I see no help in the forums?

    Radu

  3. #3

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    I have this same problem on a VAIO VGN-SZ430N. The Fn keys worked just fine in ubuntu, but here it just doesn't work.

    I wish someone could post a simple fix for this

    Please submit a bug report and post any progress you get.

  4. #4

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    I tried to solve this problem but looks like compatibility issues between the sony_laptop kernel module and the BIOS on our laptops. Before for sony they've used the sonypi and that was working.
    Opensuse has a bug opened from the time of 10.2 with this kind of issues but some of the laptops are not supported.
    https://bugzilla.novell.com/show_bug.cgi?id=226122
    https://launchpad.net/ubuntu/+source/acpid/+bug/29987 shows that even other distros have problems.

    I will try to double check the steps from these bugs and try to fix it but looks like there is little chance for this.

    Radu

  5. #5
    singh_maisbiensur NNTP User

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    hi everyone

    - they don't work for me in 10.3 either
    -- apparently the sonypi and another module intended to make it working, all i can get with that intallation is brightness percentage changing on the screen without any change in brighness!
    - the cooling fan (i imagine that is a cpu fan) keeps roaring all the time - haven't been able to do anything with kpowersave either... ...this one is really sad

    any ideas please ?
    regards

  6. #6

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    I've just discovered the same problem having updated my VGN S270P to openSUSE 11.0. The function keys and on-screen display have worked with no problems for me using 9.2, 9.3, 10.0, 10.2 and 10.3, but not any longer.

    The sony-laptop module is loaded and seems to boot with no issues, but it says that sonypi is not loaded when I go to the KDE 3.5 Control Centre section for the Vaio. I don't really understand how to get sonypi added, but from the post above it seems that won't make any difference anyway.

    I also downloaded the spicctrl from the Build Service, since I couldn't find it in my package list. Although I grabbed the 1.9 version, when I run it the opening message says it is 1.8. I'm not sure if this is because it was originally installed on the machine years ago from a source package rather than a RPM, and I don't know how to go about uninstalling the original if so. Regardless, that doesn't seem to be the issue either.

    When I press the Fn keys for volume / brightness etc., there is hard disk activity, but nothing actually happens. I'll try to file a bug report if I can find out how to do it.

  7. #7

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    Perhaps I spoke too soon. The Fn keys do appear to work when logged in as root (as does the KDE Control Centre Vaio module) but not as a user. Not sure if permissions need changing somewhere. All the Fn keys are okay except brightness+, for some reason, which was always fine before.

  8. #8
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    453

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    check this file and add your model

    /usr/share/hal/fdi/information/10freedesktop/30-keymap-module-sony-laptop.fdi

  9. #9

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    Quote Originally Posted by collinm View Post
    check this file and add your model

    /usr/share/hal/fdi/information/10freedesktop/30-keymap-module-sony-laptop.fdi
    This doesn't work for me, unfortunately, although I can't be completely sure if the format of the model string I entered is how it needs to be. I can't find anywhere on my system info where the model of my machine is actually recorded.

  10. #10
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    453

    Default Re: sony vaio laptop and Fn keys not working in 11.0

    Quote Originally Posted by gumb View Post
    This doesn't work for me, unfortunately, although I can't be completely sure if the format of the model string I entered is how it needs to be. I can't find anywhere on my system info where the model of my machine is actually recorded.
    to know the write name to write in this file...



    lshal | grep system.hardware.product

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •