Results 1 to 9 of 9

Thread: Disable the PC speaker

  1. #1
    desmondgc NNTP User

    Question Disable the PC speaker

    I know this has been asked many times before, but I'm still not satisfied with any answers that have been given. All I want to do is simply disable the PC speaker completely in openSUSE 11.0.

    Code:
    xset b off
    xset b 0 0 0
    setterm -blength 0
    ...are not what I'm looking for.

    Code:
    set bell-style none
    ...in inputrc is not going to cut it, either.

    I happen to like the soft bell that KDE pipes through my sound card ("real" speakers). I want to keep that. What I want to stop is the odd application/error that causes the sound to route through the PC speaker. Why is this so **** difficult? How hard could it be to separate the pcspkr module a la Debian/Ubuntu?

    So, I'm guessing no one will be able to help me but I've been surprised before.

    Is there any way I can disable the PC speaker (but not disable all "bells") in openSUSE 11.0?

  2. #2
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: Disable the PC speaker

    Quote Originally Posted by desmondgc View Post
    Is there any way I can disable the PC speaker (but not disable all "bells") in openSUSE 11.0?
    Install "Alsa Mixer"; logout, login; open Alsa Mixer; Mute the PC speaker & set all the rest to suit yourself
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  3. #3
    desmondgc NNTP User

    Default Re: Disable the PC speaker

    Maybe I'm missing something, then.

    The "alsamixer" tool doesn't allow me to control the PC speaker at all. Please elaborate.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Disable the PC speaker

    > The "alsamixer" tool doesn't allow me to control the PC speaker at all.

    hmmmmm...neither can i (on SuSE 10.3)...if 'snakedriver' can and we
    can't maybe his soundboard driver allows that, and ours does not ???

    mine is an on-motherboard SiS SI7012....yours? snakedrivers?

    i do notice that kmix has a volume slider for "PCSpeaker", and a
    (graphical) LED which can be clicked bright or dim.....have you played
    with that??

    DenverD

  5. #5
    void_false NNTP User

    Default Re: Disable the PC speaker

    setterm -blength 0
    THX. Was searching for that command for ages

  6. #6
    desmondgc NNTP User

    Default Re: Disable the PC speaker

    There is no PC speaker entry in my KMix.

  7. #7
    desmondgc NNTP User

    Default Re: Disable the PC speaker

    *Bump*

    Any other ideas here?

  8. #8

    Default Re: Disable the PC speaker

    If your PC is a desktop, unplugging the speaker always works.

    Have you tried the KDE Control Center | Sound & Multimedia | System Bell dialog?

    Are yuo sure there's no PC Speaker in KMix? Fire up the mixer and right-click will list all the channels with tick boxes. Just because you can't see it in KMix doesn't mean you can't hear it.

  9. #9

    Default Re: Disable the PC speaker

    Master Mono in kmix did the trick for me, i had to go to settings and configure settings

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •