Results 1 to 7 of 7

Thread: opensuse 10.3: yast2 quits, error in zypper

  1. #1

    Default opensuse 10.3: yast2 quits, error in zypper

    Hi,

    I have a strange error on a new server I installed a couple of days ago.

    Standard text mode installation, additionally postfix, dovecot and samba. Installation & update went smooth, configuration as well. After testing, the server went into production mode and everything was working as supposed.

    A few days later I had to install additional packages (rsync and wol). So I started Yast Software Management. It started to sync with the "update", "oss", "non-oss" and "mail-server" repositories taken from YaST Software Repositories. But a connection could not be established and timed out. So I aborted on the errors. After a while download.opensuse.org was reachable again and I tried again. This time it sync'ed correctly but kicked me back on the main YaST screen.
    Now a lot of modules in YaST (not only in Software) don't work anymore but I can't find an error in the log files.

    When I run zypper, ich get the following error:
    Code:
    $> zypper install rsync
    * Reading repository 'openSUSE-10.3-DVD 10.3' cache
    zypper: symbol lookup error: /usr/lib/libzypp.so.324: undefined symbol: xmlReaderForIO
    I installed smart manually, removed all zypper and almost all yast2 packages and installed them again, but this didn't help.

    Anyone a clue?

  2. #2
    Join Date
    Jun 2008
    Location
    Praha, CZ, EU
    Posts
    26

    Default Re: opensuse 10.3: yast2 quits, error in zypper

    $> zypper install rsync
    * Reading repository 'openSUSE-10.3-DVD 10.3' cache
    zypper: symbol lookup error: /usr/lib/libzypp.so.324: undefined symbol: xmlReaderForIO
    xmlReaderForIO is from libxml2.rpm. Get the rpm via Webpin and install it using rpm.

    Also run "rpm -Va" to see if there are any more broken dependencies.

  3. #3

    Default Re: opensuse 10.3: yast2 quits, error in zypper

    libxml2 is already installed in version 2.6.30. I reinstalled it using rpm but that didn't help.

    "rpm -Va" doesn't show any missing files.

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: opensuse 10.3: yast2 quits, error in zypper

    If you disable the DVD repro (in YaST > Software Repositories) & manually try to refresh the repositories ('zypper ref' in a terminal console) , do you get this error also?

    Curious...
    -Wj
    Have a lot of fun!

  5. #5
    Join Date
    Jun 2008
    Location
    Praha, CZ, EU
    Posts
    26

    Default Re: opensuse 10.3: yast2 quits, error in zypper

    Quote Originally Posted by awojcicki View Post
    libxml2 is already installed in version 2.6.30. I reinstalled it using rpm but that didn't help.

    "rpm -Va" doesn't show any missing files.
    OK, that is more complex than I thought. Please have a look at YaST/Crashes - openSUSE . In particular, post the output of the "rpm -qa ..." command mentioned there.

  6. #6

    Default Re: opensuse 10.3: yast2 quits, error in zypper

    Quote Originally Posted by Magic31 View Post
    If you disable the DVD repro (in YaST > Software Repositories) & manually try to refresh the repositories ('zypper ref' in a terminal console) , do you get this error also?
    Yes, I get the error, no matter which repositories I have enabled.

    Quote Originally Posted by mvidner View Post
    OK, that is more complex than I thought. Please have a look at YaST/Crashes - openSUSE . In particular, post the output of the "rpm -qa ..." command mentioned there.
    I found that doc already yesterday but unfortunately it didn't provide any further clues as to why I have this error. I'll post the output on Monday, I'm already off for the weekend..

  7. #7

    Default Re: opensuse 10.3: yast2 quits, error in zypper

    Ok, gave up on the problem..
    No error messages whatsoever, only the one from zypper. Reinstalling all necessary packages didn't help (from DVD and online repositories). No package conflicts.

    I reinstalled the whole system, configured it as before and now it's running flawlessly. Same package versions!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •