Results 1 to 3 of 3

Thread: Shutdown not adhering to sequence

  1. #1
    willigj NNTP User

    Question Shutdown not adhering to sequence

    It might be something stupid I did, but for some reason my shutdown sequence does not seem to be in sequence, but in parallel.. Some services keep going down while one of my other services is in the middle of its shutdown procedure...
    I did use the proper headings in my etc/init.d scripts with dependencies and used chkconfig to add them.. the K and S numbers are correct and should result in a proper sequence

    Any ideas on what I can look for to explain this issue?

  2. #2
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: Shutdown not adhering to sequence

    I'm not sure if this is what you want, but by default, suse will start/stop all services in parallel. To change this, start Yast -> System -> /etc/sysconfig editor, click the plus next to System, the plus next to Boot, and select the "Run Parallel" option. Change this to "no" to stop them from running in parallel.

  3. #3
    willigj NNTP User

    Smile Re: Shutdown not adhering to sequence


    Great that was exactly the problem and your solution seems to work perfectly!

    thanks a lot!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •