Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: samba issue: suse2xp not working

  1. #1

    Default samba issue: suse2xp not working

    Hi!

    I have 2 computers. One has only XP, and other XP and openSuse 11. File and printer sharing works fine when boath are in XP, but when I am in openSuse than I can see suse shares from my XP computer, but I cant see XP computer from suse.
    I mean I was able to see XP computer from suse, but I could not browse it, when I tried to do that it opened XP computer but like empty folder, nothing in it. Then I installed gadmin-samba and it(I) messed up something and now I cant even see my XP computer.

  2. #2

    Default Re: samba issue: suse2xp not working

    Whenever you get the chance, try this. First, open up "Samba Server" under YaST Control Center. Make sure that your computer is a part of the same workgroup that your Windows computer is assigned to. You can check this under the "Identity" tab. For instance, my Windows computer is assigned to WORKGROUP, and hence, that is what should be in the "Workgroup or Domain Name" field.

    Secondly, make yourself the Primary Domain Controller, which is right underneath the workgroup/domain name field. In my configuration, I also have WINS server support. Again, this is within the "Identity" tab. Furthermore, go ahead and designate yourself a NetBIOS name. This can be whatever you want -- mine is just my first name.

    I was having the same issue as you when it came to browsing Windows shares/folders. They always showed up empty. What seemed to do the trick was messing with the Firewall, which is also in the YaST Control Center. Go ahead and open that up. Once it is open, click on "Allowed Services," which is in the left panel. Under the "Services Allowed" drop-down menu, scroll all the way down to "Samba Server," then click "Add." Once that is done, click on "Broadcast," which is also in the left panel. Once there, click on "Add." Scroll up/down in the "Service" drop-down menu until you reach "Samba browsing." Now click "Add" again. Go back to the main part, click "Next"->"Finish."

    After all this is done, go ahead and logout/reboot. I usually reboot. See if everything works.

  3. #3

    Default Re: samba issue: suse2xp not working

    Thanks for answering.

    I did as you told me. However, I dont have a service called:
    Samba browse in firewall, so I disabled firewall for now. Still not working, the same problem...

  4. #4

    Default Re: samba issue: suse2xp not working

    Also make sure and check your "Windows Domain Membership" in YaST. Make sure that also has the correct workgroup.

    When you run the following command, what does it say?

    Go into your console and type: "smbtree", without the quotes. Also, I imagine you know the name of your Windows computer. Issue the following command:

    "smbclient -L <name_of_windows_computer>"

    What does this return?

  5. #5

    Default Re: samba issue: suse2xp not working

    Ok this is the situation:

    1. Firewall totally disabled, and after reboot everything works, I can browse the XP computer. But I dont want my firewall to be off.

    2. Firewall enabled, samba service is added to list. Now I can see my XP computer, but cant browse-i get an empty folder.

    3. In cases 1 and 2 the network name was constant: MSHOME.

    But now, with firewall back on, I get this output:

    Code:
    SMBTREE:
    Code:
    MSHOME
    	\\MIROSLAV       		Samba 3.2.0rc1-22.1-1795-SUSE-SL11.0
    		\\MIROSLAV\miroslav       	Home Directories
    		\\MIROSLAV\IPC$           	IPC Service (Samba 3.2.0rc1-22.1-1795-SUSE-SL11.0)
    		\\MIROSLAV\home           	miroslavs home folders on suse
    		\\MIROSLAV\pdf-printer    	PDF Printer Service
    		\\MIROSLAV\pdf-documents  	Converted PDF Documents
    		\\MIROSLAV\netlogon       	Network Logon Service
    		\\MIROSLAV\homes          	Home Directories
    	\\DARKO          		slave
    cli_start_connection: failed to connect to DARKO<20> (0.0.0.0). Error NT_STATUS_BAD_NETWORK_NAME
    Code:
    smbclient -L darko
    Code:
    Connection to darko failed (Error NT_STATUS_BAD_NETWORK_NAME)
    Bat the name is good..I dont get it

  6. #6

    Default Re: samba issue: suse2xp not working

    Okay, I am fairly certain that this a firewall issue. Keep your firewall enabled while having Samba service added to your list. Open up your Firewall application, go to "Broadcast." Once in there, click "Add". Under "Zone", it should be ExternalZone. "Network" should be 0/0 (or whatever is the default I presume). Then, under "Service", choose Samba browsing. Add->Next->Finish. This should do it for you. You also might want to go back to "Samba Server" in YaST and make sure "Open port in firewall" is checked.

  7. #7

    Default Re: samba issue: suse2xp not working

    Well...what to tell you besides THANKS mate...works like charm...very nice...

  8. #8

    Default Re: samba issue: suse2xp not working

    Glad it worked out! Take care.

    Regards

  9. #9
    keltose NNTP User

    Default Re: samba issue: suse2xp not working

    Quote Originally Posted by ddg_ag View Post
    Whenever you get the chance, try this. First, open up "Samba Server" under YaST Control Center. Make sure that your computer is a part of the same workgroup that your Windows computer is assigned to. You can check this under the "Identity" tab. For instance, my Windows computer is assigned to WORKGROUP, and hence, that is what should be in the "Workgroup or Domain Name" field.

    Secondly, make yourself the Primary Domain Controller, which is right underneath the workgroup/domain name field. In my configuration, I also have WINS server support. Again, this is within the "Identity" tab. Furthermore, go ahead and designate yourself a NetBIOS name. This can be whatever you want -- mine is just my first name.

    I was having the same issue as you when it came to browsing Windows shares/folders. They always showed up empty. What seemed to do the trick was messing with the Firewall, which is also in the YaST Control Center. Go ahead and open that up. Once it is open, click on "Allowed Services," which is in the left panel. Under the "Services Allowed" drop-down menu, scroll all the way down to "Samba Server," then click "Add." Once that is done, click on "Broadcast," which is also in the left panel. Once there, click on "Add." Scroll up/down in the "Service" drop-down menu until you reach "Samba browsing." Now click "Add" again. Go back to the main part, click "Next"->"Finish."

    After all this is done, go ahead and logout/reboot. I usually reboot. See if everything works.
    Great instructions! Worked wonders for me! Thanks!

  10. #10

    Default Re: samba issue: suse2xp not working

    keltose,

    No problem. I was frustrated much like you probably were, so I figured I'd be of some help. It's the least I can do.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •