Results 1 to 10 of 10

Thread: Problem to update after install

  1. #1

    Default Problem to update after install

    I just installed opensuse 11 using the network install disc.

    Everything went fine with the install. But after logging in for the first time I am asked if I want to check for online updates. I say yes, of course, and accept the default options.

    When trying to configure online update I get this error:

    "None of the installed products can be registered at the Novell registration server."

    I don't know what could be causing this....

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Problem to update after install

    I really can't say because I have never used the approach you describe.

    Login and use Yast, add repo's
    see what is there first
    add what you need

    I always manage updates in a more manual way with Yast - Software Management
    Much better
    Last edited by caf4926; 25-Jun-2008 at 20:48. Reason: typo
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Problem to update after install

    This happens automatically during the install.
    Maybe because of some default setting during the install that I just followed.

    Last night I tried to press skip when the error came and then it said in the taskbar that there were updates ready. It said 1 security update and 7 others so I let it update, but it updated a lot more than a total of 8 packages.

    Sorry if I am missing some obvious point, but this is my first real attempt to use opensuse, and I am more use to Arch, Ubuntu and Gentoo.

    All I want is to make sure everything is updated and feel there is no problems with security or system instabillities, so I can trust the system.

  4. #4

    Default Re: Problem to update after install

    Hi, when you updated, if any of your updates have any dependencies or upgrades these will also be installed or updated.

    If you click on the updater it should show you Patches and Upgrades, if it doesn't show you Upgrades, you will have to configure the applet, to show available Upgrades when they are available.

    Hope this helps you out.

  5. #5

    Default Re: Problem to update after install

    Everything seems to work, but I am just wondering if everything will be updated when it should because of the above mentioned error.
    The error happens when I do this: (sorry for the maybe bad translation. My system is not in english)

    1. Open YaST2
    2. Under Software: "Configuration of online updates"
    3. In the popup following options are selected:
    - Configure now (recommended)
    - Include: Hardware profile and optional information

    Then I get the error message:
    "An error occured when trying to connect to the server"

    And under details:
    "None of the installed products can be registered at the Novell registration server."

    Maybe I have not registered my opensuse somewhere I should or maybe this function has a bug or I don't know.

    The updates seem to work but I would like to find out why this is happening, especially since it also happened during the install. And I guess you are not suppose to get error messages when installing unless something is wrong.

  6. #6

    Default Re: Problem to update after install

    I've just checked mine, and all seems ok. I've never had to register my installation of OpenSUSE and it has always updated itself without any problems, so I would just leave the Registration Code check box unchecked.

    I believe you should still receive all the updates for your installion, as you said it did update 1 security and 7 others, so it's probably running ok.

    Sorry I can't be of more help with this problem.

  7. #7
    bencrawley NNTP User

    Question Re: Problem to update after install

    My 'problem' is a bit different - The red blob with ! in the center tells me I have 46 updates pending. It was only a few this afternoon.

    When I click "Update System Now" it results in a dialog box that says "Failed to update system" ... Authorisation could not be obtained.

    When I select "Show Updates" after a bit of a wait I learn I have 1 security, 5 important and 40 enhancement updates. I can click on "Review" and see a complete list but pressing the "Update System" button produces nothing, nada.

    Any suggestions?

  8. #8
    Join Date
    Jun 2008
    Location
    Iowa, USA
    Posts
    24

    Default Re: Problem to update after install

    Quote Originally Posted by Caybee View Post
    Everything seems to work, but I am just wondering if everything will be updated when it should because of the above mentioned error.
    The error happens when I do this: (sorry for the maybe bad translation. My system is not in english)

    1. Open YaST2
    2. Under Software: "Configuration of online updates"
    3. In the popup following options are selected:
    - Configure now (recommended)
    - Include: Hardware profile and optional information

    Then I get the error message:
    "An error occured when trying to connect to the server"

    And under details:
    "None of the installed products can be registered at the Novell registration server."

    Maybe I have not registered my opensuse somewhere I should or maybe this function has a bug or I don't know.

    The updates seem to work but I would like to find out why this is happening, especially since it also happened during the install. And I guess you are not suppose to get error messages when installing unless something is wrong.
    The only thing I can think of is that on the first run of the updater, it asks you if it can submit certain info, including registration information. If you had checked all the boxes available, you might theoretically get such an error message because the network install isn't one of the versions you can purchase and therefore come with a registration code.

    If you are able to install the update repository and get updates, you are almost certainly fine, as registration is not necessary for updates.

  9. #9

    Default Re: Problem to update after install

    The only thing I can think of is that on the first run of the updater, it asks you if it can submit certain info, including registration information. If you had checked all the boxes available, you might theoretically get such an error message because the network install isn't one of the versions you can purchase and therefore come with a registration code.

    If you are able to install the update repository and get updates, you are almost certainly fine, as registration is not necessary for updates.
    It sounds like this was probably the problem. Maybe it would be a good idea to change this. Like:

    "If you have purchased this version of opensuse click here" or
    "If you are doing a network install then skip this"

  10. #10
    Join Date
    Jun 2008
    Location
    Iowa, USA
    Posts
    24

    Default Re: Problem to update after install

    A good idea, but you need to make it by filing a bug report for it to truly be considered in the development process. It almost certainly wont get changed for 11.0, but you can file it as a request for 11.0. The better bet is to file it as a request for 11.1. Go to bugzilla.novell.com, log in using the same user & password you do for this forum. Do a quick search to see if someone else hasn't filed a similar bug/request for 11.0 or 11.1 (if so, add your 2 cents to their bug report). If not, you can file a new bug.

    Glad you got resolved your problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •