Results 1 to 8 of 8

Thread: Java (icedtea) problems with 11.0/FF 3.0?

  1. #1

    Default Java (icedtea) problems with 11.0/FF 3.0?

    On openSUSE 10.3 I used this HOWTO Java/How To use Java with Firefox on 64-bit openSuSE 10.3 - openSUSE to get Java plugins to work with 64bit Firefox. This worked fine.

    Since I upgraded to 11.0, Java plugins no longer work in Firefox 3.0. They plugins start to load, but crash with the error:
    "Java.lang.NullPointerException".

    Has anyone else noticed this problem? Help/Suggestions welcome.

  2. #2
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    I can't say from the standpoint of using IcedTea in 10.3; I used the "alternatives" method, which only worked with FF 2 and now obviously will not work in 11.0.

    Working with 11.0 and x86-64 the past two days I found two ways to get FF working with the Java plugin, both mentioned elsewhere (as there was when 10.3 was released, a lot of confusion again with 11.0) . . .

    Install 32-bit FF, 32-bit Java, 32-bit Java plugin, the 32-bit version of xulrunner190 and the xulrunner190-32-bit package.

    Or:

    Install 64-bit FF, 64-bit java open source version 6 plugin which will require the jre, 64-bit xulrunner190.

    The first method above I've been using on 10.3 with FF 3.0, everything OK. The second method I've just begun working with. I've read that the open source java doesn't work with some applets, but I think that has been resolved (there is also a version 7 available).

    As far as Flash 32-bit working with 64-bit FF while java must match, this is only an educated guess, but I think the java plugin actually calls the jre for execution whereas the Flash plugin is self-contained.

  3. #3

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    Thanks for your response. I do have the icedtea version of Java installed as well as xulruner190. For the moment I'm not having any luck with the 64bit method.
    You said something about the "alternatives" used in 10.3 not working on 11.0. I seemed to have missed something here... why does that method not work on 11.0?

  4. #4
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    Re "alternatives" on 11.0: Sorry, I spoke too soon. It's very much still there. It's a (complex) method of keeping certain symlinks in order, e.g., to the various jre's installed, the plugin, etc. (The man page explains it well.) When I was trying to get the FF plugin and java working on 10.3, I eventually discovered this mechanism. As I recall, you can run the update-alternatives executable to get the links straightened out, which I had to do.

    Sorry, no other suggestions re running 64-bit FF vsn. It runs with the 64-bit vsn 6 openjdk plugin and jre for me, and 64-bit xulrunner190 (using this under Gnome). But the 32-bit method works just as well for me (under KDE4).

  5. #5
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    Something I just remembered . . . I needed to run update-alternatives on 10.3 because I had upgraded, and I had earlier made changes (I don't remember what specifically) which affected the symlinks. It took me a long time to figure out why the jre wasn't being found in the path; the reason was the alternatives folder. Taking a scan over the HowTo you followed, it seems the first method changes the pointers; perhaps updates-alternatives is worth a look (but the right packages must be installed first).

    The two methods I cite above that are working, are on clean installs. I haven't tried it on an upgrade, yet.

  6. #6
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    I was having the same problem with applets until I changed the version of IcedTea I had installed. I went into Yast and uninstalled any packages that said java-1_7_0-icedtea, and instead installed these:
    java-1_6_0-openjdk-plugin-1.2_b09-9.1
    java-1_6_0-openjdk-1.2_b09-9.1
    from the repositories. Now applets seem to work fine.

    Hope it fixes it for you as well.

  7. #7

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    Thanks very much for the tip. The 1.6.0 openjdk java does indeed seem to do the trick.
    After removing the 1.7.0 version and installing the 1.6.0 version the little java man is once again doing his dance in 64bit FF 3.0.
    Thanks again.

  8. #8

    Default Re: Java (icedtea) problems with 11.0/FF 3.0?

    Quote Originally Posted by mingus725 View Post
    Something I just remembered . . . I needed to run update-alternatives on 10.3 because I had upgraded, and I had earlier made changes (I don't remember what specifically) which affected the symlinks. It took me a long time to figure out why the jre wasn't being found in the path; the reason was the alternatives folder. Taking a scan over the HowTo you followed, it seems the first method changes the pointers; perhaps updates-alternatives is worth a look (but the right packages must be installed first).

    The two methods I cite above that are working, are on clean installs. I haven't tried it on an upgrade, yet.
    @mingus725 and @elserj, I wish to thank you very much for taking the tine to respond and pointing me in the right direction. Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •