Results 1 to 10 of 10

Thread: can't configure printer!!!

  1. #1
    macco_chicco NNTP User

    Default can't configure printer!!!

    Hi everyone,
    i'm new both with linux and in this forum, and i'm having some problems configuring my printer epson stylus d88+ in openSUSE linux 11.0. Everytime i try to configure it with yast, a pop up window show me this message:
    terminate called after throwing an instance of 'std::logic_error'
    what (): basic_string::_S_construct NULL not valid
    Yast got signal 6 at YCP file printer/dialogs.ycp:2569
    /sbin/yast2: line 421: 7385 Aborted $ybindir/y2base $module "$@" "SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS



    that's what i read everytime from Yast. If I would to install manually the correct driver, another pop up window show me this message:
    package could not be installed
    Details:
    Subprocess failed. Error: RPM failed: error: Failed dependencies:
    libgdk-1.2.so.0 is needed by packagename
    libglib-1.2.so.0 is needed by packagename
    libgmodule-1.2.so.0 is needed by packagename
    libgtk-1.2.so.0 is needed by packagename
    libpng.so.3 is needed by packagename


    anyone can help me???pleaseeeeeee !!
    thanks anyway

    Marco

  2. #2
    halprof1 NNTP User

    Default Re: can't configure printer!!!

    Quote Originally Posted by macco_chicco View Post
    Hi everyone,
    i'm new both with linux and in this forum, and i'm having some problems configuring my printer epson stylus d88+ in openSUSE linux 11.0. Everytime i try to configure it with yast, a pop up window show me this message:
    terminate called after throwing an instance of 'std::logic_error'
    what (): basic_string::_S_construct NULL not valid
    Yast got signal 6 at YCP file printer/dialogs.ycp:2569
    /sbin/yast2: line 421: 7385 Aborted $ybindir/y2base $module "$@" "SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS



    that's what i read everytime from Yast. If I would to install manually the correct driver, another pop up window show me this message:
    package could not be installed
    Details:
    Subprocess failed. Error: RPM failed: error: Failed dependencies:
    libgdk-1.2.so.0 is needed by packagename
    libglib-1.2.so.0 is needed by packagename
    libgmodule-1.2.so.0 is needed by packagename
    libgtk-1.2.so.0 is needed by packagename
    libpng.so.3 is needed by packagename


    anyone can help me???pleaseeeeeee !!
    thanks anyway

    Marco
    Marco,

    I have the same problem at the "Printer Queue Edit Dialog" window. If I select any of the tabs other than "Printer Options" I get the first error message that you stated.

    At no point during the Yast printer install does it ask me for the printer type.

  3. #3
    halprof1 NNTP User

    Default Re: can't configure printer!!!

    Marco,

    I was able to get the printer working by using the "CUPS Manage Printing" application found under the "Utilities" group of the application browser. Be sure to use the root username and password when it prompts you for an account.

    I hope this works for you also.

    Hal

  4. #4
    macco_chicco NNTP User

    Default Re: can't configure printer!!!

    Quote Originally Posted by halprof1 View Post
    Marco,

    I was able to get the printer working by using the "CUPS Manage Printing" application found under the "Utilities" group of the application browser. Be sure to use the root username and password when it prompts you for an account.

    I hope this works for you also.

    Hal
    Well, maybe I'm really a newbie with linux, but I can't find even "utilities" under application browser. I've found cups manage printing, but in web interface.

  5. #5
    halprof1 NNTP User

    Default Re: can't configure printer!!!

    I should have told you I am using the Gnome desktop.

  6. #6
    macco_chicco NNTP User

    Default Re: can't configure printer!!!

    Quote Originally Posted by halprof1 View Post
    I should have told you I am using the Gnome desktop.
    don't worry. Btw, I've found a new list of drivers, and I' ve found a D88 driver (instead of mine D88+).
    Anyway, it seems working, so solved the problem finally. Thanks for your help.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30

    Default re: can't configure printer!!!

    Dear Developer,

    You may have to install the dependency:

    libgtk

    If that does not work:

    There are two printer configuration panels. One for Control Center GNOME, another for YAST. The YAST configuration panel for printer-, scanner- and graphics devices appear to be in redevelopment phase. The basic Control Center for GNOME and GTK should work without faults.

    Cheers.

  8. #8

    Default Re: can't configure printer!!!

    I always just open Firefox and go to http://localhost:631/ to configure my printers. That is CUPS built-in web-based interface.

  9. #9

    Default Re: can't configure printer!!!

    I got the same signal 6 error when trying to configure a networked HP 4000N printer.

  10. #10

    Default Re: can't configure printer!!!

    Quote Originally Posted by halprof1 View Post
    Marco,

    I was able to get the printer working by using the "CUPS Manage Printing" application found under the "Utilities" group of the application browser. Be sure to use the root username and password when it prompts you for an account.

    I hope this works for you also.

    Hal
    This actually worked for me. Thanks Hal!
    For clarification, you need to select the "More Applications..." button under the Recent Applications sled. In the Utilities section you should find "Manage Printing". This spawns a web interface to CUPS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •