Results 1 to 3 of 3

Thread: Amarok 1.4.9 and CVS version of libgpod on OpenSUSE 11

Hybrid View

  1. #1
    Rod_Hull NNTP User

    Default Amarok 1.4.9 and CVS version of libgpod on OpenSUSE 11

    I recently installed OpenSUSE 11 (moving from Ubuntu 8.04).

    I have Amarok 1.4.9 and have compiled the latest version of libgpod from CVS - I've renamed the old lib, and copied the newly compiled version into /usr/lib (all symlinks are correctly pointing to the new version).

    However, Amarok doesn't seem to be even using the new version, and I have even tried deleting libgpod.so.3.0.0 completely, rebooting and Amarok still manages to read and write to the iPod.

    Does anyone know why this is? Before on Ubuntu, the steps outlined above were all that was required to run Amarok against a new version of libgpod, but the build of Amarok in SUSE seems to work even when the libgpod library is removed?!

    Any ideas?

  2. #2
    Rod_Hull NNTP User

    Default Re: Amarok 1.4.9 and CVS version of libgpod on OpenSUSE 11

    I figured it out - I needed to copy the entire contents of /usr/local/lib after the build - not just the libgpod library...all working now

  3. #3

    Default Re: Amarok 1.4.9 and CVS version of libgpod on OpenSUSE 11

    That's the kind of thing openSUSE Build Service is good for.

    Create your home repository, "link" to the official libgpod package, change the .tar.bz2 file from the stable version to the CVS one and magically you (and everybody that needs it) will have an libgpod CVS RPM available. You don't even need to know how RPM files are created (even if always is something good to know).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •