Results 1 to 10 of 10

Thread: opensuse 11 compiz/gnome-system-monitor/terminal problem

  1. #1

    Default opensuse 11 compiz/gnome-system-monitor/terminal problem

    hello every body!
    it is my first time to use opensuse (use ubuntu before ),my pc is DELL xps m1530 ,i install opensuse 11 64 bit with gnome/KDE4 desktop session.
    i install the NVIDIA driver properly,the compiz work perfect.

    when i turn the compiz on ,opensuse works well on my computer expect :

    1 gnome-terminal resize problem: when i resize the window of gnome-terminal(other terminal as well),the system just hang for a second.
    2 gnome-system-nonitor problem:the time i open gnome-system-monitor ,system hang for a second too.

    i can not resolve those proble myself ,need helps.
    any one have same probles or know how to fix the problem
    please post below.
    appriciate for your help!

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    two questions:

    1) does it also happen when you don't use compiz?
    2) do you also have the issue when you stop the network service? (enter e.g. 'sudo rcnetwork stop' and try opening another terminal/system monitor)?

    Check /var/log/messages and output of dmesg for possible errors.

    Good luck,
    Wj
    Have a lot of fun!

  3. #3

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    I have try to stop the compiz ,after that everything works well.

    compiz enabled,network disabled, the proble also happen.

    but other gnome programs work well regardless of compiz.
    thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    Have you seen this : NVIDIA - openSUSE ?

    Could be these settings help for you card...
    Have a lot of fun!

  5. #5

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    Quote Originally Posted by Magic31 View Post
    Have you seen this : NVIDIA - openSUSE ?

    Could be these settings help for you card...
    thanks !
    i follow the artcle you mention :
    disable compositing with Option "Composite" "Disable" and restart your X server,applications now not freeze any longer
    i think is the compositing problems
    then Put it in the device section of my xorg.conf: Option "UseCompositeWrapper" "true" and enable compositing again,
    restart my x server.

    it seems the solution dose not work in my computer!

    what can i do about the problem??

    thanks

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    If I understand correctly just leave out the Option "UseCompositeWrapper" "true".
    Another option is to update to a newer driver if available. But upgrading your driver can give you more grief than happiness.

    The golden tip : if you have a working xorg.conf make at least 6 backups of it
    Have a lot of fun!

  7. #7
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    I have the same problem. And also selection rectangle on the desktop works extremly slow. It begins to work OK after restarting the compiz. I tried both of compiz versions: from the oss repo and from the X11GL one. Result is the same. Feature from the how-to mentioned abowe seems to shorten hanging time a bit.

    LG R500 laptop. Nvidia Geforce 8600M GS, openSUSE 11.0 i386, GNOME.

  8. #8
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    Browsing logs gave me nothing. Looks like there are no errors

  9. #9
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    It could be worth testing with different driver versions, the newest for the 8 series is v173.14.09:
    Linux Display Driver - x86

    It can be a tedious process to uninstall/reinstall. Make backups of your working configs to ease this.

    wishing you luck!
    Wj
    Have a lot of fun!

  10. #10
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    28

    Default Re: opensuse 11 compiz/gnome-system-monitor/terminal problem

    Well, there is such a problem we described above but actually it doesn't bugging me that much. That's OK to wait for a second So I'd better leave everything working like it does now instead of experimenting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •