Results 1 to 5 of 5

Thread: Mounting samba drive

  1. #1
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    46

    Default Mounting samba drive

    Im having no trouble accessing my samba drive (with the smbclient), but when I try to mount it to some folder (with given username/password) it gives this error:

    mount error 20 = Not a directory
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    mount //samba.address/harald /home/harald/samba -o user=username,password=password,uid=harald,gid=users

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Mounting samba drive

    Quote Originally Posted by harald_rombaut View Post
    Im having no trouble accessing my samba drive (with the smbclient), but when I try to mount it to some folder (with given username/password) it gives this error:

    mount error 20 = Not a directory
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    mount //samba.address/harald /home/harald/samba -o user=username,password=password,uid=harald,gid=users
    Wrong syntax Harald, try like this:

    mount -t cifs -o username=someone,password=something //samba.address/harald /home/harald/samba
    Swerdna
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    46

    Default Re: Mounting samba drive

    Doesnt make a difference. -t cifs isnt necessary because the mount command guesses its cifs (because of // in front of the address). The -o flag can be added before or after the mount dir.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Mounting samba drive

    Quote Originally Posted by harald_rombaut View Post
    Doesnt make a difference. -t cifs isnt necessary because the mount command guesses its cifs (because of // in front of the address). The -o flag can be added before or after the mount dir.
    Quite true, I missed that. Have you got cifs-mount installed (suppose so).

    have a look at post #6 over here:
    Mount.cifs Fails With "mount Error 20 = Not A Directory" - openSUSE Forums
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    46

    Default Re: Mounting samba drive

    this fixed it for me

    thx for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •