Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Realplay only play audion, can not play video files

  1. #1
    demo NNTP User

    Default Realplay only play audion, can not play video files

    anyone can help with this? I tried Realplay 10 and 11. Both don't work.

    As long as I click an rm/rmvb video file, the player lanches, but close
    immediately.

    while Mplayer and VLC are working properly with other video type.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realplay only play audion, can not play video files

    Quote Originally Posted by demo View Post
    anyone can help with this? I tried Realplay 10 and 11. Both don't work. As long as I click an rm/rmvb video file, the player lanches, but close immediately. while Mplayer and VLC are working properly with other video type.
    Try installing from packman w32codec-all.
    PackMan :: Package details for Win32-Codecs

  3. #3

    Default Re: Realplay only play audion, can not play video files

    I have the problem as well, and I have libxine1, w32codec-all, and libxine1-w32dll installed. The error I get in Kaffeine is:

    xine message - Kaffeine Player
    A problem occur while loading a library or a decdoder: drvc.so
    (grammar error in the original)

  4. #4
    Join Date
    Jul 2008
    Location
    /dev/null
    Posts
    37

    Default Re: Realplay only play audion, can not play video files

    Do a one click install from here
    Then use Kaffeine/Real Player

  5. #5

    Default Re: Realplay only play audion, can not play video files

    Tried that, it didn't help either. I am using a 64-bit install if that makes any difference, but I have the 32-bit xine packages installed. I am getting this error from mplayer when I try to play a file:

    Code:
    ==========================================================================
    Opening video decoder: [realvid] RealVideo decoder                        
    Error: /usr/lib64/RealPlayer10/codecs/drvc.so: cannot open shared object file: No such file or directory
    ERROR: Could not open required DirectShow codec drvc.so.                                                
    Read the RealVideo section of the DOCS!                                                                 
    VDecoder init failed :(                                                                                 
    Opening video decoder: [realvid] RealVideo decoder                                                      
    ERROR: Could not open required DirectShow codec drvc.dll.                                               
    Read the RealVideo section of the DOCS!                                                                 
    VDecoder init failed :(                                                                                 
    Opening video decoder: [realvid] RealVideo decoder                                                      
    Error: /usr/lib64/RealPlayer10/codecs/drv4.so.6.0: cannot open shared object file: No such file or directory
    ERROR: Could not open required DirectShow codec drv4.so.6.0.                                                
    Read the RealVideo section of the DOCS!                                                                     
    VDecoder init failed :(                                                                                     
    Opening video decoder: [realvid] RealVideo decoder                                                          
    ERROR: Could not open required DirectShow codec drv43260.dll.                                               
    Read the RealVideo section of the DOCS!                                                                     
    VDecoder init failed :(                                                                                     
    Opening video decoder: [realvid] RealVideo decoder                                                          
    Error: /usr/lib64/RealPlayer10/codecs/drvc.bundle/Contents/MacOS/drvc: cannot open shared object file: No such file or directory
    ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.                                                
    Read the RealVideo section of the DOCS!
    VDecoder init failed :(
    Cannot find codec matching selected -vo and video format 0x30345652.
    Read DOCS/HTML/en/codecs.html!
    ==========================================================================
    ==========================================================================
    There is no /usr/lib64/RealPlayer10/ directory. There is a /usr/lib/RealPlayer10/ directory, though. There is also no /usr/lib64/codecs/ directory, only /usr/lib/codecs/. This might explain why xine is having problems with drvc.so

  6. #6

    Default Solved... at least in my computer

    I was haviing the same problem. Other players only played audio and realplayer just closed up when trying to open the video with .rmvb extension.

    First open Realplayer, go to Tools, Preferences, Hardware, and deselect "Use XVideo". Now realplayer plays RMVB.

    Hope it works for you.

    Opensuse 11.0 x64
    Dell Inspiron 1525
    Intel core2 duo 1,83 MHz
    2 GB RAM
    with the the codecs pack installed
    and Realplayer 10.0.9.809 (gold)

    Rodrigo

    PD: I'm using realplayer in spanish so I hope my translation was good.

  7. #7

    Default Re: Realplay only play audion, can not play video files

    I tried that, but it doesn't make any difference for playing rmvb files in mplayer or xine.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realplay only play audion, can not play video files

    Quote Originally Posted by TheBlackCat View Post
    I have the problem as well, and I have libxine1, w32codec-all, and libxine1-w32dll installed.
    w32codec-all is not the same as libxine1-w32dll

  9. #9

    Default Re: Realplay only play audion, can not play video files

    I know that, that is why I have them both installed.

  10. #10

    Default Re: Realplay only play audion, can not play video files

    I am wondering, is it possible the problem might be due to there not being a 32-bit compatibility package for the packman version of Xine? When I try to install libxine1-w32dll, it automatically installs the 32-bit compatibility package from the repo-oss version of xine (xine-lib-32bit). It won't install without it. It appears it requires a 32-bit xine, either a pure 32-bit or a 32-bit compatibility package. However, the 64-bit version of xine I am using is the packman one (libxine1). I wonder if there might be problems using libxine1 from packman with xine-lib-32bit from repo-oss. Packman does not appear to offer a 32-bit compatibility package (I assume it would be something like libxine1-32bit).

    However, I cannot test this theory. libxine1-w32dll requires libxine1 (the packman version). So there does not appear to be a way to have libxine1-w32dll with both 64-bit and 32-bit xine versions being provided by the same vendor. I cannot use the repo-oss 64-bit version (xine-lib) since libxine1-w32dll won't accept it, but I cannot use the packman 32-bit compatibility package since it does not exist. I have to use both libxine1 and xine-lib-32bit

    If I try to switch to the 32-bit version of libxine1 Yast2 freezes, I assume because there are so many other packages that have to change architecture as a result.

    From what I have read, there are similar issues with mplayer. It sounds like the 64-bit version of mplayer cannot use 32-bit codecs. However, I cannot find a 32-bit compatibility package for mplayer at all (I assume it would be mplayer-32bit). Once again, trying to change mplayer to the 32-bit version freezes Yast because of the large number of other packages that also have to change to support this.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •